cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

277
Views
5
Helpful
3
Replies
Beginner

2 ip ranges 1 Switch

Hi

im new here and relatively new to networks i have a job coming up that requires a site to have 2 ip ranges for cctv cameras.

my question is:

will their be a conflict if you have 2 ip ranges running through one switch?

i will have 2 servers each using a different ip range each with x amount of cameras for example

server 1 192.168.1.x

server 2 193.168.2.x

if I run both these ranges through the same SG300 switch will they cause issues to one another.

3 REPLIES 3
VIP Advisor

Re: 2 ip ranges 1 Switch

 

You can run both the IP range from same switch,

by creating 2 VLAN for example below : and allocate port to respected VLAN for them to work.

 

VLAN 10 - 192.168.1.x

VLAN 11 - 192.168.2.x

 

 

BB

BB
*** Rate All Helpful Responses ***
Beginner

Re: 2 ip ranges 1 Switch

Hi

Thanks for the quick reply, would it definitely cause conflicts if VLANS were not used? I thought that would be the case needing to create “VLANS” but wanted to clarify that. How would that work with regards to viewing both servers from the same viewing PC around the site I know you can give pc’s 2 ip addresses but would that still work if VLANS were created?

 

Thanks

Highlighted
Contributor

Re: 2 ip ranges 1 Switch

Timo

 

since you want 2 separate networks, you SHOULD use VLANs to create the logical separation.  without them, you would have to create a network that contained both subnets (BAD IDEA, large broadcast domain).  As for viewing the cameras from one PC, then you just need to advertise the route.  (the vlan interfaces will act as a gateway and act as "router on a stick".  You would then restrict access with an ACL down the line, hopefully a router or ASA

example

 

vlan 2

name CAMERA_NET1

 

VLAN 3

name CAMERA_VLAN2

 

interface vlan 2

description SVI for camera Network 1

ip address 172.16.1.1 255.255.255.0

 

interface vlan 3

description SVI for camera Network 1

ip address 172.16.2.1 255.255.255.0

 

 

interface range g1/1-5

switchport mode access

switchport access vlan 2

switchport nonegotiate

 

interface g1/6-10

switchport mode access

switchport access vlan 3

switchport nonegotiate

 

 

HTH 

 

Vince

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards