03-07-2016 03:26 PM - edited 03-08-2019 04:51 AM
Hello,
I'm trying to configure a 2509 as an access server for use in CCNA labs. I've got it online on one subnet but need to be able to access it from others. At this point I can't ping it. I'm assuming I don't need to add a default route in the device because it's not connected to another route but I'm not sure. Can someone tell me where I'm off?
Building configuration...
Current configuration:
!
version 11.2
no service password-encryption
no service udp-small-servers
no service tcp-small-servers
!
hostname AS-2509
!
enable secret 5 $1$2uuQ$0.tAkvaLVq8OgBK3vXGJf.
!
username lab password 0 HWDLab
ip host 1841-1 2001 1.1.1.1
ip host 1841-2 2002 1.1.1.1
ip host 1841-3 2003 1.1.1.1
ip host 1841-4 2004 1.1.1.1
ip host 3750-1 2005 1.1.1.1
ip host 3560-1 2006 1.1.1.1
ip host 2960-1 2007 1.1.1.1
ip host 2960-2 2008 1.1.1.1
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0
ip address 10.159.53.14 255.255.255.0
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
shutdown
!
ip default-gateway 10.159.53.1
no ip classless
!
line con 0
logging synchronous
transport input none
line 1 8
no exec
exec-timeout 0 0
transport input all
line aux 0
line vty 0 4
password 2Letmein2
logging synchronous
login
!
end
Solved! Go to Solution.
03-07-2016 04:24 PM
Hi,
As you are running multiple ip interfaces you
should enable ip routing and use a default route instead of the
default-gateway command
!
no ip default-gateway 10.159.53.1
!
ip routing
ip route 0.0.0.0 0.0.0.0 10.159.53.1
!
Also what ever 10.159.53.1 device is,
it will need a route to your loopback 1.1.1.1 via
your ethernet 10.159.53.14
HTH
Regards
Alex
03-07-2016 03:27 PM
What is the other subnet, what what are the IP addresses on that device which is doing the routing?
03-07-2016 04:24 PM
Hi,
As you are running multiple ip interfaces you
should enable ip routing and use a default route instead of the
default-gateway command
!
no ip default-gateway 10.159.53.1
!
ip routing
ip route 0.0.0.0 0.0.0.0 10.159.53.1
!
Also what ever 10.159.53.1 device is,
it will need a route to your loopback 1.1.1.1 via
your ethernet 10.159.53.14
HTH
Regards
Alex
03-08-2016 06:45 AM
Thanks! It was this plus it had the no ip classless command in there.
03-08-2016 07:49 AM
Brian,
One comment although your issue has been solved: Your IOS version is 11.2. That is surprising to me. Such an old IOS is usually booted on these routers from ROM and is an extremely limited IOS that is supposed to be only used for disaster recovery - usually when the primary IOS in the FLASH has been erased or is about to be upgraded.
Can you please check the value of your configuration register? If it is set to 0x2101 or 0x2141 then it directly commands your router to boot this limited ROM-based IOS. The proper setting should be either 0x2102 (normal value) or 0x2142 (normal value with ignoring the stored configuration).
Best regards,
Peter
03-15-2016 02:32 PM
Yeah. Just an old IOS. Config register is 0x2102. Without smartnet that's how it'll stay I suppose.
03-07-2016 06:11 PM
Routing is being done at 10.159.53.1 which is an L3 switch. Access from other subnet 10.159.52.x.
As far as multiple interfaces, most of the config is from a video I saw about how to set up the 2509 as an access server using the terminal connection as your main means of access.
The end goal is to either telnet into the 2509 and then access the connected serial interfaces or simply telnet on different ports to each individual serial interface (If that's possible). This won't do any routing. Just Access Server. I can add the default route and see if that works better. Wasn't sure what would be best and saw the gateway used on another config for this device.
Hopefully that clarifies. Thanks,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide