11-08-2010 06:10 PM - edited 03-06-2019 01:57 PM
I have a quick quesiton here and not sure if I'm doing this right but my corporate network folks gave me 2 ports on the core switch now I have
2 server on 2 different subnets which is fine. the issue comes along is that my corporate network will not allocate my anymore switch ports on the core switch they told me if I wanted to add more devices I would need an intermidiate switch. So the question is the 2 servers each requires a tape drive, has a management console and then your normal NIC card so each server will require 3 connection. Do I need to buy 2 seperate 2960 switches or can I
use one 2960 and configure 2 vlans on them and use it as a pass through switch to the core switch. I hope this makes sense....thank you in advance
Solved! Go to Solution.
11-09-2010 06:40 AM
You can do it two ways:
1. Create a trunk from your 2960 to the core switch (If the network folks will permit that)
you just create the layer 2 vlans and assign ports to it.:
Example:
From Config mode:
vlan 10
vlan 20
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
!
interface FastEthernet0/5
switchport access vlan 20
!
interface FastEthernet0/6
switchport access vlan 20
!
interface FastEthernet 0/24
description Uplink to Core Switch
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20
! {port will try to create trunk by default, but you can explicitly tell it to attempt a trunk. This all depends on how the core switch's ports are configured}
switchport mode dynamic desirable
!
interface vlan10
description For Managment of the 2960 ONLY
ip address 192.168.10.250 255.255.255.0
!
ip default-gateway
2. If the network folks won't let you create a trunk for whatever reason, You can do similar to the number 1, but instead, create one additional port in each vlan and use both of the access ports assigned by your network guys.
Example:
From Config mode:
vlan 10
vlan 20
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
!
interface FastEthernet0/5
switchport access vlan 20
!
interface FastEthernet0/6
switchport access vlan 20
!
interface FastEthernet0/7
description Connection to Core VLAN 10
switchport mode access
switchport access vlan 10
!
interface FastEthernet0/8
description Connection to Core VLAN 20
switchport mode access
switchport access vlan 20
!
interface vlan10
description For Managment of the 2960 ONLY
ip address 192.168.10.250 255.255.255.0
!
ip default-gateway
11-09-2010 07:24 AM
Also, have a look at the config guide for the 2960 series switches:
HTH
Reza
11-08-2010 07:08 PM
All you need is one 2960. You can then connect the 2960 to the core switch and create multiple VLANs and have the default gateway for each subnet/vlan be you core switch.
HTH
Reza
11-09-2010 05:54 AM
Thank you for the response but can you please give me an example? So if I understand you lets say I have created 2 vlans
192.168.10.0/24 vlan10 and 192.168.20.0/24 vlan 20 so then from what you are saying is that I can use one 2960 and
create a trunk port to the core switch and have the default gateway for each vlan so if I create a trunk port on
say g0/1 and have a default gateway of 192.168.10.1 then I would be able to route both vlan 10 and 20 out that
gateway?
11-09-2010 06:40 AM
You can do it two ways:
1. Create a trunk from your 2960 to the core switch (If the network folks will permit that)
you just create the layer 2 vlans and assign ports to it.:
Example:
From Config mode:
vlan 10
vlan 20
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
!
interface FastEthernet0/5
switchport access vlan 20
!
interface FastEthernet0/6
switchport access vlan 20
!
interface FastEthernet 0/24
description Uplink to Core Switch
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10,20
! {port will try to create trunk by default, but you can explicitly tell it to attempt a trunk. This all depends on how the core switch's ports are configured}
switchport mode dynamic desirable
!
interface vlan10
description For Managment of the 2960 ONLY
ip address 192.168.10.250 255.255.255.0
!
ip default-gateway
2. If the network folks won't let you create a trunk for whatever reason, You can do similar to the number 1, but instead, create one additional port in each vlan and use both of the access ports assigned by your network guys.
Example:
From Config mode:
vlan 10
vlan 20
!
interface FastEthernet0/1
switchport access vlan 10
!
interface FastEthernet0/2
switchport access vlan 10
!
interface FastEthernet0/3
switchport access vlan 10
!
interface FastEthernet0/4
switchport access vlan 20
!
interface FastEthernet0/5
switchport access vlan 20
!
interface FastEthernet0/6
switchport access vlan 20
!
interface FastEthernet0/7
description Connection to Core VLAN 10
switchport mode access
switchport access vlan 10
!
interface FastEthernet0/8
description Connection to Core VLAN 20
switchport mode access
switchport access vlan 20
!
interface vlan10
description For Managment of the 2960 ONLY
ip address 192.168.10.250 255.255.255.0
!
ip default-gateway
11-09-2010 07:08 AM
thank you will have that a go and see what happens
11-09-2010 07:24 AM
Also, have a look at the config guide for the 2960 series switches:
HTH
Reza
11-12-2010 08:04 AM
Sorry for the delay I'm trying to get together with our coporate network person so we can test but so far no luck
12-17-2010 07:15 AM
Sorry for the late response but we finally was able to test and all is good, they wouldn't let us do a trunk port so had to go with the second option
Thank you for that!!!
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide