cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
394
Views
0
Helpful
5
Replies
Highlighted
Beginner

3845 vlan / trunk to 2960S

simple dot1q trunk but has me stumped, GE0/0 on the 3850 2 sub-int vlan10 vlan11 to GE1/0/1 switch port mode trunk. on the 3850 vlan interfaces protocol won't come up, if i switch to NM-16ESW-1GIG with switchport mode trunk protocol comes up, i have also tried channel-group but will not let me assign it if i set switchport mode trunk on the port-group

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
VIP Advisor

Re: 3845 vlan / trunk to 2960S

Hi

Could you please share the configuration?

View solution in original post

5 REPLIES 5
Highlighted
VIP Advisor

Re: 3845 vlan / trunk to 2960S

Hi

Could you please share the configuration?

View solution in original post

Beginner

Re: 3845 vlan / trunk to 2960S

no real configs at this point its a new setup that i have wiped out a couple of times over for what its worth if it helps

 

3845

Interface GigabitEthernet0/0

no ip address

Interface GigabitEthernet0/0.10

encapsulation dot1Q 10

no ip address

!

Interface GigabitEthernet0/0.11

encapsulation dot1Q 11

no ip address

!

interface vlan10

ip address 10.0.10.1 255.255.255.0

!

interface vlan11

ip address 10.0.11.1 255.255.255.0

 

(NM MODULE)

interface GigabitEthernet1/0

switchport mode trunk

 

2960

interface GigabitEthernet1/0/1

switchport mode trunk

 

interface vlan10

ip address 10.0.10.252 255.255.255.0

 

interface vlan11

ip address 10.0.11.252 255.255.255.0

Highlighted
VIP Advisor

Re: 3845 vlan / trunk to 2960S

Thank you

There are 2 ways to make it works, if you are using sub-interfaces you will not use the SVI on the router and viceversa. 

Basically the NM-16ESW-1GIG is an ether switch module. So you could configure like:

 

(NM MODULE)

vlan 10 

vlan 11

 

interface GigabitEthernet1/0

description TO-SWITCH
switchport encapsulation dot1q  

switchport mode trunk
no shutdwon

 

The configuration below is required if this router will be the gateway for the VLANs. 

 

interface vlan10

ip address 10.0.10.1 255.255.255.0

!

interface vlan11

ip address 10.0.11.1 255.255.255.0

 

 

The sub-interfaces could be removed if you are going to use this scheme.

 

:-)

Highlighted
Beginner

Re: 3845 vlan / trunk to 2960S

i have a need to carry the trunks across both the the etherswitch modules and the SVI manly to leverage the GB ports as uplinks to a couple of departments, currently i have 2 modules installed i could add 2 more but don't have a need to add the extra module if i could get the SVI port to play nice 

Highlighted
VIP Advisor

Re: 3845 vlan / trunk to 2960S

Hi

That is correct, you don't need extra modules, actually one port can be enough to transport all the VLANs, do you have picture or diagram how you are going to connect this router?

CreatePlease to create content
Content for Community-Ad