09-12-2011 01:08 PM - edited 03-07-2019 02:10 AM
I am working on configuring connection betwen Cisco 6509-E and Nexus 7000 using 2 xenpaks.
Nexus 7000 is routing and 6509-E is switching.
6509-E has a WS-SUP32-10GE-3B supervisor.
I have connect 2 xenpaks and configured as above:
interface TenGigabitEthernet5/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface TenGigabitEthernet5/2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
Router#show int ten 5/1 status
Port Name Status Vlan Duplex Speede
Te5/1 connected trunk full 10GR
Router#show int ten 5/2 status
Port Name Status Vlan Duplex Speede
Te5/2 connected trunk full 10GR
Router#show int trunk
Port Mode Encapsulation Status Native n
Te5/1 on 802.1q trunking 1
Te5/2 on 802.1q trunking 1
Port Vlans allowed on trunk
Te5/1 1-4094
Te5/2 1-4094
Port Vlans allowed and active in management domain
Te5/1 1-7,9-10,13-14,20-21,23,30,105-107
Te5/2 1-7,9-10,13-14,20-21,23,30,105-107
Port Vlans in spanning tree forwarding state and not pd
Te5/1 1-7,9-10,13-14,20-21,23,30,105-107
Te5/2 1-7,9-10,13-14,20-21,23,30,105-107
On the other side (Nexus 7000) I have done the following configuration:
interface port-channel20
description *** WC2 (XENPAK) <--> 7000 (SPF) ***
switchport mode trunk
interface Ethernet1/1
description *** WC2 (XENPAK-5/1) <--> 7000 (SPF-eth 1/1) ***
switchport mode trunk
channel-group 20
no shutdown
interface Ethernet1/2
description *** WC2 (XENPAK-5/2) <--> 7000 (SPF-eth 1/2) ***
switchport mode trunk
channel-group 20
no shutdown
Smale# show port-channel summary
Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)
M - Not in use. Min-links not met
--------------------------------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
--------------------------------------------------------------------------------
10 Po10(SU) Eth NONE Eth1/3(P)
20 Po20(SU) Eth NONE Eth1/1(P) Eth1/2(P)
113 Po113(SU) Eth NONE Eth1/10(P)
Smale#
Smale# show int trunk
--------------------------------------------------------------------------------
Port Native Status Port
Vlan Channel
--------------------------------------------------------------------------------
Eth1/1 1 trnk-bndl Po20
Eth1/2 1 trnk-bndl Po20
Eth2/48 1 trunking --
Po20 1 trunking --
--------------------------------------------------------------------------------
Port Vlans Allowed on Trunk
--------------------------------------------------------------------------------
Eth1/1 1-3967,4048-4093
Eth1/2 1-3967,4048-4093
Eth2/48 1-3967,4048-4093
Po20 1-3967,4048-4093
--------------------------------------------------------------------------------
Port Vlans Err-disabled on Trunk
--------------------------------------------------------------------------------
Eth1/1 none
Eth1/2 none
Eth2/48 none
Po20 none
--------------------------------------------------------------------------------
Port STP Forwarding
--------------------------------------------------------------------------------
Eth1/1 none
Eth1/2 none
Eth2/48 none
Po20 1-7,10-11,13-14,20-21,23,30,105-107,110,168,192,254,931
--------------------------------------------------------------------------------
Port Vlans in spanning tree forwarding state and not pruned
--------------------------------------------------------------------------------
Eth1/1 --
Eth1/2 --
Eth2/48 --
Po20 --
--------------------------------------------------------------------------------
Port Vlans Forwarding on FabricPath
--------------------------------------------------------------------------------
Eth1/1 none
Eth1/2 none
Eth2/48 none
Po20 none
Smale#
I have 2 questions:
1. Is it necessary (recommended) to configure a port-channel on 6509-E for xenpaks ?
2. I would like to define an ip address to 6509-E in order to telnet it from my administrative station. Can I set this address to
interface TenGigabitEthernet5/1 ?
Thanks in advance
Rosa
Solved! Go to Solution.
09-12-2011 03:21 PM
Rosa,
1. Is it necessary (recommended) to configure a port-channel on 6509-E for xenpaks ?
You use port-channel when you are trying to bundle multiple physical links together (link aggregation or 803.ad)
In order for it to work correctly, you need to cinfigure it on both Nexus and the 6500
2. I would like to define an ip address to 6509-E in order to telnet it from my administrative station. Can I set this address to interface TenGigabitEthernet5/1 ?
If a physical port part of an Etherchannel, then you have to make the Etherchannael layer-3 and assign the IP to it. If it is not then you can assign the IP to the physical interface.
HTH
09-12-2011 03:21 PM
Rosa,
1. Is it necessary (recommended) to configure a port-channel on 6509-E for xenpaks ?
You use port-channel when you are trying to bundle multiple physical links together (link aggregation or 803.ad)
In order for it to work correctly, you need to cinfigure it on both Nexus and the 6500
2. I would like to define an ip address to 6509-E in order to telnet it from my administrative station. Can I set this address to interface TenGigabitEthernet5/1 ?
If a physical port part of an Etherchannel, then you have to make the Etherchannael layer-3 and assign the IP to it. If it is not then you can assign the IP to the physical interface.
HTH
09-13-2011 09:09 AM
Hi Reza, thanks for your answer.
I have configured Cisco 6509-E port-channel but although both sides are up and connected I can not ping a 6509 host from 7000 .
Smale# ping 147.65.4.100
PING 147.65.4.100 (147.65.4.100): 56 data bytes
Request 0 timed out
Request 1 timed out
Request 2 timed out
^C
--- 147.65.4.100 ping statistics ---
4 packets transmitted, 0 packets received, 100.00% packet loss
Smale#
*******************************NEXUS 7000************************************
interface port-channel20
description *** 6509 (XENPAK) <--> 7000 (SPF) ***
switchport mode trunk
interface Ethernet1/1
description *** 6509 (XENPAK-5/1) <--> 7000 (SPF-eth 1/1) ***
switchport mode trunk
channel-group 20
no shutdown
interface Ethernet1/2
description *** 6509 (XENPAK-5/2) <--> 7000 (SPF-eth 1/2) ***
switchport mode trunk
channel-group 20
no shutdown
Smale# sh int port-channel 20 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Po20 *** 6509 (XENPAK) < connected trunk full 10G --
Smale# sh int eth 1/1 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/1 *** 6509 (XENPAK-5/ connected trunk full 10G 10Gbase-SR
Smale# sh int eth 1/2 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/2 *** 6509 (XENPAK-5/ connected trunk full 10G 10Gbase-SR
Smale#
*******************************Cisco 6509************************************
interface Port-channel10
switchport
switchport mode dot1q-tunnel
spanning-tree bpdufilter enable
!
interface TenGigabitEthernet5/1
switchport
switchport mode dot1q-tunnel
no cdp enable
channel-group 10 mode on
!
interface TenGigabitEthernet5/2
switchport
switchport mode dot1q-tunnel
no cdp enable
channel-group 10 mode on
Router#sho int port-channel 10 status
Port Name Status Vlan Duplex Speed Type
Po10 connected 1 a-full 10G
Router#show int ten 5/1 status
Port Name Status Vlan Duplex Speed Type
Te5/1 connected 1 full 10G 10Gbase-SR
Router#show int ten 5/2 status
Port Name Status Vlan Duplex Speed Type
Te5/2 connected 1 full 10G 10Gbase-SR
Router#
09-13-2011 01:59 PM
It works !
***********************Nexus 7000******************************
interface port-channel20
description *** WC2 (XENPAK) <--> 7000 (SPF) ***
switchport mode trunk
interface Ethernet1/1
description *** WC2 (XENPAK-5/1) <--> 7000 (SPF-eth 1/1) ***
no cdp enable
switchport mode trunk
channel-group 20
no shutdown
interface Ethernet1/2
description *** WC2 (XENPAK-5/2) <--> 7000 (SPF-eth 1/2) ***
no cdp enable
switchport mode trunk
channel-group 20
no shutdown
Smale# sh int port-channel 20 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Po20 *** WC2 (XENPAK) < connected trunk full 10G --
Smale# show int eth 1/2 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/2 *** WC2 (XENPAK-5/ connected trunk full 10G 10Gbase-SR
Smale# show int eth 1/1 status
--------------------------------------------------------------------------------
Port Name Status Vlan Duplex Speed Type
--------------------------------------------------------------------------------
Eth1/1 *** WC2 (XENPAK-5/ connected trunk full 10G 10Gbase-SR
Smale#
***********************Cat 6509-E******************************
interface Port-channel100
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface TenGigabitEthernet5/1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 100 mode desirable
!
interface TenGigabitEthernet5/2
switchport
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide