Showing results for 
Search instead for 
Did you mean: 

891W ISR: Can't access internal AP


Hello.  I have an 891W router that requires a firmware update to fix a bug wth the internal AP where all you get when accessing it via the CP Express ("Launch Wireless Application", which is  just opening another web browser to your AP) is an Enter button.  This issue seems to be common so I found a thread, though for the 881W (but same process) where the fix is to update the AP's firmware. 

So I downloaded ap801-rcvk9w8-tar.124-21a.JY.tar from, set it up in my tftp server, and at the console ran the following from the router:

Router#service-module wlan-ap 0 session <enter>

This brings me to the AP.  

I then type in:

InternalAP#archive download-sw /force-reload /overwrite tftp:// <enter>

It seems to go through the process of re-imaging the fw but the end result now after it is done is that I cannot access the ap at all and the hostname has been screwed up.  So now when I go to the AP (via Router#service-module wlan-ap 0 session <enter>), this is what I see:


If I type "enable", I get no username prompt but I do get a password prompt, however my pw no longer works.  Also the IP address of the AP ( is no longe rpingable. 

I did save the log of the console session for the (failed??) firmware upgrade process - the only odd thing I recall was that it seemed like it was trying to enter part of the update process commands but instead the router was interpreting them as a DNS lookup or something.  Kind of stupid process it seems but anyway I am quite lost.  Don't know what it'ssuch a challenge to update firmware.

Can anybody assist?  I am not a n experienced IOS tech so any commands that need to be run please be specific, thank you kindly. 


Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend
So I downloaded ap801-rcvk9w8-tar.124-21a.JY.tar from

That's not right.  This firmware is for a controller-based WAP.  You need to download the IOS that has the "w7" in the filename instead of the "w8".

Post the config of the router.  There's a line somewhere there that dictates what IOS the WAP has to reboot into, wherether it's autonomous or unified (controller-based).

Thanks leolaohoo for replying.  Sorry for my poor orientation of the picture, but here's the screenshot of the page where I downloaded the file.  If this isn't the right file then somebdy at Cisco needs to fix how they are posting firmwares as this one was found by going to Support > Downloads, typing in "891W" and selecting the AP IOS image from there.  Now I'm worried there will be no way to re-flash the image since I can no longer get into the router's AP in priviledged Exec. 

About posting the config, I did a show run and the result was some 15+ console screen pages....was there anything in particular I should grab out of that or did you want the entire thing posted?  I'd have to parse it a bit and remove the cyrpto sections and other security stuff though.  If it helps any, I have only used CP Express 2.5 to config this router and only the options within there.  No routes or other stuff configured, in fact I haven't even plugged in a wan cable (although I do have th wan port set with addressing.  If you still prefer, I can put the whole config in here just let me know. 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

You're right.  I can't find the autonomous IOS image of the AP801 (AP801 is the model number of the imbedded WAP inside the 890 router).

On the router, please enter the following command "sh run | i unified".

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

Found the command.

In configuration mode of the router, enter the command "service-module wlan-ap 0 bootimage autonomous" and a follow-up of "service-module wlan-ap 0 reload"

Try either one of these two links:


Hi again.  In response to your first post, when I ran that sh run command specified, nothing came back (just went to the command input line again).  Instead if I did "sh run | include autonomous and this came back with one line, reading "service-module wlanap 0 autonomous"

For your second post, I've got the links open and they'll be very useful when the time comes to configure a working AP, but I think since the AP firmware itself is flashed with the wrong iage there must be a way to re-flash it? I tried typing in those two service-module commands you provided but the first one was not an option (there is no option for service-module wlan-ap 0 autonomous).  I did do the Reload one and told it not to save config but noting changed. 

In either case I think I need to obtain the correct image, then if it's possible, re-flash the AP.  Any help is appreciated.  I'm kind of wiped out this weekend so am not really thinking clearly on things, thought I'd Google for a quick answer on how to do this but there's really not much out there in my 2 minute search.  I'll re-visit tomorrow but meanwhile if you see this post please feel free to offer any info, I'd appreciate it. 

Thank you again. 

Hi leolaohoo,

I ended up contacting the TAC to ask about the correct image file.  Angel there ended up Webexing into the system and we stepped through the process of updating the firmware to the proper k9w7 image.  The AP is now accessible via the web-interface.  Sure enough as you said the AP was not in automomous mode but it appeared to be someting that could only be fixed by havintg the right image, as opposed to changing config.  I don't know, this stuff is new to me so perhaps I'm not even relaying the information correctly.  But the issue is now resolved.  I showed Angel where I got the original image from and hopefully it'll be fixed on the website, or, people like me just need to know that a LW AP is one that is not autonomous thus, I should not apply firmware for LW AP's.  This stuff is not for the non-Cisco tech that is for sure.  

I should also add since often these thread are found via search engine, that the filename I ended up using was ap801-k9w7-tar.124-10b.JDA3.tar

Nothing I more annoying that finding a thread where your problem was solved by somebody else and they don't post the answer. 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend


Huh what? I did a follow-up message to mention what the filename was that I had been provided by Angel at the TAC to get th eproper image installed. 

You wouldn't by chance have that file handy would you, or at least a link to it? I accidentaly erased the flash of my 891W's wireless. Now it's in a rommon like state. It only says ap:

I'm going to have to tftp the file back to it.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: