cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

A core switch CANNOT see a WS-C2960S-48TS-S when i do show cdp neighbor.

Jacob Gwangwa
Beginner
Beginner

Hi there.

I'm having a strange issue here. I just installed a WS-C2960S-48TS-S and connected it to the core switch WS-C6509-V-E.

CDP is enabled on both devices. When i do show cdp neighbor on my WS-C6509-V-E i cannot see the WS-C2960S-48TS-S in my neighbor table.

But on the WS-C2960S-48TS-S, when i do show cdp neighbor i can see the WS-C6509-V-E.

Note everything works fine its just that i'm worried as to why my WS-C6509-V-E cant see the WS-C2960S-48TS-S as its neighbor.

What i've tried thus far.....

on the interface level for both device cdp is enable and also in the global.

Please help me resolve this issue..

I would like to thank you in anticipation of your urgernt response

Regards,

Jacob

18 REPLIES 18

Alessio Andreoli
Contributor
Contributor

Hi Jacob,

i would tell you to check if the native vlan is the same and if the negotiation resulted in full-duplex. If you could post the interfaces which are connected, this would be great. Did you test the cable?

test cable-diagnostics tdr

google for it and you will find sme post from NetPro (this forum) explaining exactly how to do it. From Joseph or Reza if i am not wrong.

For sake of testing , a show interface switchport could help too.

Hope this helps

Alessio

Hi Alessio

Thank you for your response.

From the 2960 see results below;

avrb-south-asw-8#sh int g0/49 status

Port      Name               Status       Vlan       Duplex  Speed Type
Gi0/49    ***CVSS1-JRO connected    trunk      a-full a-1000 1000BaseSX SFP
avrb-south-asw-8#sh cdp n
avrb-south-asw-8#sh cdp neighbors de
avrb-south-asw-8#sh cdp neighbors detail | in CVSS1-JRO
Device ID: CVSS1-JRO
avrb-south-asw-8#sh cdp neighbors detail                     
-------------------------
Device ID: CVSS1-JRO
Entry address(es):
  IP address: removed Platform: cisco WS-C6509-V-E,  Capabilities: Router Switch IGMP
Interface: GigabitEthernet0/49,  Port ID (outgoing port): GigabitEthernet1/2/27
Holdtime : 124 sec

Version :
Cisco IOS Software, s72033_rp Software (s72033_rp-ADVIPSERVICESK9_WAN-VM), Version 12.2(33)SXI2a, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2009 by Cisco Systems, Inc.
Compiled Tue 01-Sep-09 20:22 by prod_rel_team

advertisement version: 2
VTP Management Domain: ''
Native VLAN: 1
Duplex: full
Management address(es):
  IP address: removed

avrb-south-asw-8#

From the 6509 see results below;

CVSS1-JRO#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,
                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
avrb-south-asw-9 Gig 2/2/5         133             R S I  WS-C4507R Gig 3/2
avrb-south-asw-9 Gig 1/2/24        130             R S I  WS-C4507R Gig 3/1
avrb-south-asw-6 Gig 2/2/6         172              S I   WS-C2960G Gig 0/48
avrb-south-asw-6 Gig 1/2/6         166              S I   WS-C2960G Gig 0/47
avrb-north-asw-1 Gig 2/2/11        176             R S I  WS-C4510R Gig 1/4
avrb-north-asw-1 Gig 1/2/11        167             R S I  WS-C4510R Gig 1/3
avrb-north-asw-2 Gig 2/2/12        151             R S I  WS-C4506  Gig 2/4
avrb-north-asw-2 Gig 1/2/12        151             R S I  WS-C4506  Gig 2/3
JAE0917AL81(jp-r1r17-asw-2)
                 Gig 1/2/16        155              T S   WS-C2948G 2/51
JAE0917AL81(jp-r1r17-asw-2)
                 Gig 2/2/22        152              T S   WS-C2948G 2/49
mi-za-rba-                 Gig 1/2/48        133             R S I  CISCO7606 Gig 1/32
avrb-north-asw-03
                 Gig 1/2/13        129              S I   WS-C2960G Gig 0/47
avrb-north-asw-03
                 Gig 2/2/13        144              S I   WS-C2960G Gig 0/48
avrb-north-asw-04
                 Gig 1/2/14        120              S I   WS-C2960G Gig 0/47
avrb-north-asw-04
                 Gig 2/2/14        135              S I   WS-C2960G Gig 0/48
avrb-south-asw-02
                 Gig 1/2/2         154             R S I  WS-C4506  Gig 2/4
avrb-south-asw-02
                 Gig 2/2/2         152             R S I  WS-C4506  Gig 2/3
avrb-south-asw-01
                 Gig 2/2/1         165             R S I  WS-C4510R Gig 1/4
avrb-south-asw-01
                 Gig 1/2/1         162             R S I  WS-C4510R Gig 1/3
JAE1107688L(avrb-south-asw-4)
                 Gig 2/2/4         160              T S   WS-C2948G 2/50
JAE1107688L(avrb-south-asw-4)
                 Gig 1/2/4         160              T S   WS-C2948G 2/49
avrb-south-asw-07
                 Gig 1/2/26        179              S I   WS-C2960G Gig 0/47
rba-eline-mi
                 Gig 2/2/48        150              S I   ME-3400EG Gig 0/1
JAE0836V5LK(r1r17-asw-1)
                 Gig 1/2/15        141              T S   WS-C2948G 2/51
JAE0836V5LK(r1r17-asw-1)
                 Gig 2/2/16        119              T S   WS-C2948G 2/50
JAE11076881(avrb-south-asw-3)
                 Gig 2/2/3         123              T S   WS-C2948G 2/50
         
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
JAE11076881(avrb-south-asw-3)
                 Gig 1/2/3         123              T S   WS-C2948G 2/49
avusa-rba-ho-vois-wrl-ce
                 Gig 2/2/47        156             R S I  CISCO2921 Gig 0/1
jp-r3r1-asw-01   Gig 1/2/19        165              S I   WS-C2960G Gig 0/23
jp-r3r1-asw-01   Gig 2/2/20        154              S I   WS-C2960G Gig 0/24
yourdomain.com
                 Gig 1/2/47        131             R S I  CISCO2921 Gig 0/1
JAE1051HR1P(jp-r2r17-asw-01)
                 Gig 1/2/17        123              T S   WS-C2948G 2/50
JAE1051HR1P(jp-r2r17-asw-01)
                 Gig 2/2/17        144              T S   WS-C2948G 2/49
avrb-base-asw-02 Gig 2/2/23        138              S I   WS-C2960G Gig 0/47
avrb-west-asw-01 Gig 2/2/9         127             R S I  WS-C4510R Gig 1/4
avrb-west-asw-01 Gig 1/2/9         177             R S I  WS-C4510R Gig 1/3
avrb-west-asw-04 Gig 2/2/10        137              S I   WS-C2960G Gig 0/47
avrb-west-asw-04 Gig 1/2/10        137              S I   WS-C2960G Gig 0/48
jp-r2r17-asw-02  Gig 1/2/18        140              S I   WS-C2960G Gig 0/46
jp-r2r17-asw-02  Gig 2/2/15        139              S I   WS-C2960G Gig 0/45
r3r3-asw-01      Gig 1/2/20        160              S I   WS-C2960G Gig 0/23
r3r3-asw-01      Gig 2/2/18        172              S I   WS-C2960G Gig 0/24
av-r6r3-asw-1    Gig 2/2/25        120              S I   WS-C2960G Gig 0/24
av-r6r3-asw-1    Gig 1/2/25        170              S I   WS-C2960G Gig 0/23
CVSS1-JRO#

I hope you might have the idea of what i'm experiencing....

As you can see from the output above. The 2960 switch can see the 6509 but the 6509 cant see the 2960.

I dont have an issue for the rest of the devices. Its only this 2960s-48ts. 

i have tried the command #test cable-diagnositics tdr and its not supported.

however, i'll find out from NetPro on whether there is other ways to test the cable.

Thanks,

Jacob

Jacob

Can you post a "sh int status> from the 6509 for the port on the 6509 that the 2960 connects to.

Jon

CVSS1-JRO#sh int Gig 1/2/27 status

Port         Name               Status       Vlan       Duplex  Speed Type
Gi1/2/27     avrb-south-asw-8   connected    trunk        full   1000 1000BaseSX
CVSS1-JRO#

Jacob

Sorry, can you post "sh int trunk" from the 6500 for this interface.

Jon

CVSS1-JRO#sh int g1/2/27 trunk

Port                Mode         Encapsulation  Status        Native vlan
Gi1/2/27            on           802.1q         trunking      1

Port                Vlans allowed on trunk
Gi1/2/27            1-4094

Port                Vlans allowed and active in management domain
Gi1/2/27            1-2,4-5,8,12,16,20,24,28-29,32,36,40,44,48-49,51-52,55-56,60,62,64,68,72,76,78-80,88,91,98,100,111,188,192,196,200-201,204,208,212,216,220,224,228,230,232,234,236,400-403,545,555,800,850,915-917,995-999,1001,4094

Port                Vlans in spanning tree forwarding state and not pruned
Gi1/2/27            1-2,4-5,8,12,16,20,24,28-29,32,36,40,44,48-49,51-52,55-56,60,62,64,68,72,76,78-80,88,91,98,100,111,188,192,196,200-201,204,208,212,216,220,224,228,230,232,234,236,400-403,545,555,800,850,915-917,995-999,1001,4094
CVSS1-JRO#

bharat.rajwanshi
Beginner
Beginner

Hi Jacob,

can you check is Trunk has been configured both edge properly e.g. - Interface Speed, Duplex, Encapsulation type (Dot1Q or ISL), and "sw mode trunk" command..if all are ok then it should see each other in neighbor table.

I have servers connected to the 2960 switch and everything is working as all vlan traffic is passed through. If trunk configuration was not properly configured i would not have connectivity. For interface speed both links are set to operate at 1Gig. duplex both full.

Alessio Andreoli
Contributor
Contributor

Hi Jacob,

please these for me:

sh int g0/49 switchport

(and the relative on the 6500)

and

sh run int g0/49 switchport

(and relative on the 6500)

disabling and re-enabling cdp could help.

Thanks

Alessio

avrb-south-asw-8#sh int g0/49 switchport
Name: Gi0/49
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
avrb-south-asw-8#

CVSS1-JRO#sh int g1/2/27 switchport
Name: Gi1/2/27
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Operational Native VLAN tagging: disabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled
Unknown multicast blocked: disabled

CVSS1-JRO#

Hi Jacob -

can you please send the config for interfaces for both edge??

sh run int Gix/x/x

avrb-south-asw-8#sh run int g0/49
Building configuration...

Current configuration : 119 bytes
!
interface GigabitEthernet0/49
description ***CVSS1-JRO***
switchport mode trunk
switchport nonegotiate
end

avrb-south-asw-8#

CVSS1-JRO#sh run int g1/2/27
Building configuration...

Current configuration : 201 bytes
!
interface GigabitEthernet1/2/27
description avrb-south-asw-8
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
udld port
mls qos trust cos
spanning-tree portfast edge
end

CVSS1-JRO#

Alessio Andreoli
Contributor
Contributor

Remove UDLD and specify encapsulation dot1q on both the configs

interface GigabitEthernet0/49

description ***CVSS1-JRO***

switchport trunk encapsulation dot1q

switchport mode trunk

switchport nonegotiate

end

interface GigabitEthernet1/2/27
description avrb-south-asw-8
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate

mls qos trust cos
spanning-tree portfast edge ! should not this be trunk rather than edge? Consider removing this line
end

Let me know

Alessio

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: