cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3171
Views
0
Helpful
6
Replies
Cisco Employee

Accessing GNS3 router from different PC

Hi Experts,

I've attached the file which shows the issue which im facing in reachability between a PC to GNS3 router.

Home Broadband ->LAN (192.168.1.1) ---- Win 7 (192.168.1.3) -->Loopback Adaptor(192.168.137.1)---->GNS3(cloud-->Router (192.168.137.2))

                                                              Win XP (192.168.15)

Win 7 (192.168.1.3)

Default g/w : 192.168.1.1

Firewall: off

Windows Defender: off

ICS : Enabled between Wireless adaptor and MS loopback adaptor

Routing: Enabled

ICMPRedirect: Disabled

GNS3 Cloud -> points MS Loopback Adaptor (192.168.137.1)

GNS3 Router-> F0/0 (192.168.137.2)

ip route 0.0.0.0 0.0.0.0 192.168.137.1

Ping from Router to Win XP (192.168.1.5) works (actually, Win 7 acts as proxy - confirmed with packet capture).

Win XP (192.168.1.5)

Default g/w: 192.168.1.1

Routing: Enabled

Firewall: off

ICMPRedirect: Disabled

route add 192.168.137.0 mask 255.255.255.0 192.168.1.3

Ping from XP to 192.168.137.2 , goes till Win 7, but no response (request timeout).

Hope this type of n/w already tried by anyone!?

Also, i've tried connecting Win 7 , Win XP back-to-back , with all static routes, still issue is same.

Appreciate for any response / pointers

Thanks,

yoga ..

Everyone's tags (4)
6 REPLIES 6
Highlighted
Beginner

Accessing GNS3 router from different PC

Hi,

1. Wich destination-address (IP & MAC) do you see at the xp client for successful reply of the icmp request from R1 ?

Maybe your ICS is natting the adresses behind your loopback interface.

2. "ICMPRedirect: Disabled" in the configuration of Win7 sounds interesting concerning the problem you mentioned.

3. I assume the ping is successful between win7 and R1? Of course it should work since R1 can ping XP.

Anyway, I would check it, too.

I am facing a similar problem... I am not able to ping between my loopback from win7 to my R1.

When pinging from R1 to Loopback I can see replys to the correct MAC of R1. But the replays never arrive at the router.

I have checked if my firewall is disabled several times, routingtables seems fine, MAC-adresses are correct

Regards

Stefan

Highlighted
Advisor

Accessing GNS3 router from different PC

Hi,

Have you set your Loopback with network location as Home ?

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.
Highlighted
Engager

Re: Accessing GNS3 router from different PC

Hi,

Try to temporarily disable your wifi adapter especially if you're running it simulatneously with GNS3.

They might be on the same subnet.

Sent from Cisco Technical Support iPad App

Highlighted
Cisco Employee

Re: Accessing GNS3 router from different PC

Hi,

Workaround for this problem:

1. Connected the Win7 LAN directly to one of the port in BroadBand router, hence the Gig Interface now part of 192.168.1.x network as like WiFi interface of Win 7

2. Now, GNS3 router has cloud with Gig interface (IP DHCP enabled) and also the Loopback adaptor which is in 192.168.137.1

3. Enabled RIP in GNS3 router

Since, gig interface is in same network 192.168.1.x,  there is 2 way reach between GNS3 router and WinXP (192.168.1.5)

Now, for any VM i create, shall place the m/c in differnt loopback adaptor and add it as cloud t GNS3 router.

It meets my requirment - with drawback that have to have GIG connected to router (wired!),

however, the original question in thread remains unsolved,

Appreciate for all your responses !!

Highlighted
Beginner

Re: Accessing GNS3 router from different PC

I have already tried while my wireless adapter was deactivated, unfortunately without any effort.

I will check the Home thing later

Thanks

Sent from Cisco Technical Support iPhone App

Highlighted
Beginner

Re: Accessing GNS3 router from different PC

some news concerning my problem:

I forgot to tell that in my case R1 is an ASA. I am still facing the problem that I am not able to ping the ASA when it is connected like:

Loopback - Switch - ASA

As soon as i replace the setup like:

Loopback - Switch - Router - Switch ASA

I am able to establish an IP connection.

yvivekan: Any updates concerning your problem?

CreatePlease to create content
Content for Community-Ad