cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
944
Views
20
Helpful
7
Replies

arp problem with IOS Software-15.2.1E ED

wekraibueh1
Level 1
Level 1

I added a new 2960S-switch to my network and made a software update to level 15.2.1E ED.

This was the first switch in my network with this level.

From that day on about 10 percent of our 400 users had a network problem with their windows PCs.

Most of these users were not plugged on this switch. It was the same network, but in different buildings.

The PCs have fixed IP Addresses but they believed this address was already used by another network device.

So they tried to get a better IP-Address from a DHCP Server. Because they  cannot find a DHCP-Server they use IP Address in the range 169.254.*.*

The user wonders why he cannot see his network shares and reboots the PCs. After two or three boots or if the user dooes a plug-out/plug-in of the network cable he has normal normal-connectivity.

We found out that the arp-packets which lead the PC to believe his network address is duplicated come from this one switch with the new IOS-Level.

After a downgrade to 15.0-2.SE2 the problem was gone.

Perhaps someone at cisco reads this and can fix the IOS.

7 Replies 7

Richard Primm
Cisco Employee
Cisco Employee

Hello,

Are you using dot1x on the switches?

Hello,

no,I do not use dot1x

Hardi Ahmed
Level 7
Level 7

Hi wekraibueh1,

when you get access to the new upgraded swtich what kind of message you get from the Privilge access mode?

also you can apply below command on the same switch and please post the output.

SW_X# show log.

regards,

Hi Hardi Ahmed,

there were no messages beside the usual up/down messages when the connected devices are powered on ore off.

regards

Hi Wekraibueh1,

there are many test you can apply on your netework to help  you to detect this issue. first of all the 2960 cisco switches are operating on layer 2. check the dhcp server pool from your router and lease ip addresses. or simply you can start to so below tests on your netwrok devices:

1- you can check your switch for the arp & DHCP lease/status by appling below commands:

#show ip arp XX

# show dhcp lease.

# show ip int brief

alos there are many more commands you can use

2- there are two show commands that allow you to detect this issue in a time:

 

# show log

# show tech-support.

3- check the connectivity between Layer 2 & 3 of your network devices and also if you didn't apply IP default gateway in your switch now you can apply it on your swtich.

if you feel that this issue is remaining in your network, you can post the configuration of your switch, along with your route. or if you don't mind to send me privately, this is up to you.

please let me know if you need any assistance.

regards,

Hi Hardi Ahmed,

there was no DHCP Server enabled on the switch.

As described the problem was solved by just downgrading the switch - no change to the config at all.

regards

Werner

Hi,

I see, the dhcp configuring on the router, and also you can apply the commands that I mentioned in my previus posted to assure about the arp traffic and dhcp lease in your switch.

in this case you don't loss anything if you have a review on your configuration on the router and your newly upgraded switch. if the configuration from both ends are the same as before the upgrade the only  choice is to recover your switch to the old IOS or install another IOS on your switch.

there is one more test and you can apply  on your network: disconnect the switch from your network and have a check if the same issue is reamin in your network. just befor apply this you have to assure that all of the configuration on your devices are saved and also you can reset your devices along with the end users PCs.

thanks,

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card