cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2607
Views
0
Helpful
4
Replies

AutoQoS cause slow performance on Catalyst 2960S with FTP Transfert

Hi!

I activated AutoQoS on a Catalyst 2960S (IOS 15.0.2.SE).


When AutoQos is enabled... a 12 GB file between a Server and a PC run at 100-150 Kbytes/sec.

If I deactivate the AutoQoS on the switch it run at 10 000 KBytes/sec.

Someone has an idea on what could happen?

...Sorry for my bad english...

mls qos map policed-dscp  0 10 18 24 46 to 8

mls qos map cos-dscp 0 8 16 24 32 46 48 56

mls qos srr-queue output cos-map queue 1 threshold 3 4 5

mls qos srr-queue output cos-map queue 2 threshold 1 2

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 3 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 3 1

mls qos srr-queue output dscp-map queue 1 threshold 3 32 33 40 41 42 43 44 45

mls qos srr-queue output dscp-map queue 1 threshold 3 46 47

mls qos srr-queue output dscp-map queue 2 threshold 1 16 17 18 19 20 21 22 23

mls qos srr-queue output dscp-map queue 2 threshold 1 26 27 28 29 30 31 34 35

mls qos srr-queue output dscp-map queue 2 threshold 1 36 37 38 39

mls qos srr-queue output dscp-map queue 2 threshold 2 24

mls qos srr-queue output dscp-map queue 2 threshold 3 48 49 50 51 52 53 54 55

mls qos srr-queue output dscp-map queue 2 threshold 3 56 57 58 59 60 61 62 63

mls qos srr-queue output dscp-map queue 3 threshold 3 0 1 2 3 4 5 6 7

mls qos srr-queue output dscp-map queue 4 threshold 1 8 9 11 13 15

mls qos srr-queue output dscp-map queue 4 threshold 2 10 12 14

mls qos queue-set output 1 threshold 1 100 100 50 200

mls qos queue-set output 1 threshold 2 125 125 100 400

mls qos queue-set output 1 threshold 3 100 100 100 400

mls qos queue-set output 1 threshold 4 60 150 50 200

mls qos queue-set output 1 buffers 15 25 40 20

mls qos

class-map match-all AUTOQOS_VOIP_DATA_CLASS

  match ip dscp ef

class-map match-all AUTOQOS_DEFAULT_CLASS

  match access-group name AUTOQOS-ACL-DEFAULT

class-map match-all AUTOQOS_VOIP_SIGNAL_CLASS

  match ip dscp cs3

policy-map AUTOQOS-SRND4-CISCOPHONE-POLICY

class AUTOQOS_VOIP_DATA_CLASS

   set dscp ef

  police 128000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_VOIP_SIGNAL_CLASS

   set dscp cs3

  police 32000 8000 exceed-action policed-dscp-transmit

class AUTOQOS_DEFAULT_CLASS

   set dscp default

  police 10000000 8000 exceed-action policed-dscp-transmit

4 REPLIES 4
Highlighted
VIP Expert

AutoQoS cause slow performance on Catalyst 2960S with FTP Transf

Disclaimer

The    Author of this posting offers the information contained within this    posting without consideration and with the reader's understanding that    there's no implied or expressed suitability or fitness for any  purpose.   Information provided is for informational purposes only and  should not   be construed as rendering professional advice of any kind.  Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In    no event shall Author be liable for any damages whatsoever  (including,   without limitation, damages for loss of use, data or  profit) arising  out  of the use or inability to use the posting's  information even if  Author  has been advised of the possibility of such  damage.

Posting

Good chance the default class 10 Mbps policer is the problem.

Highlighted

AutoQoS cause slow performance on Catalyst 2960S with FTP Transf

I tried to change the bandwidth on each class.

No results.

The problem is just with FTP protocol.
I tried to use other FTP applications (like Filezilla, WS-FTP) to transfer files. All gave the same results.

If I copy the same file from a PC to another, no problem, I reach "normal" speed.

Highlighted
VIP Expert

AutoQoS cause slow performance on Catalyst 2960S with FTP Transf

Disclaimer

The     Author of this posting offers the information contained within this     posting without consideration and with the reader's understanding  that    there's no implied or expressed suitability or fitness for any   purpose.   Information provided is for informational purposes only and   should not   be construed as rendering professional advice of any kind.   Usage of  this  posting's information is solely at reader's own risk.

Liability Disclaimer

In     no event shall Author be liable for any damages whatsoever   (including,   without limitation, damages for loss of use, data or   profit) arising  out  of the use or inability to use the posting's   information even if  Author  has been advised of the possibility of  such  damage.

Posting

What exactly did you try (when changing bandwidth)?

PC to PC copy via the same switch?

What are interface settings for all source and destination ports?

Highlighted

AutoQoS cause slow performance on Catalyst 2960S with FTP Transf

I changed the 10 Mbs value in the Default Class Policy.

I tried to change the value in the other class too but I know that my traffic normally pass through the Default Class.

The PC-to-PC copy had the same source and destination switch than my FTP transfer.

My source is a "server" switch, so, no QOS (no telephony) on this switch.

My destination port...

interface GigabitEthernet2/0/38

switchport access vlan 48

switchport mode access

switchport voice vlan 756

srr-queue bandwidth share 1 30 35 5

priority-queue out

mls qos trust device cisco-phone

mls qos trust cos

auto qos voip cisco-phone

spanning-tree portfast

service-policy input AUTOQOS-SRND4-CISCOPHONE-POLICY

CreatePlease to create content
Content for Community-Ad