cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Ask the Expert- SD-WAN

176
Views
0
Helpful
3
Replies
Highlighted
Beginner

AutoQoS output drops - but why?

Hi everybody,

I'm using a Cisco 9300 with IOS XE 16.09, and I found something strange: Output drops. And I think that these output drops are related to AutoQoS.

 

This is the interface configuration:

 

interface GigabitEthernet1/0/1
 switchport access vlan 415
 switchport mode access
 switchport nonegotiate
 switchport voice vlan 789
 auto qos trust
 spanning-tree portfast
 service-policy input AutoQos-4.0-Trust-Cos-Input-Policy
 service-policy output AutoQos-4.0-Output-Policy
end

To each port is a PC or laptop (docking station) connected and a Yealink VoIP phone. The PC/ laptop is connected to the phone, and the phone is connected to the port.

 

This is the policy map that is attached to all interfaces:

9300-1#sh policy-map int gi1/0/1
 GigabitEthernet1/0/1

  Service-policy input: AutoQos-4.0-Trust-Cos-Input-Policy

    Class-map: class-default (match-any)
      327161029 packets
      Match: any
      QoS Set
         cos cos table AutoQos-4.0-Trust-Cos-Table

  Service-policy output: AutoQos-4.0-Output-Policy

    queue stats for all priority classes:
      Queueing
      priority level 1

      (total drops) 0
      (bytes output) 399130526

    Class-map: AutoQos-4.0-Output-Priority-Queue (match-any)
      0 packets
      Match:  dscp cs4 (32) cs5 (40) ef (46)
      Match: cos  5
      Priority: 30% (300000 kbps), burst bytes 7500000,

      Priority Level: 1

    Class-map: AutoQos-4.0-Output-Control-Mgmt-Queue (match-any)
      0 packets
      Match:  dscp cs2 (16) cs3 (24) cs6 (48) cs7 (56)
      Match: cos  3
      Queueing

      queue-limit dscp 16 percent 80
      queue-limit dscp 24 percent 90
      queue-limit dscp 48 percent 100
      queue-limit dscp 56 percent 100
      (total drops) 0
      (bytes output) 12987888
      bandwidth remaining 10%

      queue-buffers ratio 10

    Class-map: AutoQos-4.0-Output-Multimedia-Conf-Queue (match-any)
      0 packets
      Match:  dscp af41 (34) af42 (36) af43 (38)
      Match: cos  4
      Queueing

      (total drops) 0
      (bytes output) 0
      bandwidth remaining 10%
      queue-buffers ratio 10

    Class-map: AutoQos-4.0-Output-Trans-Data-Queue (match-any)
      0 packets
      Match:  dscp af21 (18) af22 (20) af23 (22)
      Match: cos  2
      Queueing

      (total drops) 0
      (bytes output) 0
      bandwidth remaining 10%
      queue-buffers ratio 10

    Class-map: AutoQos-4.0-Output-Bulk-Data-Queue (match-any)
      0 packets
      Match:  dscp af11 (10) af12 (12) af13 (14)
      Match: cos  1
      Queueing

      (total drops) 0
      (bytes output) 0
      bandwidth remaining 4%
      queue-buffers ratio 10

    Class-map: AutoQos-4.0-Output-Scavenger-Queue (match-any)
      0 packets
      Match:  dscp cs1 (8)
      Queueing

      (total drops) 0
      (bytes output) 0
      bandwidth remaining 1%
      queue-buffers ratio 10

    Class-map: AutoQos-4.0-Output-Multimedia-Strm-Queue (match-any)
      0 packets
      Match:  dscp af31 (26) af32 (28) af33 (30)
      Queueing

      (total drops) 0
      (bytes output) 0
      bandwidth remaining 10%
      queue-buffers ratio 10

    Class-map: class-default (match-any)
      0 packets
      Match: any
      Queueing

      (total drops) 41326851
      (bytes output) 18995900759
      bandwidth remaining 25%
      queue-buffers ratio 25

I see dropped packets on all active ports, and it looks like that traffic, that traffic matches either class map "AutoQos-4.0-Output-Control-Mgmt-Queue" or class map "class-default". And only traffic that matches "class-default" is being dropped.

Do you share this observation? I can't see that traffic is dropped due to physical errors or congestion.

 

Any explanation for this? I'm new to Cisco and this switch was configured by another admin, that isn't onboard anymore. :/ Thanks for advice!

 

 

 

 

 

 

 

 

 

Everyone's tags (3)
3 REPLIES 3
Hall of Fame Expert

Re: AutoQoS output drops - but why?

Hello Patrick81,

your understanding is correct.

You say that you are new to Cisco devices.

The AutoQoS provides an automatic configuration and deployment using parameters that are considered best practice for common scenarios.

However, the AutoQoS is not a perfect fit for every environment and you may need and you can actually do a tuning of the configuration.

First of all, the VOIP traffic should be classified in the priority queue and you say you see traffic only in two classes.

 

You need to read the following documents:

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-9/configuration_guide/qos/b_169_qos_9300_cg.html?dtid=osscdc000283

 

! for auto-qos

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/catalyst9300/software/release/16-9/configuration_guide/qos/b_169_qos_9300_cg/configuring_auto_qos.html

 

It is not an easy argument feel free to ask for help.

 

Hope to help

Giuseppe

 

Beginner

Re: AutoQoS output drops - but why?

Hello Giuseppe,

thank you for your reply and for confirming my observation. If I understand your posting correctly, VoIP packets should be addressed by class map "AutoQos-4.0-Output-Priority-Queue", which is currently getting no traffic. Correct? I miss the 

(total drops)
(bytes output)

rows for  "AutoQos-4.0-Output-Priority-Queue" in the output, which makes me think that this class map matches no traffic.

 

Thank you for your help!

VIP Mentor

Re: AutoQoS output drops - but why?

Hello,

 

try and set the softmax multiplier to something like the value below:

 

qos queue-softmax-multiplier 1200

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards