cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1136
Views
5
Helpful
3
Replies

BFD support on Catalyst 6500 routed sub-interface on SUP2T ?

2colin-cant
Beginner
Beginner

Hi guys,

I am just investigating the possibility to run BFD on a Cat650X utilizing SUP2Ts running:

s2t54-ipservicesk9-mz.SPA.151-2.SY7.bin

However, my initial testing shows its not supported, and I would like to ask the greater audience if someone got it working, or if this is generally not supported.
Running routed sub-interfaces worked for EIGRP sessions to establish, whereas BFD would not, please find the implemented config on the Cat6500 as follows:

CAT65#sh run | b 1/8/44
interface GigabitEthernet1/8/44
 no switchport
 no ip address
!
interface GigabitEthernet1/8/44.80
 encapsulation dot1Q 80
 ip address 172.29.0.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3
!
interface GigabitEthernet1/8/44.81
 encapsulation dot1Q 81
 ip address 172.30.0.1 255.255.255.0
 bfd interval 50 min_rx 50 multiplier 3

router eigrp 250
network 172.29.0.1 0.0.0.0
network  ip address 172.30.0.1 0.0.0.0
no passive-interface gi1/8/44.80
no passive-interface gi1/8/44.81

CAT65#sh ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(250)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   172.30.0.2              Gi1/8/44.81              14 00:00:06    2   100  0  19
0   172.29.0.2              Gi1/8/44.80              12 00:00:06    2   100  0  13

CAT65#sh bfd neighbors
CAT65#
CAT65#

BFD never came up, the other side was a C2851 whereas I had previously tested BFD working on routed sub-interfaces

Thanks

Colin

3 Replies 3

2colin-cant
Beginner
Beginner

Background of why i'm after this is to utilize VRF lite like configuration, while being able to have BFD on run on the sub-interfaces.

BFD has been implemented a bit crunchy on Cat65's by the looks, not sure if BFD IPv4 multi-hop would work on Cat65, but I try to avoid that if I can.
Probably helps understanding why i am asking it.

Thanks

Colin

Hi Colin,

You need to enable BFD under the routing process configuration, if it's supported for the protocol.

Try:

router eigrp 250
 bfd all-interfaces

or

router eigrp 250
 bfd interface GigabitEthernet1/8/44.80
 bfd interface GigabitEthernet1/8/44.81

Regards,
   Sigurbjartur

Hi Sigurbjartur,

Thanks for your answer. It worked as expected.

Quick question, what do you recommend when using BFD timers of lets say 300ms multiplier 3.

I thought of using the following, adding dampening and carrier-delay 0 into the mix, in order to avoid flapping behavior.


interface GigabitEthernet1/X
dampening
ip address 10.X.X.X 255.255.255.252
carrier-delay 0
bfd interval 300 min_rx 300 multiplier 3

THX

Colin

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: