cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
834
Views
5
Helpful
4
Replies

BGP rib-failure

rahul.bambhnia
Level 1
Level 1

as i have three router and configure basic bgp but suddenly i got rib-failure in sh ip bgp. below is sh run configuration please help me resolved this.

R1#
interface Loopback0
ip address 151.1.1.1 255.255.255.0
!
interface Loopback1
ip address 151.2.1.1 255.255.255.0
!
interface Loopback2
ip address 151.3.1.1 255.255.255.0
!
interface Loopback3
ip address 151.4.1.1 255.255.255.0
!
interface Loopback4
ip address 153.1.1.1 255.255.255.0
!
interface Loopback5
ip address 153.2.1.1 255.255.255.0
!
interface Serial2/0
ip address 150.1.1.1 255.255.255.252
serial restart-delay 0
!
interface Serial2/3
ip address 192.168.1.1 255.255.255.252
ip policy route-map rahul
shutdown
serial restart-delay 0
!
router bgp 111
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 150.1.1.2 remote-as 500
no auto-summary

R3#


interface Ethernet1/0
ip address 200.1.1.1 255.255.255.0
duplex half
!
interface Serial2/0
ip address 150.1.1.2 255.255.255.252
serial restart-delay 0
!
interface Serial2/1
ip address 150.1.1.6 255.255.255.252
serial restart-delay 0
!
router bgp 500
no synchronization
bgp log-neighbor-changes
network 200.1.1.1
neighbor 150.1.1.1 remote-as 111
neighbor 150.1.1.5 remote-as 222
no auto-summary

R2#

interface Loopback0
ip address 152.1.1.1 255.255.255.0
!
interface Loopback1
ip address 152.2.1.1 255.255.255.0
!
interface Loopback2
ip address 152.3.1.1 255.255.255.0
!
interface Loopback3
ip address 152.4.1.1 255.255.255.0
!
interface Loopback4
ip address 153.1.1.1 255.255.255.0
!
interface Loopback5
ip address 153.2.1.1 255.255.255.0

!
interface Serial2/1
ip address 150.1.1.5 255.255.255.252
serial restart-delay 0
!
router bgp 222
no synchronization
bgp log-neighbor-changes
redistribute connected
neighbor 150.1.1.6 remote-as 500
no auto-summary

R3 #sh ip bgp
BGP table version is 27, local router ID is 200.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, x best-external
Origin codes: i - IGP, e - EGP, ? - incomplete

Network Next Hop Metric LocPrf Weight Path
r> 150.1.1.0/30 150.1.1.1 0 0 111 ?
r> 150.1.1.4/30 150.1.1.5 0 0 222 ?
*> 151.1.1.0/24 150.1.1.1 0 0 111 ?
*> 151.2.1.0/24 150.1.1.1 0 0 111 ?
*> 151.3.1.0/24 150.1.1.1 0 0 111 ?
*> 151.4.1.0/24 150.1.1.1 0 0 111 ?
*> 152.1.1.0/24 150.1.1.5 0 0 222 ?
*> 152.2.1.0/24 150.1.1.5 0 0 222 ?
*> 152.3.1.0/24 150.1.1.5 0 0 222 ?
*> 152.4.1.0/24 150.1.1.5 0 0 222 ?
*> 153.1.1.0/24 150.1.1.1 0 0 111 ?
* 150.1.1.5 0 0 222 ?
*> 153.2.1.0/24 150.1.1.1 0 0 111 ?
* 150.1.1.5 0 0 222 ?

R3#sh ip route

Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP
+ - replicated route, % - next hop override

Gateway of last resort is not set

150.1.0.0/16 is variably subnetted, 4 subnets, 2 masks
C 150.1.1.0/30 is directly connected, Serial2/0
L 150.1.1.2/32 is directly connected, Serial2/0
C 150.1.1.4/30 is directly connected, Serial2/1
L 150.1.1.6/32 is directly connected, Serial2/1
151.1.0.0/24 is subnetted, 1 subnets
B 151.1.1.0 [20/0] via 150.1.1.1, 00:30:23
151.2.0.0/24 is subnetted, 1 subnets
B 151.2.1.0 [20/0] via 150.1.1.1, 00:30:23
151.3.0.0/24 is subnetted, 1 subnets
B 151.3.1.0 [20/0] via 150.1.1.1, 00:30:23
151.4.0.0/24 is subnetted, 1 subnets
B 151.4.1.0 [20/0] via 150.1.1.1, 00:30:23
152.1.0.0/24 is subnetted, 1 subnets
B 152.1.1.0 [20/0] via 150.1.1.5, 00:40:46
152.2.0.0/24 is subnetted, 1 subnets
B 152.2.1.0 [20/0] via 150.1.1.5, 00:40:46
152.3.0.0/24 is subnetted, 1 subnets
B 152.3.1.0 [20/0] via 150.1.1.5, 00:40:46
152.4.0.0/24 is subnetted, 1 subnets
B 152.4.1.0 [20/0] via 150.1.1.5, 00:40:46
153.1.0.0/24 is subnetted, 1 subnets
B 153.1.1.0 [20/0] via 150.1.1.1, 00:30:23
153.2.0.0/24 is subnetted, 1 subnets
B 153.2.1.0 [20/0] via 150.1.1.1, 00:30:23
200.1.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 200.1.1.0/24 is directly connected, Ethernet1/0
L 200.1.1.1/32 is directly connected, Ethernet1/0

R3#sh ip bgp rib-failure
Network Next Hop RIB-failure RIB-NH Matches
150.1.1.0/30 150.1.1.1 Higher admin distance n/a
150.1.1.4/30 150.1.1.5 Higher admin distance n/a

even i did not used and any IGP .

1 Accepted Solution

Accepted Solutions

Francesco Molino
VIP Alumni
VIP Alumni

Hi

as per your output, BGP is saying on R3 a rib-failure for 2 networks because there are directly connected and the AD of a connected is better than AD from BGP routes. 

This is a normal behaviour and I don't see any special issues on that output. 

You are getting that output because on R1 and R2, you redistribute connected without filtering. When these 2 subnets arrives in R3 and it see that he have a better path then it will flag those 2 subnets as rib-failure.

There is a good document explain that very simply, that has been mentionned on this forum:

http://blog.ipspace.net/2007/12/what-is-bgp-rib-failure.html

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

View solution in original post

4 Replies 4

Francesco Molino
VIP Alumni
VIP Alumni

Hi

as per your output, BGP is saying on R3 a rib-failure for 2 networks because there are directly connected and the AD of a connected is better than AD from BGP routes. 

This is a normal behaviour and I don't see any special issues on that output. 

You are getting that output because on R1 and R2, you redistribute connected without filtering. When these 2 subnets arrives in R3 and it see that he have a better path then it will flag those 2 subnets as rib-failure.

There is a good document explain that very simply, that has been mentionned on this forum:

http://blog.ipspace.net/2007/12/what-is-bgp-rib-failure.html

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

rahul.bambhnia
Level 1
Level 1

thanks you so much for very quick reply

so could please tell me which cmd i have to hit on router so that i can resolve this issues 

thanks a lot in advance

I will not advertise these connected networks between routers.

I will do On R1 (same should apply to R2 but networks will be changed):

ip prefix-list LOCAL seq 5 permit 150.1.1.0/30

Route-map LOCAL deny 10

 match ip address prefix-list LOCAL

route-map LOCAL permit 20

router bgp 111

 redistribute connected route-map LOCAL

OR Another way to do this, is :

ip prefix-list LOCAL seq 5 deny 150.1.1.0/30

ip prefix-list LOCAL seq 10 permit 0.0.0.0/0 le 32

route-map LOCAL permit 10

 match ip address prefix-list LOCAL

router bgp 111

redistribute connected route-map LOCAL

Thanks


Thanks
Francesco
PS: Please don't forget to rate and select as validated answer if this answered your question

thanks  a lot .

its works..

Review Cisco Networking for a $25 gift card