Showing results for 
Search instead for 
Did you mean: 

%C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId0 on Switch


On many 4506-E switch with cat4500e-entservicesk9-mz.122-53.SG1.bin, I have frequently this error :

Feb 17 10:30:40.879 GMT+1: %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE: Blocked transmit queue HwTxQId7 on Switch Phyport Gi2/48, count=102879

And it's always between the 4506-E and the Cisco 2901/K1 router, the port is blocked (Pause frames).

I did this below (excepted reset the line card) but the only thing to unblock the port is to reboot cisco2901/K9.

When the problem occurs the console port on the cisco2901/k9 is unreachable and I turned off the port on the 4506 and I disconnected the physical link, the port Ge0/0 on the Cisco2901 still has green leds as if it still was connected !

I also tried this command "flowcontrol receive off" on the 4506's port with the Cisco2902/K9, but nothing change (

Peer is Sending Pause Frames => flow control problem)

So i have no idea where is the problem ? Would you have an idea ?

Thank you for your help.



Core issue

The %C4K_HWPORTMAN-4-BLOCKEDTXQUEUE:Blocked transmit queue HwTxQId[dec]on[char], count=[dec] error message is generated on a Cisco Catalyst 4500 series switch when connected to a device. This error is a rate-limited message that indicates a transmit queue blockage on a port.

In this case, the traffic on the affected port is limited and blocked for reasons other than being paused. This blockage can occur if the supervisor is not able to send packets to the line card because a busybit message is received. In this situation, blocked transmit queue messages are seen. A bad hardware or speed and duplex mismatch can cause this problem.


Perform these procedures as a workaround for this issue:

  1. Issue the shut /no shut commands to recover the port and configure both ends to operate at the same speed and duplex, as per Cisco bug ID CSCsb62330.
  2. If the problem persists, move the connected device to another port and see if the problem also happens there.
  3. Issue the hw-module reset command to reboot the switch or reset the line card, as a final attempt to unblock the Transmit (Tx) queue.

Alternatively, upgrade the the Cisco IOS version to the 12.2(25)EWA2 and 12.2(25)SG releases, which have the fix for this problem, as per Cisco bug ID CSCsb01311.


Thank you for documenting this issue with details.  I had this same issue on my Cat4503-E in using VTP 2.0 with a CISCO3640.  Once I hard-set the speed/duplex of the trunk port on my Cat4503-E, as well as fa0/0 on my CISCO3640, all I had to do was reload the Cat4503-E.  The trunking and VTP both worked just fine.

-cecastil, CCIE #1868