cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
166
Views
0
Helpful
2
Replies

C841-M Cannot assign same range different subnets in multiple vlans

sumesh.desilva
Beginner
Beginner

Hi,

We have a requirement to create multiple interface vlans in router using a same ip range segregated to different subnets.

First interface (vlan will be Status/Protocol UP/UP,

10.23.174.0/27

but second interface (vlan 9) assigned with the next subnet will not come up.

10.23.174.32/27

Example config : 

=======================================================================

interface GigabitEthernet0/0
description CONNECTED to LAN
switchport mode trunk
no ip address
!
interface GigabitEthernet0/4.1
description WAN 1
bandwidth 1024
encapsulation dot1Q 1674
ip address 10.50.x.5 255.255.255.252
ip ospf network point-to-point
no cdp enable
!
interface GigabitEthernet0/5
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/5.1
description WAN 2
bandwidth 1024
encapsulation dot1Q 674
ip address 10.50.x.1 255.255.255.252
ip ospf network point-to-point
no cdp enable
!
interface Vlan1
description LAN
no ip address
!
interface Vlan8
ip address 10.23.174.1 255.255.255.224
!
interface Vlan9
ip address 10.23.174.33 255.255.255.224
!
interface Vlan174
ip address 10.20.174.1 255.255.255.192
!
router ospf 100
area 174 stub no-summary
network 10.10.174.1 0.0.0.0 area 174
network 10.20.174.0 0.0.0.63 area 174
network 10.23.174.0 0.0.0.31 area 174
network 10.23.174.32 0.0.0.31 area 174
network 10.50.174.0 0.0.0.3 area 174
network 10.50.174.4 0.0.0.3 area 174
!

===================================================================

Thanks in advance

Sumesh

 

2 Replies 2

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - Try : interface Vlan9
           ip address 10.23.174.33 255.255.255.224
           no shutdown
!

 M.

HI!, 

Thanks for your time in replying.

Already tried, but did'nt succeed.

If I assign a different range subnet to the interface it works, not any subnet in the same subnet as vlan 8.

Is it becasue it's a switch port and the subnet behaves in it's native ip class when it comes to broadcast ?

Thanks again,

Sumesh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers