05-11-2023 12:14 PM
Hello, I am using a Cisco 9300 switch with computers plugged into it via ethernet. The devices can access the internet and ping 1.1.1.1, but cannot ping 8.8.8.8 for some reason.
I am pretty new to networking, so I would be grateful if someone can help me solve this problem. The cisco 9300 config is below.
Thanks
!
interface Port-channel1
description backhaul to aggregation
switchport trunk allowed vlan 201,202
switchport mode trunk
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
ip address 10.0.20.213 255.255.255.0
negotiation auto
!
interface GigabitEthernet1/0/1
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/2
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/3
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/4
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/5
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/6
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/7
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/8
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/9
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/10
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/11
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/12
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/13
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/14
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/15
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/16
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/17
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/18
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/19
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/20
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/21
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/22
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/23
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/24
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/25
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/26
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/27
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/28
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/29
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/30
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/31
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/32
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/33
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/34
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/35
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/36
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/37
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/38
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/39
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/40
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/41
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/42
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/43
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/44
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/45
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/46
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/47
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/0/48
switchport access vlan 201
switchport mode access
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
description backhaul port 1
switchport trunk allowed vlan 201,202
switchport mode trunk
channel-group 1 mode active
!
interface TenGigabitEthernet1/1/2
description backhaul port 2
channel-group 1 mode active
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/5
!
interface TenGigabitEthernet1/1/6
!
interface TenGigabitEthernet1/1/7
!
interface TenGigabitEthernet1/1/8
!
interface FortyGigabitEthernet1/1/1
!
interface FortyGigabitEthernet1/1/2
!
interface TwentyFiveGigE1/1/1
!
interface TwentyFiveGigE1/1/2
!
interface AppGigabitEthernet1/0/1
!
interface Vlan1
no ip address
shutdown
!
interface Vlan201
no ip address
!
interface Vlan202
no ip address
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
!
!
!
!
!
!
control-plane
service-policy input system-cpp-policy
!
05-11-2023 05:57 PM
Hello,
Whoever would be the problem, it is not this switch you shared the config. This 9300 is only a layer2 switch and it will basically offer connectivity.
You need to figure out who is the layer 3. You can run "show cdp nei" to see who is connected to this switch, it might have some layer3 device. Then, access this device and share the show run config
05-11-2023 06:55 PM
I agree that this switch is a simple layer 2 switch, and whatever the issue is it is not on this switch. Certainly show cdp neighbor is one way to identify upstream devices, but it is possible that there could be more than 1 cdp neighbor. Another approach would be to check one of the hosts connected to this switch, and find what is its default gateway. That is likely the device where the problem is.
05-30-2023 01:20 PM
Sorry for the delay. The 9300 is connected to a cisco 9500. The config is below.
Also for more clarification, the cisco 9500 can ping 8.8.8.8 and 1.1.1.1, but the 9300 and any device plugged into the 9300 cannot. I have also set up a non-cumulus switch to do the same function, for testing, and devices connected to it were able to ping everything normally, so I am not sure why this is occuring only when using the 9300. Thanks for the help!
!
interface Port-channel1
description PA-3260
switchport access vlan 150
switchport mode access
speed nonegotiate
spanning-tree portfast disable
!
interface Port-channel2
description Dell Agg Switches
switchport mode trunk
speed nonegotiate
spanning-tree portfast disable
!
interface GigabitEthernet0/0
vrf forwarding Mgmt-vrf
ip address 10.0.15.3 255.255.0.0
negotiation auto
!
interface HundredGigE1/0/1
!
interface HundredGigE1/0/2
!
interface HundredGigE1/0/3
switchport access vlan 150
switchport mode access
channel-group 1 mode on
!
interface HundredGigE1/0/4
switchport access vlan 150
switchport mode access
channel-group 1 mode on
!
interface HundredGigE1/0/5
!
interface HundredGigE1/0/6
!
interface HundredGigE1/0/7
!
interface HundredGigE1/0/8
!
interface HundredGigE1/0/9
!
interface HundredGigE1/0/10
!
interface HundredGigE1/0/11
!
interface HundredGigE1/0/12
!
interface HundredGigE1/0/13
!
interface HundredGigE1/0/14
!
interface HundredGigE1/0/15
!
interface HundredGigE1/0/16
!
interface HundredGigE1/0/17
!
interface HundredGigE1/0/18
!
interface HundredGigE1/0/19
!
interface HundredGigE1/0/20
!
interface HundredGigE1/0/21
!
interface HundredGigE1/0/22
!
interface HundredGigE1/0/23
!
interface HundredGigE1/0/24
!
interface HundredGigE1/0/25
!
interface HundredGigE1/0/26
!
interface HundredGigE1/0/27
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE1/0/28
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE1/0/29
!
interface HundredGigE1/0/30
!
interface HundredGigE1/0/31
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE1/0/32
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE2/0/1
stackwise-virtual link 1
!
interface HundredGigE2/0/2
stackwise-virtual link 1
!
interface HundredGigE2/0/3
switchport access vlan 150
switchport mode access
channel-group 1 mode on
!
interface HundredGigE2/0/4
switchport access vlan 150
switchport mode access
channel-group 1 mode on
!
interface HundredGigE2/0/5
!
interface HundredGigE2/0/6
!
interface HundredGigE2/0/7
!
interface HundredGigE2/0/8
!
interface HundredGigE2/0/9
!
interface HundredGigE2/0/10
!
interface HundredGigE2/0/11
!
interface HundredGigE2/0/12
!
interface HundredGigE2/0/13
!
interface HundredGigE2/0/14
!
interface HundredGigE2/0/15
!
interface HundredGigE2/0/16
!
interface HundredGigE2/0/17
!
interface HundredGigE2/0/18
!
interface HundredGigE2/0/19
!
interface HundredGigE2/0/20
!
interface HundredGigE2/0/21
!
interface HundredGigE2/0/22
!
interface HundredGigE2/0/23
!
interface HundredGigE2/0/24
!
interface HundredGigE2/0/25
!
interface HundredGigE2/0/26
!
interface HundredGigE2/0/27
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE2/0/28
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE2/0/29
!
interface HundredGigE2/0/30
!
interface HundredGigE2/0/31
switchport mode trunk
channel-group 2 mode active
!
interface HundredGigE2/0/32
switchport mode trunk
channel-group 2 mode active
!
interface Vlan1
no ip address
shutdown
!
interface Vlan150
description Firewall
ip address 10.115.115.3 255.255.255.0
!
interface Vlan201
description wired admin
ip address 10.200.32.1 255.255.240.0
!
interface Vlan202
description wired access
ip address 10.200.48.1 255.255.240.0
!
interface Vlan1000
description OAM
ip address 10.0.0.1 255.255.255.0
!
router ospf 4
router-id 10.0.0.1
passive-interface default
no passive-interface Vlan1000
network 10.0.0.0 0.0.255.255 area 0
default-information originate
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.115.115.1
ip ssh version 2
ip ssh server algorithm authentication password
!
!
!
05-30-2023 01:29 PM
Hello,
One question: When you plug a PC to 9300, does it get IP address or do you configure static IP ?
Can you run two commands on 9300:
show ip int br
sh vlan
05-30-2023 01:36 PM
The PCs get an IP address automatically, so DHCP works. The outputs of those two commands are below.
Switch#show ip int br
Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM administratively down down
Vlan201 unassigned YES unset up up
Vlan202 unassigned YES unset up up
GigabitEthernet0/0 10.0.20.213 YES manual up up
GigabitEthernet1/0/1 unassigned YES unset up up
GigabitEthernet1/0/2 unassigned YES unset down down
GigabitEthernet1/0/3 unassigned YES unset down down
GigabitEthernet1/0/4 unassigned YES unset down down
GigabitEthernet1/0/5 unassigned YES unset down down
GigabitEthernet1/0/6 unassigned YES unset down down
GigabitEthernet1/0/7 unassigned YES unset down down
GigabitEthernet1/0/8 unassigned YES unset down down
GigabitEthernet1/0/9 unassigned YES unset down down
GigabitEthernet1/0/10 unassigned YES unset down down
GigabitEthernet1/0/11 unassigned YES unset down down
GigabitEthernet1/0/12 unassigned YES unset down down
GigabitEthernet1/0/13 unassigned YES unset down down
GigabitEthernet1/0/14 unassigned YES unset down down
GigabitEthernet1/0/15 unassigned YES unset down down
GigabitEthernet1/0/16 unassigned YES unset down down
GigabitEthernet1/0/17 unassigned YES unset down down
GigabitEthernet1/0/18 unassigned YES unset down down
GigabitEthernet1/0/19 unassigned YES unset down down
GigabitEthernet1/0/20 unassigned YES unset down down
GigabitEthernet1/0/21 unassigned YES unset down down
GigabitEthernet1/0/22 unassigned YES unset down down
GigabitEthernet1/0/23 unassigned YES unset down down
GigabitEthernet1/0/24 unassigned YES unset down down
GigabitEthernet1/0/25 unassigned YES unset down down
GigabitEthernet1/0/26 unassigned YES unset down down
GigabitEthernet1/0/27 unassigned YES unset down down
GigabitEthernet1/0/28 unassigned YES unset down down
GigabitEthernet1/0/29 unassigned YES unset down down
GigabitEthernet1/0/30 unassigned YES unset down down
GigabitEthernet1/0/31 unassigned YES unset down down
GigabitEthernet1/0/32 unassigned YES unset down down
GigabitEthernet1/0/33 unassigned YES unset down down
GigabitEthernet1/0/34 unassigned YES unset down down
GigabitEthernet1/0/35 unassigned YES unset down down
GigabitEthernet1/0/36 unassigned YES unset down down
GigabitEthernet1/0/37 unassigned YES unset down down
GigabitEthernet1/0/38 unassigned YES unset down down
GigabitEthernet1/0/39 unassigned YES unset down down
GigabitEthernet1/0/40 unassigned YES unset down down
GigabitEthernet1/0/41 unassigned YES unset down down
GigabitEthernet1/0/42 unassigned YES unset down down
GigabitEthernet1/0/43 unassigned YES unset down down
GigabitEthernet1/0/44 unassigned YES unset down down
GigabitEthernet1/0/45 unassigned YES unset down down
GigabitEthernet1/0/46 unassigned YES unset down down
GigabitEthernet1/0/47 unassigned YES unset down down
GigabitEthernet1/0/48 unassigned YES unset down down
GigabitEthernet1/1/1 unassigned YES unset down down
GigabitEthernet1/1/2 unassigned YES unset down down
GigabitEthernet1/1/3 unassigned YES unset down down
GigabitEthernet1/1/4 unassigned YES unset down down
Te1/1/1 unassigned YES unset up up
Te1/1/2 unassigned YES unset down down
Te1/1/3 unassigned YES unset down down
Te1/1/4 unassigned YES unset down down
Te1/1/5 unassigned YES unset down down
Te1/1/6 unassigned YES unset down down
Te1/1/7 unassigned YES unset down down
Te1/1/8 unassigned YES unset down down
Fo1/1/1 unassigned YES unset down down
Fo1/1/2 unassigned YES unset down down
TwentyFiveGigE1/1/1 unassigned YES unset down down
TwentyFiveGigE1/1/2 unassigned YES unset down down
Ap1/0/1 unassigned YES unset up up
Port-channel1 unassigned YES unset up up
Switch#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Te1/1/2, Te1/1/3, Te1/1/4
Te1/1/5, Te1/1/6, Te1/1/7
Te1/1/8, Ap1/0/1
201 VLAN0201 active Gi1/0/1, Gi1/0/2, Gi1/0/3
Gi1/0/4, Gi1/0/5, Gi1/0/6
Gi1/0/7, Gi1/0/8, Gi1/0/9
Gi1/0/10, Gi1/0/11, Gi1/0/12
Gi1/0/13, Gi1/0/14, Gi1/0/15
Gi1/0/16, Gi1/0/17, Gi1/0/18
Gi1/0/19, Gi1/0/20, Gi1/0/21
Gi1/0/22, Gi1/0/23, Gi1/0/24
Gi1/0/25, Gi1/0/26, Gi1/0/27
Gi1/0/28, Gi1/0/29, Gi1/0/30
Gi1/0/31, Gi1/0/32, Gi1/0/33
Gi1/0/34, Gi1/0/35, Gi1/0/36
Gi1/0/37, Gi1/0/38, Gi1/0/39
Gi1/0/40, Gi1/0/41, Gi1/0/42
Gi1/0/43, Gi1/0/44, Gi1/0/45
Gi1/0/46, Gi1/0/47, Gi1/0/48
202 VLAN0202 active
1000 VLAN1000 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
201 enet 100201 1500 - - - - - 0 0
202 enet 100202 1500 - - - - - 0 0
1000 enet 101000 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - - 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- --------- ----------------- ------------------------------------------
05-30-2023 01:47 PM
Great, thank you.
I saw that the 9300 has a port-channel with the interface :
interface TenGigabitEthernet1/1/1
description backhaul port 1
switchport trunk allowed vlan 201,202
switchport mode trunk
channel-group 1 mode active
But I could not identify on the 9500 a port-channel to 9300. How they are connected ?
05-30-2023 01:51 PM
TenGigabitEthernet 1/1/1 is a fiber connection to a dell switch running cumulus linux. The 9500 is connected to the dell switch via a qsfp cable.
05-30-2023 01:53 PM
OK, but how are those switches connected? 9300 and 9500 ?
And this config above I got from 9300 and not 9500
05-30-2023 01:54 PM
Sorry I forgot that they are not directly connected. The 9300 connects to the dell switch which connects to the 9500.
05-30-2023 01:57 PM - edited 05-30-2023 02:02 PM
oh...can you show me the interface on 9300 that connect to Dell ?
As you are tagging all ports with vlan 201, I expect you have a trunk between 9300 and Dell, the vlan 201 created on Dell and a trunk netween Dell and 9500 with vlan 201 on it.
05-30-2023 02:08 PM
TenGigabitEthernet 1/1/1 connects to the dell switch.
TenGigabitEthernet 1/1/2 will eventually connect to an identical dell switch which will also go to the 9500, but it is not set up yet.
Is the problem that the second part of the trunk is not set up yet?
05-30-2023 02:19 PM
This interface is part of a channel and it connects to Dell? So, you have a port-channel with dell swtch?
9300:
Interface TenGigabitEthernet1/1/1
description backhaul port 1
switchport trunk allowed vlan 201,202
switchport mode trunk
channel-group 1 mode active
Can you show the command
show spanning-tree vlan 201
06-01-2023 06:33 AM
Yes, this interface connects to the Dell Switch.
Switch#show spanning-tree vlan 201
VLAN0201
Spanning tree enabled protocol rstp
Root ID Priority 32969
Address 74ad.9897.f3a0
Cost 2
Port 3049 (Port-channel1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32969 (priority 32768 sys-id-ext 201)
Address e069.ba79.1c00
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300 sec
Interface Role Sts Cost Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Gi1/0/1 Desg FWD 4 128.1 P2p
Po1 Root FWD 2 128.3049 P2p
06-01-2023 07:04 AM
If you were able to share a simple diagram of the network, would be helpfull.
Seems to me that you have a port-channel from 9500 to Dell and another one from Dell to 9300.
The traffic should run from 9300 to Dell, from Dell to 9500 and then to the internet and back.
Do you have any evidence that the traffic is able to leave 9300, make it through dell and get to 9500 ? That could be a good start point.
Another question I have is from where the DHCP comes and which gateway the DHCP is assigning to the PC.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide