05-03-2017 10:23 AM - edited 03-08-2019 10:25 AM
Hi all,
I need assistance in building this network. I need to ping all the routers, the other PC and all the switches. I was able to do the first two but I can't figure out how to ping the last Switch2 switch. Thanks
Solved! Go to Solution.
05-03-2017 01:37 PM
Hi
Thank you, you need to advertise the networks connected (or created) into R2 through a routing protocol, also configure the switches with a management IP, let me share an example
:-)
05-03-2017 10:28 AM
Hi
Could you please provide a diagram?, basically you need to implement any dynamic routing protocol like RIP, EIGRP or OSPF between the routers and advertise the directly connected subnets of each router through the routing protocol.
:-)
05-03-2017 11:56 AM
05-03-2017 01:37 PM
Hi
Thank you, you need to advertise the networks connected (or created) into R2 through a routing protocol, also configure the switches with a management IP, let me share an example
:-)
05-03-2017 01:55 PM
Router 1
interface s0/0
description TO-R2
ip address 10.0.0.1 255.255.255.252
clock rate 64000
no shutdown
router ospf 100
network 10.0.0.0 0.0.0.3 area 0
Router 2
interface s0/0
description TO-R1
ip address 10.0.0.2 255.255.255.252
clock rate 64000
no shutdown
interface fa0/0
no shutdown
interface fa0/0.10
description MGNT-SWITCHES
encapsulation dot1q 10
ip add 192.168.10.1 255.255.255.0
interface fa0/0.20
description VLAN-PC
encapsulation dot1q 20
ip add 192.168.20.1 255.255.255.0
router ospf 100
network 10.0.0.0 0.0.0.3 area 0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.20.0 0.0.0.255 area 0
SWITCHES S1
vlan 10
vlan 20
interface fa1/0/1
description TO-ROUTER-2
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
interface fa1/0/2
description TO-OTHER-SWITCHES
switchport trunk encapsulation dot1q
switchport mode trunk
no shutdown
int vlan 10
description MGNT-SWITCHES
ip add 192.168.10.100 255.255.255.0
ip default-gateway 192.168.10.1
The lines highlighted in blue will be similar on S2 y S3 just change the IP of management on each one.
Remember for the ports where the PC will be connected you must set up them like access ports
example:
int fa1/0/20
no shut
switchport access vlan 20
switchport mode access
05-03-2017 02:08 PM
Thanks for the picture. It does help to have some sense of the topology of the network. Details of how the switches and routers are configured would be quite helpful.
If I understand the post correctly it seems that you can ping switches except for switch2. If that is the case then it suggests that the issue may be with the IP configured on the switch (especially if it is not in the same subnet as the other switches) or that the issue may be with the default gateway configured on switch2.
HTH
Rick
05-04-2017 04:28 PM
Thanks for the helpful replies. I managed to get all pinging since I forgot to put the encapsulation dot1q native on the R2. Do you guys mind checking my network if there are other issues that I should be aware of?
Another question, Is there any purpose of using switchport trunk native vlan on S2 and S3? I only have mine on S1 that is connected to the router
05-03-2017 10:35 AM
Hello,
switches usually have management IP addresses that belong to the same address space, these are generally configured on the Vlan 1 interface. They also have the 'ip default-gateway' configured, which points to an interface of the neighboring router. Make sure your switches have both,
05-03-2017 10:48 AM
The original post says that there is a network but provides very little information about it. The post says that ping works for the first two but not the last. But we have no detail to help us understand how this is configured any why ping is not working. Please give us information to help understand the topology of the network and details of the configuration so that we might be able to give better answers to the problem.
HTH
Rick
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide