- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2020 07:25 AM
Hi,
In Packet Tracer, I build small network, one of 192.168.10.0/24 that runs on vlan10 and name by LAN1.
The other network is LAN2 and runs on 172.19.0.0/16.
I want to SSH from PC in LAN1 (192.168.10.1/24 for example) and connect to the only switch that is placed in LAN2, to the address 172.19.100.100/16.
I configured the address at interface vlan 10, i don't want to manage the sessions from VLAN1, but from VLAN10.
Everything is work perfectly, i have pings to all nodes, can connect via SSHv2 to all other switch/routers in this toplogy.
For sumarry, I want to connect to remote switch (172.19.100.110/16) via PC0 (192.168.10.1/24) on VLAN10 and not Native VLAN1.
Commands on the switch that i want to connect to:
interface Vlan1
no ip address
shutdown
!
interface Vlan10
mac-address x.x.x
ip address 172.19.100.110 255.255.0.0
!
ip default-gateway 172.19.255.254
!
banner motd ^CCaution! Only Authorized Users Can Access This Device!^C
!
!
!
line con 0
password 7 08204E4D0D
logging synchronous
!
line vty 0 1
logging synchronous
login local
transport input ssh
line vty 2 4
login
line vty 5 15
login
!
!
!
!
end
Solved! Go to Solution.
- Labels:
-
Other Switches
Accepted Solutions
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2020 07:46 AM - edited 05-14-2020 07:54 AM
the issue is between sw 4 and router 2. ping fails. you have trunk link on sw 4 to R2 but R2 has no trunking enabled on port fa0/1. normally, you would want to make sub-interfaces on R2 for future vlan routing, aka inter-vlan routing
- aka, interface fa0/1.10, encap dot1q 10 and ip address 172.19.255.254).
since u have just 1 vlan on sw 4, u can make sw 4 fa0/1 as access port in vl 10 -port connecting R2. so , quick solution is sw 4
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
ping is fine now, so ssh works
Regards, ML
**Please Rate All Helpful Responses **
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2020 07:31 AM
have you generated the ssh key on the switch?
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2020 08:02 AM - edited 05-13-2020 08:04 AM
To clarify, I have done all the configurations for the ssh connection. Even more, it's all working when i configure the ip address 172.19.100.110 on VLAN1, it is all working fine, I can access the switch from the 192.168.10.1 computer on LAN1.
I'm Trying to enter the switch via VLAN that is not native VLAN1.
P.s
A picture that describe the topology is added to this post.
Thanks!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-13-2020 12:18 PM
please attach PT file (zip format) for us to check; sometimes PT misbehaves; works for me but not for you;
Regards, ML
**Please Rate All Helpful Responses **
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2020 02:24 AM - edited 05-14-2020 02:27 AM
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2020 07:46 AM - edited 05-14-2020 07:54 AM
the issue is between sw 4 and router 2. ping fails. you have trunk link on sw 4 to R2 but R2 has no trunking enabled on port fa0/1. normally, you would want to make sub-interfaces on R2 for future vlan routing, aka inter-vlan routing
- aka, interface fa0/1.10, encap dot1q 10 and ip address 172.19.255.254).
since u have just 1 vlan on sw 4, u can make sw 4 fa0/1 as access port in vl 10 -port connecting R2. so , quick solution is sw 4
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
ping is fine now, so ssh works
Regards, ML
**Please Rate All Helpful Responses **
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2020 11:13 PM
It's working !
I just opened a sun-interface 0/1.10 and gave him the dot1q with the DG..
just opened trunk, and it worked ! it needs to be linked with the dot1q with the specific vlan that you want.
Thank you very much!
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
05-14-2020 11:41 PM
glad to help
