cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3037
Views
5
Helpful
9
Replies

Cannot enable ip routing Catalyst4948 - Layer 3 switch ip based

IAmSeth
Level 1
Level 1

I have a problem with enabling ip routing on the layer 3 switch Catalyst4948. As a result of that my Vlan interfaces cannot communicate. I also cannot ping other interface ip addesses, if device is connected on one vlan it can only ping devices on vlan and interface ip addess. On other layer 3 switch the command worked fine and routing was enabled, however this one is not cooperating.

 

Controls_Switch(config)#ip routing

this command does not give error but it is not visible on the running conf.

 

#show run:

Current configuration : 7368 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
!
hostname Controls_Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oZvd$9LgA6xDbAMYrExKdwJAxr.
!
username admin password 7 0822455D0A16
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
aaa session-id common
ip subnet-zero
ip domain-name xxx.xx.xx
ip dhcp excluded-address 10.0.200.1 10.0.200.10
ip dhcp excluded-address 10.0.210.1 10.0.210.10

 

#Show ver:

Cisco IOS Software, Catalyst 4500 L3 Switch Software (cat4500-IPBASEK9-M), Version 15.0(2)SG11, RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Mon 24-Oct-16 10:00 by prod_rel_team
Image text-base: 0x10000000, data-base: 0x12097BA8

ROM: 12.2(31r)SGA1
Dagobah Revision 226, Swamp Revision 5

Controls_Switch uptime is 10 hours, 52 minutes
System returned to ROM by power-on
System image file is "bootflash:cat4500-ipbasek9-mz.150-2.SG11.bin"

Could someone help? 

9 Replies 9

Reza Sharifi
Hall of Fame
Hall of Fame

I think "ip routing" is enable by default on the 4948 switches and maybe that is the reason you don't see it in the running config.

Can you try 

no ip routing

and see if it shows up in the running config?

than

ip routing 

and test again?

HTH

I have tried that and "no ip routing" did display, but "ip routing" is not visible.

 

Please see full ruuning-configuration:

Current configuration : 7364 bytes
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
service compress-config
!
hostname Controls_Switch
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$oZvd$9LgA6xDbAMYrExKdwJAxr.
!
username admin password 0 xxxxx
!
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
!
!
aaa session-id common
ip subnet-zero
ip domain-name xxxx.xx.xx
ip dhcp excluded-address 10.0.200.1 10.0.200.10
ip dhcp excluded-address 10.0.210.1 10.0.210.10
!
ip dhcp pool vlan200
   network 10.0.200.0 255.255.255.0
   default-router 10.0.200.254
!
ip dhcp pool vlan210
   network 10.0.210.0 255.255.255.0
   default-router 10.0.210.254
!
!
ip vrf mgmtVrf
!
!
!
!
power redundancy-mode redundant
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet1
 ip vrf forwarding mgmtVrf
 no ip address
 speed auto
 duplex auto
!
interface GigabitEthernet1/1
!
interface GigabitEthernet1/2
 switchport access vlan 101
 switchport mode access
!
interface GigabitEthernet1/3
 switchport access vlan 102
 switchport mode access
!
interface GigabitEthernet1/4
 switchport access vlan 103
 switchport mode access
!
interface GigabitEthernet1/5
 switchport access vlan 104
 switchport mode access
!
interface GigabitEthernet1/6
 switchport access vlan 105
 switchport mode access
!
interface GigabitEthernet1/7
 switchport access vlan 106
 switchport mode access
!
interface GigabitEthernet1/8
 switchport access vlan 107
 switchport mode access
!
interface GigabitEthernet1/9
 switchport access vlan 108
 switchport mode access
!
interface GigabitEthernet1/10
 switchport access vlan 109
 switchport mode access
!
interface GigabitEthernet1/11
 switchport access vlan 110
 switchport mode access
!
interface GigabitEthernet1/12
 switchport access vlan 111
 switchport mode access
!
interface GigabitEthernet1/13
 switchport access vlan 112
 switchport mode access
!
interface GigabitEthernet1/14
 switchport access vlan 113
 switchport mode access
!
interface GigabitEthernet1/15
 switchport access vlan 114
 switchport mode access
!
interface GigabitEthernet1/16
 switchport access vlan 115
 switchport mode access
!
interface GigabitEthernet1/17
 switchport access vlan 116
 switchport mode access
!
interface GigabitEthernet1/18
 switchport access vlan 117
 switchport mode access
!
interface GigabitEthernet1/19
 switchport access vlan 118
 switchport mode access
!
interface GigabitEthernet1/20
 switchport access vlan 119
 switchport mode access
!
interface GigabitEthernet1/21
 switchport access vlan 120
 switchport mode access
!
interface GigabitEthernet1/22
 switchport access vlan 121
 switchport mode access
!
interface GigabitEthernet1/23
 switchport access vlan 122
 switchport mode access
!
interface GigabitEthernet1/24
 switchport access vlan 123
 switchport mode access
!
interface GigabitEthernet1/25
 switchport access vlan 124
 switchport mode access
!
interface GigabitEthernet1/26
 switchport access vlan 125
 switchport mode access
!
interface GigabitEthernet1/27
 switchport access vlan 126
 switchport mode access
!
interface GigabitEthernet1/28
 switchport access vlan 127
 switchport mode access
!
interface GigabitEthernet1/29
 switchport access vlan 128
 switchport mode access
!
interface GigabitEthernet1/30
 switchport access vlan 129
 switchport mode access
!
interface GigabitEthernet1/31
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/32
 switchport access vlan 200
 switchport mode access
!
interface GigabitEthernet1/33
 switchport access vlan 205
 switchport mode access
!
interface GigabitEthernet1/34
 switchport access vlan 205
 switchport mode access
!
interface GigabitEthernet1/35
 switchport access vlan 205
 switchport mode access
!
interface GigabitEthernet1/36
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/37
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/38
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/39
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/40
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/41
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/42
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/43
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/44
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/45
 switchport access vlan 210
 switchport mode access
!
interface GigabitEthernet1/46
 switchport access vlan 215
 switchport mode access
!
interface GigabitEthernet1/47
 switchport access vlan 215
 switchport mode access
!
interface GigabitEthernet1/48
 switchport access vlan 220
 switchport mode access
!
interface Vlan1
 ip address 192.168.0.100 255.255.255.0
!
interface Vlan101
 ip address 10.0.101.254 255.255.255.0
!
interface Vlan102
 ip address 10.0.102.254 255.255.255.0
!
interface Vlan103
 ip address 10.0.103.254 255.255.255.0
!
interface Vlan104
 ip address 10.0.104.254 255.255.255.0
!
interface Vlan105
 ip address 10.0.105.254 255.255.255.0
!
interface Vlan106
 ip address 10.0.106.254 255.255.255.0
!
interface Vlan107
 ip address 10.0.107.254 255.255.255.0
!
interface Vlan108
 ip address 10.0.108.254 255.255.255.0
!
interface Vlan109
 ip address 10.0.109.254 255.255.255.0
!
interface Vlan110
 ip address 10.0.110.254 255.255.255.0
!
interface Vlan111
 ip address 10.0.111.254 255.255.255.0
!
interface Vlan112
 ip address 10.0.112.254 255.255.255.0
!
interface Vlan113
 ip address 10.0.113.254 255.255.255.0
!
interface Vlan114
 ip address 10.0.114.254 255.255.255.0
!
interface Vlan115
 ip address 10.0.115.254 255.255.255.0
!
interface Vlan116
 ip address 10.0.116.254 255.255.255.0
!
interface Vlan117
 ip address 10.0.117.254 255.255.255.0
!
interface Vlan118
 ip address 10.0.118.254 255.255.255.0
!
interface Vlan119
 ip address 10.0.119.254 255.255.255.0
!
interface Vlan120
 ip address 10.0.120.254 255.255.255.0
!
interface Vlan121
 ip address 10.0.121.254 255.255.255.0
!
interface Vlan122
 ip address 10.0.122.254 255.255.255.0
!
interface Vlan123
 ip address 10.0.123.254 255.255.255.0
!
interface Vlan124
 ip address 10.0.124.254 255.255.255.0
!
interface Vlan125
 ip address 10.0.125.254 255.255.255.0
!
interface Vlan126
 ip address 10.0.126.254 255.255.255.0
!
interface Vlan127
 ip address 10.0.127.254 255.255.255.0
!
interface Vlan128
 ip address 10.0.128.254 255.255.255.0
!
interface Vlan129
 ip address 10.0.129.254 255.255.255.0
!
interface Vlan200
 ip address 10.0.200.254 255.255.255.0
!
interface Vlan205
 ip address 10.0.205.254 255.255.255.0
!
interface Vlan210
 ip address 10.0.210.254 255.255.255.0
!
interface Vlan215
 ip address 10.0.215.254 255.255.255.0
!
interface Vlan220
 ip address 10.0.220.254 255.255.255.0
!
no ip http server
no ip http secure-server
!
!
!
!
control-plane
!
banner motd ^CThis is Controls Department switch.^C
!
line con 0
 stopbits 1
line vty 0 4
 transport input ssh
!
end

I want to enable vlan 200 and vlan 210 communication but it doesn't work at the moment.

Do you have VTP configured? I don't see VLANs created.
Please send output of commands:
sh vlan brief
sh ip int brief | exc unass

Can you post the output of "sh ip route"?

HTH

Along with the output of show ip route I think it might be helpful to have the output of show ip protocol. If the original poster is concerned that the command ip routing does not show up in the config then there is a very simple explanation for this. For many commands, including this one, the command is not in the output of show run when the command is enabled by default. show ip route and show ip protocol should help demonstrate whether ip routing is actually enabled. 

 

The original post does seem to indicate that devices connected to this switch were having difficulty communicating outside of their own subnet. Perhaps we need to look into this a bit more. I do note that this switch does not have any static routes configured and no routing protocol. So it would not be able to communicate with anything not connected to this switch. But any connected device should be able to communicate with any other connected device. If this is not working then perhaps the original poster can provide some information about particular devices that do not communicate.

HTH

Rick

pascalek
Level 1
Level 1

If your computers have connectivity and your L3 switch had no routing enabled than which device is making a routing job in your network?

 

You did not provided full config so it's hard to say what's happening but if network behavior is changing after you enabled ip routing than your switch doesn't look like a router now. Honestly... it brings more questions than answers.

 

About invisible configuration: try using sh run all command.

 

As last word... ip routing command disables ip default-gateway so you need to setup some routes (statically or dynamically).

 

 

IAmSeth
Level 1
Level 1

It seems that command "no ip routing" followed by "ip routing" did the trick.

 

Thanks! Now it is solved

Thanks for the update indicating that no ip routing followed by ip routing did the trick.

HTH

Rick

glennsha
Level 1
Level 1

I'm having this same exact problem on the same exact switch here. I tried doing the whole no ip routing and ip routing trick, and still the same result of hidden text/no error. Here is my config (hastebin.com) 

Review Cisco Networking products for a $25 gift card