cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1138
Views
0
Helpful
9
Replies
Highlighted
Beginner

Catalyst 2960S Port-Based Address Allocation

I just bought a Catalyst 2960S to test out the feature "Port-Based Address Allocation" which is required for our factory. I followed the instruction from Cisco IOS and did all the steps but I could not get it to work, my network client did not received the expected IP address that I configured. Is there any one got this thing working? any help would be awesome.

Thanks

Phuong

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Hi,

config t

int range g1/0/1 -3

switchport mode access

switchport access vlan 2

exit

int vlan 2

ip address 192.168.1.x

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

9 REPLIES 9
Highlighted
Participant

hello,

could you please check this link and see if you following the correct procedure

http://www.cisco.com/en/US/docs/switches/lan/catalyst2960/software/release/12.2_55_se/configuration/guide/swdhcp82.html#wp1320926

go to

Port-Based Address Allocation Configuration Guidelines

please let me know if this helps.

thanks

Highlighted

Yes, I did follow the same guide. I just tried to set up for 3 ports and when I plugged the client into the port, DHCP failed . Below is my running-config. Wonder I missed anything or did something wrong.


Switch#show running-config
Building configuration...

Current configuration : 1871 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
switch 1 provision ws-c2960s-24ts-l
ip dhcp use subscriber-id client-id
ip dhcp subscriber-id interface-name
!
ip dhcp pool vlan2
   network 192.168.1.0 255.255.255.0
   address 192.168.1.1 client-id "Gi1/0/1" ascii
   address 192.168.1.2 client-id "Gi1/0/2" ascii
   address 192.168.1.3 client-id "Gi1/0/3" ascii
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/2
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/3
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
--More--

Highlighted

I noticed that you named your DHCP pool Vlan2, are you using Vlan2 in the config? My guess would be that you don't have the ports setup for Vlan2, hence the reason they are not getting DCHP.

Try putting the 3 ports in vlan 2 and see what happens.

Switchport access vlan 2

since hte bottom part of the config is missing I thinking that you have an interface vlan2 with an ip address.

Highlighted

Jamescox3, thanks so much for fast response. Can you tell me how to do that, I' m so new to the CLI.

Thanks

Highlighted

Could you post the full config from the switch

Highlighted

Sure,

Switch#show running-config
Building configuration...

Current configuration : 1892 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
switch 1 provision ws-c2960s-24ts-l
ip dhcp use subscriber-id client-id
ip dhcp subscriber-id interface-name
!
ip dhcp pool vlan2
   network 192.168.1.0 255.255.255.0
   address 192.168.1.1 client-id "Gi1/0/1" ascii
   address 192.168.1.2 client-id "Gi1/0/2" ascii
   address 192.168.1.3 client-id "Gi1/0/3" ascii
!
ip dhcp pool vlan1
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0
no ip address
!
interface GigabitEthernet1/0/1
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/2
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/3
ip dhcp server use subscriber-id client-id
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
ip http server
ip http secure-server
!
line con 0
line vty 5 15
!
end

Switch#

Highlighted

Hi,

config t

int range g1/0/1 -3

switchport mode access

switchport access vlan 2

exit

int vlan 2

ip address 192.168.1.x

Regards.

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

View solution in original post

Highlighted

Working now. Thanks for all your help

Highlighted

@PhuongTrinh Hi, I am trying to achieve the same. but I am having trouble where the last byte of the interface name is lost (32). Please advise.

VRF: IP address Client-ID/ Lease expiration Type Hardware address/ User name 192.168.100.1 0047.6931.2f30.2f Jan 09 2016 04:53 AM Automatic 192.168.100.5 0047.6931.2f30.2f32 Infinite Manual'

Content for Community-Ad