11-03-2011 07:47 AM - edited 03-07-2019 03:11 AM
Dear all,
I am trying to implement policing on some ports on a 3560 to limit the amount of bandwidth (e.g. 2M; 8M or 16M) a connected device can send into our network.
My problem is that the policy map doesn't police properly. The configured bandwidth has no influence on the throughput.
Ive tried implementing this in a number of different ways:
* aggregate policers
* policy map using a class
* policy map using class-default
Unfortunately srr-queue is not suitable for my deployment as it is not as granular as I need it to be.
And I do have "mls qos" enabled, tried rebooting the switch after enabling this command, tried ipbase and ipservices images, but nothing.
Hereby some examples of configurations I tested so far:
- - - - - - - - - #1
class-map match-any any-any
match access-group name ip-any-any
!
policy-map police-8mbit-in
class any-any
police 8000000 8000 exceed-action drop
!
interface GigabitEthernet0/1
service-policy input police-8mbit-in
!
ip access-list extended ip-any-any
permit ip any any
!
- - - - - - - - - #2
class-map match-any any-any
match access-group 99
!
policy-map police-8mbit-in
class any-any
police 8000000 8000 exceed-action drop
!
interface GigabitEthernet0/1
service-policy input police-8mbit-in
!
access-list 99 permit ip any
!
- - - - - - - - - #3
policy-map police-8mbit-in
class class-default
police 8000000 8000 exceed-action drop
!
interface GigabitEthernet0/1
service-policy input police-8mbit-in
!
- - - - - - - - - #4
mls qos aggregate-policer 8mbit 8000000 8000 exceed-action drop
!
policy-map police-8mbit-in
class class-default
police aggregate 8mbit
!
interface GigabitEthernet0/1
service-policy input police-8mbit-in
!
... and so on.
Everything I have tried just doesnt seem to work. The maximum transfer rate stays at 0.12 Mbit/s. Without any policy I could create up to 94 Mbit/s.
I already tried to change the burst value, but it seems that this have no infulence on my transfer rate.
Can someone tell me what Im doing wrong? Im pulling my hair out over this. :-)
Thanks,
Johannes
11-03-2011 10:08 AM
Johannes
Can you try this, I'm sure this worked before for me
!
mls qos
!
policy-map POLICE-8MEG
class class-default
police 8000000 8000 exceed-action drop
!
!
interface gig 0/1
description ### Police to 8 Mbps ###
service-policy input POLICE-8MEG
!
HTH
alex
11-04-2011 12:27 AM
Alex,
your config looks like my example #3. I have tested it anyway, but without success. My transfer rate stays at 0.12 Meg.
Maybe you've another config?
Johannes
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide