04-30-2014 08:24 AM - edited 03-07-2019 07:17 PM
Hi guys,
I have a doubt about trunk and port-channel:
Which configuration is correct to do a port-channel with trunk between two Gi ports ?
Configuration a)
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
Configuration b)
interface Port-channel1
!
interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface GigabitEthernet1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
Maybe both are correct but I don't know the difference...
thanks Davide
Solved! Go to Solution.
04-30-2014 09:55 AM
That is correct. Once you configure it under the portchannel, the same command should show up under the physical links.
HTH
04-30-2014 09:00 AM
Hi,
a is correct. When you configure a portchannel, you apply all the configs under the portchannel interface and the physical interfaces inherit the config from the portchannel.
for example
if you want to configure all the ports as trunk, you add the config to the portchannel and then physical ports inherit that. No need to add the command manually to each physical interface.
HTH
04-30-2014 09:10 AM
If I understand I don't need to configure trunk in physical interface:
The correct configuration is:
interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/1
channel-group 1 mode active
!
interface GigabitEthernet1/0/2
channel-group 1 mode active
!
04-30-2014 09:55 AM
That is correct. Once you configure it under the portchannel, the same command should show up under the physical links.
HTH
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide