cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
28676
Views
5
Helpful
5
Replies

Catalyst 9200 IOS install

EunjinBae09320
Beginner
Beginner

Hi,

 

I have factory reset the Catalyst 9200 and now I don't have IOS file there.

I know it sounds dumb but can someone help me to install the IOS file there again?

 

I have tried various things with googling, looking at Catalyst 9200 document, watching Youtube.

 

Somehow I didn't make it work.

I can't use flash command from here and it doesn't give me dir: flash.

I have set IPs on my laptop and switch. Somehow the switch detected the laptop but it was just once. I have attached the xmodem log file.

 

Do you guys have any idea how to install this?

 

Log file here as attachment is sometimes annoying.

================================================


switch: set ?
Usage: set <variable name> <value>
No arguments will list all environment variables
switch: ping 10.31.115.234
Ethernet link down!..
Failed to ping 10.31.115.234
switch: pingn 10.31.115.234
Error: command 'pingn' not found. Use 'help' to list commands.
switch: ?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: set_ip 10.31.115.235
Error: command 'set_ip' not found. Use 'help' to list commands.
switch: set ip_address 10.31.115.235
switch: set subnet_mask 255.255.255.0
switch: ping 10.31.115.234
Pinging 10.31.115.234
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.234

switch: set ip_address 10.31.115.234
switch: set subnet_mask 255.255.255.0
switch: ping 10.31.115.234
Pinging 10.31.115.234
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.234
switch: ping 10.31.115.234
Pinging 10.31.115.234
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.234
switch:
switch: set ip_subnet_mask 255.255.255.0
switch: set ip_address 10.31.115.234
switch: ping 10.31.115.234
Pinging 10.31.115.234
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.234
switch: set ip_address 10.31.115.235
switch: set ip_subnet_mask 255.255.255.0
switch: ping 10.31.115.234
Pinging 10.31.115.234
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.234
switch:
switch:
switch:
switch: set IP_ADDRESS 10.31.115.235
switch: set IP_SUBNET_MASK 255.255.255.0
switch: set DEFAULT_GATEWAY 10.31.115.1
switch: ping 10.31.115.234
Pinging 10.31.115.234
ICMP: Arp request failed!
Failed to ping 10.31.115.234
switch: ping 10.31.115.234
Pinging 10.31.115.234
ICMP: Arp request failed!
Failed to ping 10.31.115.234
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.235
Pinging 10.31.115.235
!!!!
10.31.115.235 is alive!
Failed to ping 10.31.115.235
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.235
Pinging 10.31.115.235
!!!!
10.31.115.235 is alive!
Failed to ping 10.31.115.235
switch: sh ?
Error: command 'sh' not found. Use 'help' to list commands.
switch: arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
................. ................. ............
switch: copy xmodem: flash:cat9k_lite_iosxe.16.10.01.SPA.bin
Unsupported destination device/filesystem.

switch: copy xmodem: flash:cat9k_lite_iosxe.16.10.01.SPA.bin
Unsupported destination device/filesystem.

switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236

switch: arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
E8:6A:64:DF:1E:B1 10.31.115.236 182
................. ................. ............
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.235
Pinging 10.31.115.235
!!!!
10.31.115.235 is alive!
Failed to ping 10.31.115.235
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch:arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
................. ................. ............
switch: arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
................. ................. ............
switch: set DEFAULT_GATEWAY 10.31.115.1
switch: arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
................. ................. ............
switch: set IP_ADDRESS 10.31.115.235
switch: set IP_SUBNET_MASK 255.255.255.0
switch: arp

MAC Address IP Address Age(Seconds)
----------------- ----------------- ------------
................. ................. ............
switch: ping 10.31.115.235
Pinging 10.31.115.235
!!!!
10.31.115.235 is alive!
Failed to ping 10.31.115.235
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
!ICMP: Request Timed Out....
Failed to ping 10.31.115.236
switch: ping 10.31.115.236
Pinging 10.31.115.236
!ICMP: Request Timed Out....
!

1 Accepted Solution

Accepted Solutions

Hi Meheretab,

 

Thanks for the recap. Yes that is correct.

I did a bit of work around as well such as disabling all firewalls on Windows.

I have bold the commands that are important.

 

Pre set up is as below.

 

- Tera Term used for xmodem.

- Console to USB mini B type

- MGMT to laptop Ethernet

 


switch: dir ?
usage:
dir <path-to-directory>
switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: dir usbflash0:
Error: missing MBR on "usbflash0:" physical disk; use 'format' to fix.
Error[11]: Failed to open directory!
switch: set ?
Usage: set <variable name> <value>
No arguments will list all environment variables
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: dir ?
usage:
dir <path-to-directory>
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch:
switch: ?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: version

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: copy xmodem: flash:cat9k_lite_iosxe.16.10.01.SPA.bin
Unsupported destination device/filesystem.
switch: set IP_ADDRESS 192.168.55.3/255.255.255.0
Can't set variable "IP_ADDRESS" to "192.168.55.3/255.255.255.0".
switch: set IP_ADDRESS 192.168.55.3
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_address
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset DEFAULT_GATEWAY
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: ping 192.168.55.2
Pinging 192.168.55.2
!!!!
192.168.55.2 is alive!
switch: boot tftp
boot: attempting to boot from [tftp]
switch:
switch: copy tftp flash
Unsupported destination device/filesystem.
switch: copy tftp flash:
Unsupported destination device/filesystem.
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1

switch: i

Are you sure you want to reset the system (y/n)? y
Please wait while the system restarts.

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

WARNING: Bootable URL's in BOOT variable not found or exhausted.
Please check the ROMMON configuration or boot command usage.
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: boot tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin
boot: attempting to boot from [tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin]
Filename : /cat9k_lite_iosxe.16.10.01.SPA.bin
IpAddress : 192.168.55.3
TftpServer : 192.168.55.2
TftpBlkSize : 1468
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!*
File Size : 346617733

Both links down, not waiting for other switches
Switch number is 1

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

Cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

 

Cisco IOS Software [Gibraltar], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.10.1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Wed 14-Nov-18 06:35 by mcpre

 

PLEASE READ THE FOLLOWING TERMS CAREFULLY. INSTALLING THE LICENSE OR
LICENSE KEY PROVIDED FOR ANY CISCO SOFTWARE PRODUCT, PRODUCT FEATURE,
AND/OR SUBSEQUENTLY PROVIDED SOFTWARE FEATURES (COLLECTIVELY, THE
"SOFTWARE"), AND/OR USING SUCH SOFTWARE CONSTITUTES YOUR FULL
ACCEPTANCE OF THE FOLLOWING TERMS. YOU MUST NOT PROCEED FURTHER IF YOU
ARE NOT WILLING TO BE BOUND BY ALL THE TERMS SET FORTH HEREIN.

Your use of the Software is subject to the Cisco End User License Agreement
(EULA) and any relevant supplemental terms (SEULA) found at
http://www.cisco.com/c/en/us/about/legal/cloud-and-software/software-terms.html.

You hereby acknowledge and agree that certain Software and/or features are
licensed for a particular term, that the license to such Software and/or
features is valid only for the applicable term and that such Software and/or
features may be shut down or otherwise terminated by Cisco after expiration
of the applicable license term (e.g., 90-day trial period). Cisco reserves
the right to terminate any such Software feature electronically or by any
other means available. While Cisco may provide alerts, it is your sole
responsibility to monitor your usage of any such term Software feature to
ensure that your systems and networks are prepared for a shutdown of the
Software feature.


% Failed to initialize nvram
% Failed to initialize backup nvram
cisco C9200-24T (ARM64) processor with 875158K/3071K bytes of memory.
FIPS: Flash Key Check : Key Not Found, FIPS Mode Not Enabled

Processor board ID JAD231305KV
2048K bytes of non-volatile configuration memory.
4060256K bytes of physical memory.
819200K bytes of Crash Files at crashinfo:.
1941504K bytes of Flash at flash:.
0K bytes of WebUI ODM Files at webui:.

Base Ethernet MAC Address : dc:8c:37:bb:46:80
Motherboard Assembly Number : 73-18794-04
Motherboard Serial Number : JAD231305KV
Model Revision Number : A1
Motherboard Revision Number : A0
Model Number : C9200-24T
System Serial Number : JAD231305KV


%INIT: waited 0 seconds for NVRAM to be available


--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

Enter host name [Switch]: cisco_test_cooking

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: ***********

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: ***********

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: ***********
Configure SNMP Network Management? [no]: no

Current interface summary

View solution in original post

5 Replies 5

Meheretab Mengistu
Rising star
Rising star

 

If you have the IOS file on usb, you can boot from the usb and copy the .bin file from usbflash0: to flash:

Please share the output of the following commands so that I could advise further:

1) Check dir flash:  and  dir usbflash0: If no file shows up,  simply check  dir

2) Check set  (simply press enter after set)

 

HTH,

Meheretab

HTH,
Meheretab

Hi Meheretab,

 

Thanks for your response.

I have made it work for installation.

I will probably share the log file for future reference if there's anyone struggling with this.

 


switch: dir ?
usage:
dir <path-to-directory>
switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: dir usbflash0:
Error: missing MBR on "usbflash0:" physical disk; use 'format' to fix.
Error[11]: Failed to open directory!
switch: set ?
Usage: set <variable name> <value>
No arguments will list all environment variables
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: dir ?
usage:
dir <path-to-directory>
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch:
switch: ?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: dir usbflash0:
Error: missing MBR on "usbflash0:" physical disk; use 'format' to fix.
Error[22]: Failed to open directory!
switch: dir usbflash1:
Error: missing MBR on "usbflash1:" physical disk; use 'format' to fix.
Error[11]: Failed to open directory!
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch: copy ?
Usage: copy <src file> <dest file>
switch: copy usbflash0: flash:
Unsupported destination device/filesystem.
switch:


switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch:
switch:
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: ?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: dir bootflash:
Error: cannot list filesystem path
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch: show ?
Error: command 'show' not found. Use 'help' to list commands.


switch: version

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: copy xmodem: flash:cat9k_lite_iosxe.16.10.01.SPA.bin
Unsupported destination device/filesystem.
switch: set IP_ADDRESS 192.168.55.3/255.255.255.0
Can't set variable "IP_ADDRESS" to "192.168.55.3/255.255.255.0".
switch: set IP_ADDRESS 192.168.55.3
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_address
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset DEFAULT_GATEWAY
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: ping 192.168.55.2
Pinging 192.168.55.2
!!!!
192.168.55.2 is alive!
switch: ping 192.168.55.2
Pinging 192.168.55.2
!!!!
192.168.55.2 is alive!
switch: boot tftp
boot: attempting to boot from [tftp]
switch:
switch: copy tftp flash
Unsupported destination device/filesystem.
switch: copy tftp flash:
Unsupported destination device/filesystem.
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch: help
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from host
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: i

Are you sure you want to reset the system (y/n)? y
Please wait while the system restarts.

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

WARNING: Bootable URL's in BOOT variable not found or exhausted.
Please check the ROMMON configuration or boot command usage.
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: boot tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin
boot: attempting to boot from [tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin]
Filename : /cat9k_lite_iosxe.16.10.01.SPA.bin
IpAddress : 192.168.55.3
TftpServer : 192.168.55.2
TftpBlkSize : 1468
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!*
File Size : 346617733

Both links down, not waiting for other switches
Switch number is 1

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

Cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

 

Cisco IOS Software [Gibraltar], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.10.1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Wed 14-Nov-18 06:35 by mcpre

 

PLEASE READ THE FOLLOWING TERMS CAREFULLY. INSTALLING THE LICENSE OR
LICENSE KEY PROVIDED FOR ANY CISCO SOFTWARE PRODUCT, PRODUCT FEATURE,
AND/OR SUBSEQUENTLY PROVIDED SOFTWARE FEATURES (COLLECTIVELY, THE
"SOFTWARE"), AND/OR USING SUCH SOFTWARE CONSTITUTES YOUR FULL
ACCEPTANCE OF THE FOLLOWING TERMS. YOU MUST NOT PROCEED FURTHER IF YOU
ARE NOT WILLING TO BE BOUND BY ALL THE TERMS SET FORTH HEREIN.

Your use of the Software is subject to the Cisco End User License Agreement
(EULA) and any relevant supplemental terms (SEULA) found at
http://www.cisco.com/c/en/us/about/legal/cloud-and-software/software-terms.html.

You hereby acknowledge and agree that certain Software and/or features are
licensed for a particular term, that the license to such Software and/or
features is valid only for the applicable term and that such Software and/or
features may be shut down or otherwise terminated by Cisco after expiration
of the applicable license term (e.g., 90-day trial period). Cisco reserves
the right to terminate any such Software feature electronically or by any
other means available. While Cisco may provide alerts, it is your sole
responsibility to monitor your usage of any such term Software feature to
ensure that your systems and networks are prepared for a shutdown of the
Software feature.


% Failed to initialize nvram
% Failed to initialize backup nvram
cisco C9200-24T (ARM64) processor with 875158K/3071K bytes of memory.
FIPS: Flash Key Check : Key Not Found, FIPS Mode Not Enabled

Processor board ID JAD231305KV
2048K bytes of non-volatile configuration memory.
4060256K bytes of physical memory.
819200K bytes of Crash Files at crashinfo:.
1941504K bytes of Flash at flash:.
0K bytes of WebUI ODM Files at webui:.

Base Ethernet MAC Address : dc:8c:37:bb:46:80
Motherboard Assembly Number : 73-18794-04
Motherboard Serial Number : JAD231305KV
Model Revision Number : A1
Motherboard Revision Number : A0
Model Number : C9200-24T
System Serial Number : JAD231305KV


%INIT: waited 0 seconds for NVRAM to be available


--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

Enter host name [Switch]: cisco_test_cooking

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: ***********

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: ***********

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: ***********
Configure SNMP Network Management? [no]: no

Current interface summary

Interface IP-Address OK? Method Status Protocol
Vlan1 192.168.1.1 YES TFTP up down
GigabitEthernet0/0 unassigned YES unset up up
GigabitEthernet1/0/1 unassigned YES unset down down
GigabitEthernet1/0/2 unassigned YES unset down down
GigabitEthernet1/0/3 unassigned YES unset down down
GigabitEthernet1/0/4 unassigned YES unset down down
GigabitEthernet1/0/5 unassigned YES unset down down
GigabitEthernet1/0/6 unassigned YES unset down down
GigabitEthernet1/0/7 unassigned YES unset down down
GigabitEthernet1/0/8 unassigned YES unset down down
GigabitEthernet1/0/9 unassigned YES unset down down
GigabitEthernet1/0/10 unassigned YES unset down down
GigabitEthernet1/0/11 unassigned YES unset down down
GigabitEthernet1/0/12 unassigned YES unset down down
GigabitEthernet1/0/13 unassigned YES unset down down
GigabitEthernet1/0/14 unassigned YES unset down down
GigabitEthernet1/0/15 unassigned YES unset down down
GigabitEthernet1/0/16 unassigned YES unset down down
GigabitEthernet1/0/17 unassigned YES unset down down
GigabitEthernet1/0/18 unassigned YES unset down down
GigabitEthernet1/0/19 unassigned YES unset down down
GigabitEthernet1/0/20 unassigned YES unset down down
GigabitEthernet1/0/21 unassigned YES unset down down
GigabitEthernet1/0/22 unassigned YES unset down down
GigabitEthernet1/0/23 unassigned YES unset down down
GigabitEthernet1/0/24 unassigned YES unset down down
GigabitEthernet1/1/1 unassigned YES unset down down
GigabitEthernet1/1/2 unassigned YES unset down down
GigabitEthernet1/1/3 unassigned YES unset down down
GigabitEthernet1/1/4 unassigned YES unset down down
Te1/1/1 unassigned YES unset down down
Te1/1/2 unassigned YES unset down down
Te1/1/3 unassigned YES unset down down
Te1/1/4 unassigned YES unset down down

Enter interface name used to connect to the
management network from the above interface summary: GigabitEthernet1/0/1

Configuring interface GigabitEthernet1/0/1:
Configure IP on this interface? [no]: n

The following configuration command script was created:

hostname cisco_test_cooking
enable secret 9 $9$a0k3ijDfopc8vE$xTE2bjR8Ew.IM/RMWTbZpoHHofKTHTcHZTZ4yj8OG6I
enable password 
line vty 0 15
password 
no snmp-server
!
no ip routing

!
interface Vlan1
shutdown
no ip address
!
interface GigabitEthernet0/0
shutdown
no ip address
!
interface GigabitEthernet1/0/1
no switchport
no shutdown
no ip address
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
!
interface GigabitEthernet1/1/3
!
interface GigabitEthernet1/1/4
!
interface TenGigabitEthernet1/1/1
!
interface TenGigabitEthernet1/1/2
!
interface TenGigabitEthernet1/1/3
!
interface TenGigabitEthernet1/1/4
!
end


[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.

Enter your selection [2]: 2
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.

 


Press RETURN to get started!


*Sep 18 23:23:25.222: %CRYPTO_ENGINE-5-KEY_ADDITION: A key named TP-self-signed-3752601635 has been generated or imported by crypto-engine
*Sep 18 23:23:25.226: %SSH-5-ENABLED: SSH 1.99 has been enabled
*Sep 18 23:23:25.353: %PKI-4-NOCONFIGAUTOSAVE: Configuration was modified. Issue "write memory" to save new IOS PKI configuration
*Sep 18 23:23:25.500: %CRYPTO_ENGINE-5-KEY_ADDITION: A key named TP-self-signed-3752601635.server has been generated or imported by crypto-engine
cisco_test_cooking>ena
Password:
cisco_test_cooking#show dir
^
% Invalid input detected at '^' marker.

cisco_test_cooking#dir
Directory of flash:/

16194 drwx 4096 Sep 18 2019 23:17:37 +00:00 .installer
16196 -rw- 37 Sep 18 2019 23:17:40 +00:00 bootloader_evt_handle.log
16197 drwx 4096 Sep 18 2019 23:19:50 +00:00 core
16198 drwx 4096 Sep 18 2019 23:17:56 +00:00 .prst_sync
16200 drwx 4096 Sep 18 2019 23:17:55 +00:00 .rollback_timer
16203 drwx 4096 Sep 18 2019 23:17:57 +00:00 tech_support
16204 drwx 4096 Sep 18 2019 23:17:57 +00:00 dc_profile_dir
16206 -rw- 140 Sep 18 2019 23:17:58 +00:00 boothelper.log
16207 -rw- 131378 Sep 18 2019 23:18:16 +00:00 memleak.tcl
16209 drwx 4096 Sep 18 2019 23:19:24 +00:00 .dbpersist
16210 -rw- 2097152 Sep 18 2019 23:23:18 +00:00 nvram_config
16211 -rw- 2097152 Sep 18 2019 23:23:18 +00:00 nvram_config_bkup
16212 drwx 4096 Sep 18 2019 23:19:29 +00:00 onep
16214 -rw- 0 Sep 18 2019 23:19:30 +00:00 rdope_out.txt
16215 -rw- 89 Sep 18 2019 23:19:44 +00:00 rdope.log

1956839424 bytes total (1849892864 bytes free)
cisco_test_cooking#dir flash:
Directory of flash:/

16194 drwx 4096 Sep 18 2019 23:17:37 +00:00 .installer
16196 -rw- 37 Sep 18 2019 23:17:40 +00:00 bootloader_evt_handle.log
16197 drwx 4096 Sep 18 2019 23:19:50 +00:00 core
16198 drwx 4096 Sep 18 2019 23:17:56 +00:00 .prst_sync
16200 drwx 4096 Sep 18 2019 23:17:55 +00:00 .rollback_timer
16203 drwx 4096 Sep 18 2019 23:17:57 +00:00 tech_support
16204 drwx 4096 Sep 18 2019 23:17:57 +00:00 dc_profile_dir
16206 -rw- 140 Sep 18 2019 23:17:58 +00:00 boothelper.log
16207 -rw- 131378 Sep 18 2019 23:18:16 +00:00 memleak.tcl
16209 drwx 4096 Sep 18 2019 23:19:24 +00:00 .dbpersist
16210 -rw- 2097152 Sep 18 2019 23:23:18 +00:00 nvram_config
16211 -rw- 2097152 Sep 18 2019 23:23:18 +00:00 nvram_config_bkup
16212 drwx 4096 Sep 18 2019 23:19:29 +00:00 onep
16214 -rw- 0 Sep 18 2019 23:19:30 +00:00 rdope_out.txt
16215 -rw- 89 Sep 18 2019 23:19:44 +00:00 rdope.log

 

 

 

I am glad it is working for you, and thank you for sharing your solution! It will definitely help someone in the future.

Please allow me to recap what you did (in a couple of steps):-

 

1) Change the IP address of the switch so that it could reach to the TFTP server (I assumed you do not have USB drive which has .bin file, or for any reason it was not reading your usb drive.)

switch: set IP_ADDRESS 192.168.55.3
switch: set

 

2) Boot from the .bin file on the TFTP server

switch: boot tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin
boot: attempting to boot from [tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin]
Filename : /cat9k_lite_iosxe.16.10.01.SPA.bin
IpAddress : 192.168.55.3
TftpServer : 192.168.55.2
TftpBlkSize : 1468
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!*
File Size : 346617733

 

3) Follow the prompt on the switch

 

Please solve the ticket.

 

HTH,
Meheretab

Hi Meheretab,

 

Thanks for the recap. Yes that is correct.

I did a bit of work around as well such as disabling all firewalls on Windows.

I have bold the commands that are important.

 

Pre set up is as below.

 

- Tera Term used for xmodem.

- Console to USB mini B type

- MGMT to laptop Ethernet

 


switch: dir ?
usage:
dir <path-to-directory>
switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: dir usbflash0:
Error: missing MBR on "usbflash0:" physical disk; use 'format' to fix.
Error[11]: Failed to open directory!
switch: set ?
Usage: set <variable name> <value>
No arguments will list all environment variables
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: dir ?
usage:
dir <path-to-directory>
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1
switch:
switch: ?
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
arp Dump or Clear ARP Table
boot Load and boot an executable image
cat Display text content from a file
copy Copy a file
dir List filesystems or a directory on a filesystem path
help List command information
history Show command history
idprom Show idprom data
ping Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
ping6 Ping use ICMP protocol to get an ICMP ECHO_RESPONSE from ho st
reset Reset entire system or a soft reload of the boot CPU core
set Set an environment variable value
unset Unsets an environment variable
version Show sboot version and runtime info
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: version

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

switch: dir flash:

Attributes Size Name
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=10.31.115.235
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: copy xmodem: flash:cat9k_lite_iosxe.16.10.01.SPA.bin
Unsupported destination device/filesystem.
switch: set IP_ADDRESS 192.168.55.3/255.255.255.0
Can't set variable "IP_ADDRESS" to "192.168.55.3/255.255.255.0".
switch: set IP_ADDRESS 192.168.55.3
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_address=10.31.115.235
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_address
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
ip_subnet_mask=255.255.255.0
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset ip_subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
DEFAULT_GATEWAY=10.31.115.1
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset DEFAULT_GATEWAY
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
subnet_mask=255.255.255.0
switch: unset subnet_mask
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: ping 192.168.55.2
Pinging 192.168.55.2
!!!!
192.168.55.2 is alive!
switch: boot tftp
boot: attempting to boot from [tftp]
switch:
switch: copy tftp flash
Unsupported destination device/filesystem.
switch: copy tftp flash:
Unsupported destination device/filesystem.
switch: dir
usage:
dir <path-to-directory>
supported filesystem(s):
flash: flash
usbflash0: front-panel USB 0
usbflash1: front-panel USB 1

switch: i

Are you sure you want to reset the system (y/n)? y
Please wait while the system restarts.

System Bootstrap, Version 16.10.1r [FC4], RELEASE SOFTWARE (P)
Compiled Mon 12/03/2018 15:14:20 by rel

Current ROMMON image : Primary
C9200-24T platform with 4194304 Kbytes of main memory

WARNING: Bootable URL's in BOOT variable not found or exhausted.
Please check the ROMMON configuration or boot command usage.
switch: set
ABNORMAL_RESET_COUNT=0
BAUD=115200
IP_ADDRESS=192.168.55.3
IP_SUBNET_MASK=255.255.255.0
MAC_ADDR=DC:8C:37:BB:46:80
MODEL_NUM=C9200-24T
MOTHERBOARD_SERIAL_NUM=JAD231305KV
ROMMON_BOARDID=0x323
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=JAD231305KV
baud=57600
onment=variable value
ronment=variable value
switch: boot tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin
boot: attempting to boot from [tftp://192.168.55.2/cat9k_lite_iosxe.16.10.01.SPA.bin]
Filename : /cat9k_lite_iosxe.16.10.01.SPA.bin
IpAddress : 192.168.55.3
TftpServer : 192.168.55.2
TftpBlkSize : 1468
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!*
File Size : 346617733

Both links down, not waiting for other switches
Switch number is 1

Restricted Rights Legend

Use, duplication, or disclosure by the Government is
subject to restrictions as set forth in subparagraph
(c) of the Commercial Computer Software - Restricted
Rights clause at FAR sec. 52.227-19 and subparagraph
(c) (1) (ii) of the Rights in Technical Data and Computer
Software clause at DFARS sec. 252.227-7013.

Cisco Systems, Inc.
170 West Tasman Drive
San Jose, California 95134-1706

 

Cisco IOS Software [Gibraltar], Catalyst L3 Switch Software (CAT9K_LITE_IOSXE), Version 16.10.1, RELEASE SOFTWARE (fc3)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Wed 14-Nov-18 06:35 by mcpre

 

PLEASE READ THE FOLLOWING TERMS CAREFULLY. INSTALLING THE LICENSE OR
LICENSE KEY PROVIDED FOR ANY CISCO SOFTWARE PRODUCT, PRODUCT FEATURE,
AND/OR SUBSEQUENTLY PROVIDED SOFTWARE FEATURES (COLLECTIVELY, THE
"SOFTWARE"), AND/OR USING SUCH SOFTWARE CONSTITUTES YOUR FULL
ACCEPTANCE OF THE FOLLOWING TERMS. YOU MUST NOT PROCEED FURTHER IF YOU
ARE NOT WILLING TO BE BOUND BY ALL THE TERMS SET FORTH HEREIN.

Your use of the Software is subject to the Cisco End User License Agreement
(EULA) and any relevant supplemental terms (SEULA) found at
http://www.cisco.com/c/en/us/about/legal/cloud-and-software/software-terms.html.

You hereby acknowledge and agree that certain Software and/or features are
licensed for a particular term, that the license to such Software and/or
features is valid only for the applicable term and that such Software and/or
features may be shut down or otherwise terminated by Cisco after expiration
of the applicable license term (e.g., 90-day trial period). Cisco reserves
the right to terminate any such Software feature electronically or by any
other means available. While Cisco may provide alerts, it is your sole
responsibility to monitor your usage of any such term Software feature to
ensure that your systems and networks are prepared for a shutdown of the
Software feature.


% Failed to initialize nvram
% Failed to initialize backup nvram
cisco C9200-24T (ARM64) processor with 875158K/3071K bytes of memory.
FIPS: Flash Key Check : Key Not Found, FIPS Mode Not Enabled

Processor board ID JAD231305KV
2048K bytes of non-volatile configuration memory.
4060256K bytes of physical memory.
819200K bytes of Crash Files at crashinfo:.
1941504K bytes of Flash at flash:.
0K bytes of WebUI ODM Files at webui:.

Base Ethernet MAC Address : dc:8c:37:bb:46:80
Motherboard Assembly Number : 73-18794-04
Motherboard Serial Number : JAD231305KV
Model Revision Number : A1
Motherboard Revision Number : A0
Model Number : C9200-24T
System Serial Number : JAD231305KV


%INIT: waited 0 seconds for NVRAM to be available


--- System Configuration Dialog ---

Would you like to enter the initial configuration dialog? [yes/no]: yes

At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.


Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system

Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:

Enter host name [Switch]: cisco_test_cooking

The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: ***********

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: ***********

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: ***********
Configure SNMP Network Management? [no]: no

Current interface summary

Please help me out on the same issue. Thanks

switch: dir flash:
switch: dir usbflash0:
%ERROR: File system protocol not found on device (Unsupported)
ERROR: failed to read contents of usbflash0: (Unsupported)
switch: set
ABNORMAL_RESET_COUNT=0
BOARDID=24669
MAC_ADDR=4C:E1:76:83:C1:80
MODEL_NUM=C9300-24S
MODEL_REVISION_NUM=D0
MOTHERBOARD_ASSEMBLY_NUM=73-19407-04
MOTHERBOARD_REVISION_NUM=C0
MOTHERBOARD_SERIAL_NUM=FOC23524AP3
ROMMON_AUTOBOOT_ATTEMPT=0
SWITCH_NUMBER=1
SYSTEM_SERIAL_NUM=FOC2402X14R
VERSION_ID=V01
switch:

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers