cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
808
Views
0
Helpful
6
Replies

Changing IP address

kjefferson1
Level 1
Level 1

We are working on changing IP Address from 192.168.x.x to a 10.40.x.x and we have give all of the new subnet to AT&T but like to know what changes would we have to make on are Switches and ASA to make this go easy with out bring down the network

 

6 Replies 6

Seb Rupik
VIP Alumni
VIP Alumni

Hi there,

It depends on your Layer3 topology. Any L3 switches or routers will support secondary IP addresses on their interfaces. This will allow you to configure VLANs which can support more than one subnet at once. So for any VLAN/ L3 interface you can configure both a 192.168.0.0/16 and 10.40.0.0/16 address and migrate the hosts between the associated subnet without too much disruption.

 

The ASA does not support secondary IP addresses, so you will need to have an out of band method of connecting to the ASA (or console access) when you change its routed interface IP addresses.

 

cheers,

Seb.

Thank you we have two Nexus 3500 for are core switch and we are using a AT&T manage firewall and wealso have a Cisco ASA but only using it for VPN. so what we are looking to do is see what changes we need to make on are side as far as are switches. Not sure of the step that we need to do 

 

Hi there,

I suggest you work one routed interface (physical/ SVI) at a time.

 

For example if you had VLAN10 which used the subnet 192.168.10.0/24 and you wanted to migrate its hosts to 10.40.10.0./24, then configure the SVI like so:

!
interface vlan 10
  ip address 192.168.10.254 255.255.255.0
  ip address 10.40.10.254 255.255.255.0 secondary
!

Then start moving hosts on that VLAN to the new subnet. Either via static interface configuration on the devices themselves or through DHCP (ensuring that the new subnet scopes exist on the DHCP server).

Once the hosts are migrated, make a final change to the SVI:

!
interface vlan 10
  no ip address 192.168.10.254 255.255.255.0
  ip address 10.40.10.254 255.255.255.0
!

Make sure that any other routers in your network are aware of the new 10.40.0.0/16 subnet. Either update static routes or preferable advertise the new subnet via IGP.

 

Finally look at migrating the link to the firewall. As I previously said, the ASA does not support secondary IP addresses on interfaces so you would incur some loss of outbound connectivty whilst the ASA IP address was changed.

 

Are you running a IGP between the ASA and Nexus? If so there are some options we could explore to eliminate the disruption.

 

cheers,

Seb.

Thanks for the help

 

MPC-VV-N3K_Core1#show run
version 6.0(2)A1(1d)
hostname MPC-VV-N3K_Core1

feature telnet
feature tacacs+
cfs eth distribute
feature eigrp
feature udld
feature interface-vlan
feature hsrp
feature lacp
feature dhcp
feature vpc
feature lldp
feature vtp

username admin password 5 $1$vNhgf5xu$SNPyFtRDqgTvX2YQm.IN3. role network-admin
username nexus password 5 $1$wonwG9Tr$u5k9jfT2fRBGI2s5F6nNo1 role network-admin
username nexus role network-operator
username Advantel password 5 $1$.HixRnrx$aJakbuhqy0oCnDEImh4rA0 role network-ad
min
username MarianiAdmin password 5 $1$oBVRP74l$IVvW3WOq1OJIkSLWN0nFu/ role networ
k-admin
username sosadmin password 5 $1$w5Ahx406$hCqY8jprATlg5OH4sdV2B0 role network-ad
min
username rthornton password 5 $1$PHCBCP9Y$5ceALv3EgLETWoVh03LLq0 role network-a
dmin
no password strength-check
ip domain-lookup
ip domain-name mariani.com
ip name-server 68.94.156.1 68.94.157.1
radius-server key 7 "Q3bzk4omsF0w3O3sp3f"
radius-server host 10.1.120.17 authentication accounting
aaa group server radius RADIUSServers
server 10.1.120.17
source-interface Vlan10
ip access-list Vlan200-Input
10 permit ip 10.1.200.0/24 10.1.100.15/32
20 permit ip 10.1.200.0/24 10.1.120.0/24
30 deny ip any any log
ip access-list copp-system-acl-eigrp
10 permit eigrp any any
ip access-list copp-system-acl-ftp
10 permit tcp any any eq ftp-data
20 permit tcp any any eq ftp
30 permit tcp any eq ftp-data any
40 permit tcp any eq ftp any
ip access-list copp-system-acl-http
10 permit tcp any any eq www
20 permit tcp any any eq 443
ip access-list copp-system-acl-icmp
10 permit icmp any any
ip access-list copp-system-acl-ntp
10 permit udp any any eq ntp
20 permit udp any eq ntp any
ip access-list copp-system-acl-ping
10 permit icmp any any echo
20 permit icmp any any echo-reply
ip access-list copp-system-acl-routingproto1
10 permit tcp any any eq bgp
20 permit tcp any eq bgp any
30 permit tcp any any eq 639
40 permit tcp any eq 639 any
50 permit ospf any any
ip access-list copp-system-acl-routingproto2
10 permit 112 any 224.0.0.0/24
ip access-list copp-system-acl-snmp
10 permit udp any any eq snmp
20 permit udp any eq snmp any
30 permit udp any any eq snmptrap
ip access-list copp-system-acl-ssh
10 permit tcp any any eq 22
20 permit tcp any eq 22 any
ip access-list copp-system-acl-stftp
10 permit udp any any eq tftp
20 permit udp any any eq 1758
30 permit udp any eq tftp any
40 permit udp any eq 1758 any
50 permit tcp any any eq 115
60 permit tcp any eq 115 any
ip access-list copp-system-acl-tacacsradius
10 permit tcp any any eq tacacs
20 permit tcp any eq tacacs any
30 permit udp any any eq 1812
40 permit udp any any eq 1813
50 permit udp any any eq 1645
60 permit udp any any eq 1646
70 permit udp any eq 1812 any
80 permit udp any eq 1813 any
90 permit udp any eq 1645 any
100 permit udp any eq 1646 any
ip access-list copp-system-acl-telnet
10 permit tcp any any eq telnet
20 permit tcp any any eq 107
30 permit tcp any eq telnet any
40 permit tcp any eq 107 any
ip access-list copp-system-dhcp-relay
10 permit udp any eq bootps any eq bootps
class-map type qos match-all copp-ftp
class-map type qos match-all copp-ntp
class-map type qos match-all copp-ssh
class-map type qos match-all copp-http
class-map type qos match-all copp-icmp
class-map type qos match-all copp-snmp
class-map type qos match-all copp-s-arp
class-map type qos match-all copp-s-cdp
class-map type qos match-all copp-s-ptp
class-map type qos match-all copp-stftp
class-map type qos match-all copp-s-bpdu
class-map type qos match-all copp-s-igmp
class-map type qos match-all copp-s-lacp
class-map type qos match-all copp-s-lldp
class-map type qos match-all copp-s-ping
class-map type qos match-all copp-s-ttl1
class-map type qos match-all copp-telnet
class-map type qos match-all copp-s-eigrp
class-map type qos match-all copp-s-glean
class-map type qos match-all copp-s-ip-nat
class-map type qos match-all copp-s-pimreg
class-map type qos match-all copp-s-default
class-map type qos match-all copp-s-dhcpreq
class-map type qos match-all copp-s-dhcpresp
class-map type qos match-all copp-s-ipmcmiss
class-map type qos match-all copp-s-l3mtufail
class-map type qos match-all copp-s-pimautorp
class-map type qos match-all copp-s-ip-options
class-map type qos match-all copp-s-ipmc-g-hit
class-map type qos match-all copp-s-l3destmiss
class-map type qos match-all copp-tacacsradius
class-map type qos match-all copp-s-routingProto1
class-map type qos match-all copp-s-routingProto2
class-map type qos match-all copp-s-ipmc-rpf-fail-g
class-map type qos match-all copp-s-ipmc-rpf-fail-sg
class-map type control-plane match-any cop
match access-group name copp-system-acl-stftp
match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-ftp
match access-group name copp-system-acl-ftp
class-map type control-plane match-any copp-http
match access-group name copp-system-acl-http
class-map type control-plane match-any copp-icmp
match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-cdp
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
match access-group name copp-system-dhcp-relay
class-map type control-plane match-any copp-s-eigrp
match access-group name copp-system-acl-eigrp
class-map type control-plane match-any copp-s-glea
class-map type control-plane match-any copp-s-glean
class-map type control-plane match-any copp-s-i
class-map type control-plane match-any copp-s-igmp
class-map type control-plane match-any copp-s-ip-n
class-map type control-plane match-any copp-s-ip-nat
class-map type control-plane match-any copp-s-ip-options
class-map type control-plane match-any copp-s-ipmc-g-hit
class-map type control-plane match-any copp-s-ipmc-rpf-fail-g
class-map type control-plane match-any copp-s-ipmc-rpf-fail-sg
class-map type control-plane match-any copp-s-ipmcmiss
class-map type control-plane match-any copp-s-l3destmiss
class-map type control-plane match-any copp-s-l3mtufail
class-map type control-plane match-any copp-s-lacp
class-map type control-plane match-any copp-s-lldp
class-map type control-plane match-any copp-s-pimautorp
class-map type control-plane match-any copp-s-pimreg
class-map type control-plane match-any copp-s-ping
match access-group name copp-system-acl-ping
class-map type control-plane match-any copp-s-ptp
class-map type control-plane match-any copp-s-routingProto1
match access-group name copp-system-acl-routingproto1
class-map type control-plane match-any copp-s-routingProto2
match access-group name copp-system-acl-routingproto2
class-map type control-plane match-any copp-s-ttl
match access-group name copp-system-acl-ssh
match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-s-ttl1
class-map type control-plane match-any copp-snmp
match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-ssh
match access-group name copp-system-acl-ssh
class-map type control-plane match-any copp-stftp
match access-group name copp-system-acl-stftp
class-map type control-plane match-any copp-tacacsradius
match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-telnet
match access-group name copp-system-acl-telnet
policy-map type control-plane copp-system-policy
class copp-s-default
police pps 400
class copp-s-ping
police pps 100
class copp-s-l3destmiss
police pps 100
class copp-s-glean
police pps 500
class copp-s-l3mtufail
police pps 100
class copp-s-ttl1
police pps 100
class copp-s-ip-options
police pps 100
class copp-s-ip-nat
police pps 100
class copp-s-ipmcmiss
police pps 400
class copp-s-ipmc-g-hit
police pps 400
class copp-s-ipmc-rpf-fail-g
police pps 400
class copp-s-ipmc-rpf-fail-sg
police pps 400
class copp-s-dhcpreq
police pps 300
class copp-s-dhcpresp
police pps 300
class copp-s-igmp
police pps 400
class copp-s-routingProto2
police pps 1300
class copp-s-eigrp
police pps 200
class copp-s-pimreg
police pps 200
class copp-s-pimautorp
police pps 200
class copp-s-routingProto1
police pps 1000
class copp-s-arp
police pps 200
class copp-s-ptp
police pps 1000
class copp-s-bpdu
police pps 12000
class copp-s-cdp
police pps 400
class copp-s-lacp
police pps 400
class copp-s-lldp
police pps 200
class copp-icmp
police pps 200
class copp-telnet
police pps 500
class copp-ssh
police pps 500
class copp-snmp
police pps 500
class copp-ntp
police pps 100
class copp-tacacsradius
police pps 400
class copp-stftp
police pps 400
class copp-ftp
police pps 100
class copp-http
police pps 100
control-plane
service-policy input copp-system-policy
vtp mode transparent
vtp domain Mariani
snmp-server contact admin
snmp-server location MDF
snmp-server user admin network-admin auth md5 0xef671263543c829f7bbf1a1a46057a6c
priv 0xef671263543c829f7bbf1a1a46057a6c localizedkey
snmp-server user nexus network-admin auth md5 0xa4fef1663a0e64dd5e00422571c6d6d4
priv 0xa4fef1663a0e64dd5e00422571c6d6d4 localizedkey
snmp-server user nexus network-operator
snmp-server user Advantel network-admin auth md5 0x01e8d9cba3782d54437c1a62d728e
b71 localizedkey
snmp-server user sosadmin network-admin auth md5 0x4a95acdb294e364d2c03e9a66d369
bc8 priv 0x4a95acdb294e364d2c03e9a66d369bc8 localizedkey
snmp-server user rthornton network-admin auth md5 0x4a95acdb294e364d2c03e9a66d36
9bc8 priv 0x4a95acdb294e364d2c03e9a66d369bc8 localizedkey
snmp-server user MarianiAdmin network-admin auth md5 0x27c942b9abd72f97503f39587
5d2f6a9 priv 0x27c942b9abd72f97503f395875d2f6a9 localizedkey
snmp-server host 10.1.100.15 traps version 2c MarianiNetTrap
snmp-server community mariani-private group network-admin
snmp-server community MarianiNetRO group network-operator
snmp-server community mariani-public group network-operator
ntp server 10.1.120.18
ntp server 164.67.62.194
ntp server 192.83.249.28
ntp server 204.74.68.55
aaa authentication login default group RADIUSServers local
aaa authentication login console local
aaa accounting default group RADIUSServers
aaa authentication login error-enable

vrf context management
vrf context peer-keepalive
vlan 1
vlan 10
name Management
vlan 11
name Voice
vlan 12
name Data
vlan 13
name Admin
vlan 14
name WLAN
vlan 15
name Inet_Connect
vlan 16
name INET_Xconnect
vlan 20-21
vlan 100
name Monitoring
vlan 105
name wireless
vlan 110
name VoIP
vlan 120
name Servers1
vlan 121
name Servers2
vlan 130
name User1
vlan 131
name User2
vlan 140
name Wireless
vlan 150
name Guest
vlan 200
name Plant_Equipment
vlan 400
name SQLPrivate
vlan 501
name MGNT
vlan 502
name CCTV
vlan 503
vlan 504
name Wireless-Guest
vlan 508
vlan 512
name Wireless-MGNT
vlan 513-514,516
vlan 532
name Data-IDF1
vlan 536,540,544,548,552,556,560,564,568,572,576
vlan 580
name Wireless-CORP
vlan 584
name Wireless-Redzone
vlan 588
vlan 998
name DMZ
vlan 999
name Trunk_Native
service dhcp
ip dhcp relay
vpc domain 100
peer-switch
role priority 1000
system-priority 4000
peer-keepalive destination 172.16.100.2 source 172.16.100.1 vrf peer-keepalive
peer-gateway


interface Vlan1
no ip redirects

interface Vlan10
description Manage
no shutdown
ip address 10.1.10.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 10
preempt
priority 105
ip 10.1.10.1
ip dhcp relay address 10.1.12.2

interface Vlan11
description Voice
no shutdown
ip address 10.1.11.252/24
hsrp 11
preempt
priority 105
ip 10.1.11.2
ip dhcp relay address 10.1.11.1

interface Vlan12
description Data
no shutdown
ip address 10.1.12.250/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 12
preempt
priority 105
ip 10.1.12.1
ip dhcp relay address 10.1.12.2

interface Vlan13
description Admin
no shutdown
ip address 10.1.13.254/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 13
preempt
priority 105
ip 10.1.13.1
ip dhcp relay address 10.1.12.2

interface Vlan14
description WLAN
no shutdown
ip address 10.1.14.254/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 14
preempt
priority 105
ip 10.1.14.1
ip dhcp relay address 10.1.12.2

interface Vlan15
description MPLS_Xconnec
no shutdown
ip address 192.168.1.253/24
hsrp version 2
hsrp 15
preempt
priority 105
ip 192.168.1.2

interface Vlan16
description INET_Xconnect:10.1.1.0/24
no shutdown
ip address 10.1.1.254/24
ip router eigrp 100
hsrp version 2
hsrp 16
preempt
priority 105
ip 10.1.1.1

interface Vlan20
no shutdown
ip address 10.1.20.253/24
hsrp 20
preempt
priority 105
ip 10.1.20.1

interface Vlan21
no shutdown
ip address 10.1.21.253/24
hsrp version 2
hsrp 21
preempt
priority 105
ip 10.1.21.1

interface Vlan100
description Monitoring
no shutdown
ip address 10.1.100.254/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 100
preempt delay minimum 60 reload 300
priority 250
ip 10.1.100.1
ip dhcp relay address 10.1.120.17

interface Vlan105
description Network_Equipment
no shutdown
ip address 10.1.105.254/24
ip router eigrp 10
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 105
preempt delay minimum 60 reload 300
priority 250
ip 10.1.105.1
ip dhcp relay address 10.1.120.17

interface Vlan110
description VoIP
no shutdown
ip address 10.1.110.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 110
preempt delay minimum 60 reload 300
priority 250
ip 10.1.110.1
ip dhcp relay address 10.1.120.17

interface Vlan120
description Servers1
no shutdown
ip address 10.1.120.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 120
preempt delay minimum 60 reload 300
priority 250
ip 10.1.120.1
ip dhcp relay address 10.1.120.17

interface Vlan121
description Servers2
no shutdown
ip address 10.1.121.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 121
preempt delay minimum 60 reload 300
priority 250
ip 10.1.121.1
ip dhcp relay address 10.1.120.17

interface Vlan130
description User1
no shutdown
ip address 10.1.130.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 130
preempt delay minimum 60 reload 300
priority 250
ip 10.1.130.1
ip dhcp relay address 10.1.120.17

interface Vlan131
description User2
no shutdown
ip address 10.1.131.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 131
preempt delay minimum 60 reload 300
priority 250
ip 10.1.131.1
ip dhcp relay address 10.1.120.17

interface Vlan140
description Wireless
no shutdown
ip address 10.1.140.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 140
preempt delay minimum 60 reload 300
priority 250
ip 10.1.140.1
ip dhcp relay address 10.1.120.17

interface Vlan150
description Guest
no shutdown
ip address 10.1.150.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 140
preempt delay minimum 60 reload 300
priority 250
ip 10.1.150.1
ip dhcp relay address 10.1.120.17

interface Vlan200
description Plant_Equipment
no shutdown
ip access-group Vlan200-Input in
ip address 10.1.200.253/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp 200
preempt delay minimum 60 reload 300
priority 250
ip 10.1.200.1

interface Vlan501
description Management
no shutdown
ip address 10.10.1.3/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp version 2
hsrp 501
preempt
ip 10.10.1.1

interface Vlan503
description Security
no shutdown
ip address 10.10.3.3/24
ip router eigrp 100
ip passive-interface eigrp 100
hsrp version 2
hsrp 503
preempt
ip 10.10.3.1
ip dhcp relay address 10.1.120.17

interface Vlan508
description Servers
no shutdown
ip address 10.10.8.3/22
hsrp version 2
hsrp 508
preempt
ip 10.10.8.1
ip dhcp relay address 10.1.120.17

interface Vlan512
description Wireless-MGNT
no shutdown
ip address 10.10.12.3/24
ip passive-interface eigrp 100
hsrp version 2
hsrp 512
preempt
ip 10.10.12.1
ip dhcp relay address 10.1.120.17

interface Vlan513
description IT
no shutdown
ip address 10.10.13.3/24
hsrp version 2
hsrp 513
preempt
ip 10.10.13.1
ip dhcp relay address 10.1.120.17

interface Vlan514
description Production
no shutdown
ip address 10.10.14.3/23
hsrp version 2
hsrp 514
preempt
ip 10.10.14.1
ip dhcp relay address 10.1.120.17

interface Vlan532
description Data-IDF1
no shutdown
ip address 10.10.32.3/24
ip passive-interface eigrp 100
hsrp version 2
hsrp 501
preempt
ip 10.10.32.1
ip dhcp relay address 10.1.120.17

interface Vlan536
description Data-IDF2
no shutdown
ip address 10.10.36.3/24
ip passive-interface eigrp 100
hsrp version 2
hsrp 502
preempt
ip 10.10.36.1
ip dhcp relay address 10.1.120.17

interface Vlan540
description Data-IDF3
no shutdown
ip address 10.10.40.3/22
ip passive-interface eigrp 100
hsrp version 2
hsrp 503
preempt
ip 10.10.40.1
ip dhcp relay address 10.1.120.17

interface Vlan544
description Data-IDF4
no shutdown
ip address 10.10.44.3/22
ip passive-interface eigrp 100
hsrp version 2
hsrp 503
preempt
ip 10.10.44.1
ip dhcp relay address 10.1.120.17

interface Vlan548
description Workstation-5
no shutdown
ip address 10.10.48.3/22
hsrp version 2
hsrp 548
preempt
ip 10.10.48.1
ip dhcp relay address 10.1.120.17

interface Vlan552
description Workstation-6
no shutdown
ip address 10.10.52.3/22
hsrp version 2
hsrp 552
preempt
ip 10.10.52.1
ip dhcp relay address 10.1.120.17

interface Vlan556
description Workstation-7
no shutdown
ip address 10.10.56.3/22
hsrp version 2
hsrp 556
preempt
ip 10.10.56.1
ip dhcp relay address 10.1.120.17

interface Vlan560
description Workstation-8
no shutdown
ip address 10.10.60.3/22
hsrp version 2
hsrp 560
preempt
ip 10.10.60.1
ip dhcp relay address 10.1.120.17

interface Vlan564
description Workstation-9
no shutdown
ip address 10.10.64.3/22
hsrp version 2
hsrp 564
preempt
ip 10.10.64.1
ip dhcp relay address 10.1.120.17

interface Vlan568
description Workstation-10
no shutdown
ip address 10.10.68.3/22
hsrp version 2
hsrp 568
preempt
ip 10.10.68.1
ip dhcp relay address 10.1.120.17

interface Vlan572
description Workstation-11
no shutdown
ip address 10.10.72.3/22
hsrp version 2
hsrp 572
preempt
ip 10.10.72.1
ip dhcp relay address 10.1.120.17

interface Vlan576
description Workstation-12
no shutdown
ip address 10.10.76.3/22
hsrp version 2
hsrp 576
preempt
ip 10.10.76.1
ip dhcp relay address 10.1.120.17

interface Vlan580
description Wireless-Corp
no shutdown
ip address 10.10.80.3/22
ip passive-interface eigrp 100
hsrp version 2
hsrp 580
preempt
ip 10.10.80.1
ip dhcp relay address 10.1.120.17

interface Vlan584
description Wireless-Redzone
no shutdown
ip address 10.10.84.3/22
ip passive-interface eigrp 100
hsrp version 2
hsrp 584
preempt
ip 10.10.84.1
ip dhcp relay address 10.1.120.17

interface Vlan588
description LAB
no shutdown
ip address 10.10.88.3/22
hsrp version 2
hsrp 588
preempt
ip 10.10.88.1
ip dhcp relay address 10.1.120.17

interface port-channel1
description VPC Peer Link (vPC PL)
switchport mode trunk
spanning-tree port type network
speed 10000
vpc peer-link

interface port-channel10
description Portchannel to MPCSVR13 10.12.1.2
switchport mode trunk
switchport trunk allowed vlan 1-499,502,508,589-4094
speed 10000
vpc 10

interface port-channel11
description Portchannel to PROD_UCS2
switchport mode trunk
switchport trunk allowed vlan 1-499,502,508,589-4094
speed 10000
vpc 11

interface port-channel17
description Portchannel to SwCutFruit WS-C3560
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
vpc 17

interface port-channel18
description Portchannel to SwHR WS-C3560
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
vpc 18

interface port-channel19
description Portchannel to SwLabelRoom-1 WS-C3560
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
vpc 19

interface port-channel21
description Portchannel to SwTelecom WS-C3560
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
vpc 21

interface port-channel25
description MPC-IDF1-Telecomroom
switchport mode trunk
speed 1000
vpc 25

interface port-channel26
description MPC-IDF2-HR
switchport mode trunk
speed 1000
vpc 26

interface port-channel27
description MPC-IDF3-LabelRoom
switchport mode trunk
speed 1000
vpc 27

interface port-channel28
description MPC-IDF4-CutFruit
switchport mode trunk
speed 1000
vpc 28

interface port-channel29
description MPC-IDF5-PruneLine
switchport mode trunk
speed 1000
vpc 29

interface port-channel30
description MPC-IDF6-BagLine
switchport mode trunk
speed 1000
vpc 30

interface port-channel31
description MPC-IDF7-Logistics
switchport mode trunk
speed 1000
vpc 31

interface port-channel32
description MPC-IDF8-WestDock
switchport mode trunk
speed 1000
vpc 32

interface port-channel33
switchport mode trunk
vpc 33

interface Ethernet1/1
no switchport
speed 1000
vrf member peer-keepalive
ip address 172.16.100.1/30

interface Ethernet1/2
description VPC Peer Link- 1/2 (vPC PL)PROD_N3K_CORE2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/3
description MPCSVR13 10.12.1.2
switchport mode trunk
switchport trunk allowed vlan 1-499,502,508,589-4094
channel-group 10 mode active

interface Ethernet1/4
description VPC to PROD_UCS2
switchport mode trunk
switchport trunk allowed vlan 1-499,502,508,589-4094
channel-group 11 mode active

interface Ethernet1/5
description VPC to Nimble Storage CS210
switchport access vlan 20

interface Ethernet1/6
description VPC to Nimble Storage CS210
switchport access vlan 20
spanning-tree port type edge

interface Ethernet1/7
description MPCNIMBLE-2 TG1A
switchport access vlan 20

interface Ethernet1/8
description MPCNIMBLE-2 TG1B
switchport access vlan 20
spanning-tree port type edge

interface Ethernet1/9
description MPC-UCVM-01 Port 1
switchport mode trunk
switchport trunk allowed vlan 10-11,998
spanning-tree port type edge trunk

interface Ethernet1/10
description MPC-UCVM-02 Port 1
switchport mode trunk
switchport trunk allowed vlan 10-11,998
spanning-tree port type edge trunk

interface Ethernet1/11
description Cisco Wireless Controller
switchport mode trunk
switchport access vlan 105
switchport trunk allowed vlan 105,120,140,150,200,504,512,580,584

interface Ethernet1/12
description AT&T Circuit
switchport access vlan 501
speed 1000

interface Ethernet1/13
shutdown

interface Ethernet1/14
shutdown

interface Ethernet1/15
switchport monitor
speed 1000

interface Ethernet1/16
shutdown

interface Ethernet1/17
shutdown

interface Ethernet1/18
description VPC Peer Link 1/18 (vPC PL)PROD_N3K_CORE2
switchport mode trunk
channel-group 1 mode active

interface Ethernet1/19
description OLD Telecom Room
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
channel-group 21 mode active

interface Ethernet1/20
description OLD HR
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
spanning-tree port type edge trunk
speed 1000
channel-group 18 mode active

interface Ethernet1/21
description OLD Label Room
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
channel-group 19 mode active

interface Ethernet1/22
description OLD Cut Fruit
switchport mode trunk
switchport trunk allowed vlan 1-499,502,589-4094
speed 1000
channel-group 17 mode active

interface Ethernet1/23
description OLD Gaurd Shack
switchport mode trunk
switchport trunk allowed vlan 1-499,502,572,589-4094
speed 1000

interface Ethernet1/24
description Old Bag Line
switchport mode trunk
switchport trunk allowed vlan 1-578,589-4094
speed 1000

interface Ethernet1/25
description Old West Dock
switchport mode trunk
switchport trunk allowed vlan 1-499,502,512,589-4094
speed 1000

interface Ethernet1/26
shutdown

interface Ethernet1/27
shutdown

interface Ethernet1/28
shutdown

interface Ethernet1/29
shutdown

interface Ethernet1/30
shutdown

interface Ethernet1/31
shutdown

interface Ethernet1/32
shutdown

interface Ethernet1/33
speed 1000

interface Ethernet1/34
description MPC-IDF1-TelecomRoom
switchport mode trunk
speed 1000
channel-group 25 mode active

interface Ethernet1/35
description MPC-IDF2-HR
switchport mode trunk
speed 1000
channel-group 26 mode active

interface Ethernet1/36
description MPC-IDF4-CutFruit
switchport mode trunk
speed 1000
channel-group 28 mode active

interface Ethernet1/37
description MPC-IDF3-LabelRoom
switchport mode trunk
speed 1000
channel-group 27 mode active

interface Ethernet1/38
description MPC-IDF3-LabelRoom
switchport mode trunk
speed 1000
channel-group 27 mode active

interface Ethernet1/39
description MPC-IDF5-PruneLine
switchport mode trunk
speed 1000
channel-group 29 mode active

interface Ethernet1/40
description MPC-IDF6-BagLine
switchport mode trunk
speed 1000
channel-group 30 mode active

interface Ethernet1/41
description MPC-IDF7-Logistics
switchport mode trunk
speed 1000
channel-group 31 mode active

interface Ethernet1/42
description MPC-IDF8-WestDock
switchport mode trunk
speed 1000
channel-group 32 mode active

interface Ethernet1/43
description MPC-ServerRoom Stack
switchport mode trunk
spanning-tree port type edge
channel-group 33 mode active

interface Ethernet1/44
speed 1000

interface Ethernet1/45
description CCM0
switchport access vlan 11
spanning-tree port type edge
speed 1000

interface Ethernet1/46
description CCM1
switchport access vlan 11
spanning-tree port type edge
speed 1000

interface Ethernet1/47
description Mariani_Voice_GW
switchport access vlan 11
spanning-tree port type edge
speed 1000

interface Ethernet1/48

interface mgmt0
clock timezone PST -8 0
line console
line vty
boot kickstart bootflash:/n3500-uk9-kickstart.6.0.2.A1.1d.bin
boot system bootflash:/n3500-uk9.6.0.2.A1.1d.bin
ip radius source-interface Vlan10
router eigrp 100
autonomous-system 100
ip route 0.0.0.0/0 10.10.1.254
ip route 10.1.200.11/32 10.1.10.21
ip route 10.10.4.0/22 10.1.1.2
ip route 10.20.0.0/16 10.10.1.254
ip route 10.20.1.0/24 10.10.1.254
ip route 10.30.0.0/16 10.10.1.254
ip route 10.40.0.0/16 10.10.1.254
ip route 10.225.71.224/30 10.10.1.254
ip route 172.16.0.0/12 10.1.1.2
ip route 192.168.5.0/24 10.10.1.254
ip route 192.168.6.0/24 10.10.1.254
ip route 192.168.7.0/24 10.10.1.254
ip route 192.168.8.0/24 10.10.1.254
ip route 192.168.8.128/25 10.10.1.254
ip route 192.168.10.0/24 10.1.1.2
ip route 192.168.11.0/24 10.10.1.254
ip route 192.168.12.0/29 10.10.1.254
monitor session 1
source vlan 12
destination interface Ethernet1/15
no shut


MPC-VV-N3K_Core1#

The config for each site that we gave to AT&T for there router below

interface GigabitEthernet0/1
description att-unman customer LAN
no ip address 10.20.1.1 255.255.255.0
ip address 10.20.1.254 255.255.255.0
usmpcimarca02r
interface GigabitEthernet0/0
description customer LAN att-unman
no ip address 10.40.1.1 255.255.255.0
ip address 10.40.1.254 255.255.255.0
usmpcimarca01r
interface GigabitEthernet0/1
description customer LAN
no ip address 10.30.1.1 255.255.255.0
ip address 10.30.1.254 255.255.255.0


The following changes was made on all three routers:
usmpciwiswi01r
interface GigabitEthernet0/1
description att-unman customer LAN
no ip address 10.20.1.1 255.255.255.0
ip address 10.20.1.254 255.255.255.0
usmpcimarca02r
interface GigabitEthernet0/0
description customer LAN att-unman
no ip address 10.40.1.1 255.255.255.0
ip address 10.40.1.254 255.255.255.0
usmpcimarca01r
interface GigabitEthernet0/1
description customer LAN
no ip address 10.30.1.1 255.255.255.0
ip address 10.30.1.254 255.255.255.0

Is that a typo? :)

Both blocks of config are the same, and you aren't moving from a 192.168.0.0/16 subnet.

Review Cisco Networking for a $25 gift card