cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

2486
Views
0
Helpful
9
Replies
Highlighted
Beginner

Cisco 1800 Router + Two Sites + Share Internet of One Site to Other + Both Sites LAN communicate to each other

Hi Experts,

I have only Site-A setup, we are planning to setup of Site-B for Future purpose. Plz find Network diagram and

see below Site-A  and Site-B router Config. Note that, Red text indicates that configuration is not incomplete, if you feel that it is incorrect or any need to change then u can correct  it......

Router Site A Config.

ip name-server 201.122.33.154

ip name-server 201.122.33.152

interface FastEthernet0/1

description $For LAN$

ip address 172.25.182.1 255.255.255.0

ip nat inside

interface FastEthernet0/0

description $For WAN$

ip address 122.55.66.77 255.255.255.224

ip nat outside

!

interface FastEthernet0/2

description --- 2Mbps LL to SiteB Fe0/0 ---

ip address 192.168.1.1 255.255.255.0

ip nat inside (Yes or No)

ip route 192.168.20.0 255.255.255.0 Fe0/2

ip route 0.0.0.0 0.0.0.0 122.55.66.76

ip http server

ip nat inside source list 101 interface FastEthernet0/0 overload

!

access-list 101 permit ip any any 

access-list 101 permit icmp any any

!

end

Router Site B Config.

interface Fe0/0

description --- 2Mbps LL to SiteA Feo/2 ---

ip address 192.168.1.2 255.255.255.0

ip nat outside ( yes or no)

interface Fe0/1

description -----------

ip address 192.168.20.1 255.255.255.0

ip nat inside (yes or no)

=========================

ip classless

Here i m confused that which one should i use  ??

{

ip route 0.0.0.0 0.0.0.0 Fe0/0 

                   OR

Create "ip route for all VLAN's like as :

ip route 172.25.162.0 255.255.255.0 Fe0/0

ip route 172.25.163.0 255.255.255.0 Fe0/0

ip route 172.25.164.0 255.255.255.0 Fe0/0

ip route 172.25.165.0 255.255.255.0 Fe0/0

-

-

-

-

ip route 172.25.185.0 255.255.255.0 Fe0/0 )

}

ip route 0.0.0.0 0.0.0.0 122.55.66.76  ( yes or no )

=====================

I have a setup with cisco 1841 series router for 1 MBPS leased line for Internet acces in existing office (Site A) .

For Both Sites connectivity, I have taken 2 MBPS point to point leased line connection between two office's.

I am not using any kind of Routing Protocol and also do not want to use any Routing protols...........

There are some Basic Questions given below, plz give reply serialwise:

1. By Default, Cisco 1841 comes with 2 Fastethernet Port so i need to buy HWIC card with one FastEthernet port.

   So plz tell me which HWIC card will need to purchase ?

2. I want to share this same internet line of Site A with a branch office (Site B) because Site B do not have any

   internet line .How can I do that please correct and send me configuration of  "Site-B Router"  and  "Site-A Router interface F0/2" .

( Configuration like ip nat outside/inside with Router Port, ip route , access list, etc )

3. Site-A's LAN should be communicate with Site-B's LAN   and   Site-B's LAN should be communicate with Site-A's LAN

   Note that, Site-A have multiple VLAN's but Site B have only single subnet..

1 ACCEPTED SOLUTION

Accepted Solutions
Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hello Kuldeep,

Answers

1.

then do i have to configure same above command on Site B router.. ( Yes or No)

NO

which main command providing internet of SiteA ISP to SiteB ?  plz mention here

Default routes on siteB and SiteA will take care of this.

we have pointed a default route on siteB, where any traffic generated on siteb (source as 192.168.20.0/24) with destination as any will be handed over to next hop IP(i.e SiteA fa 0/2). on reaching here (siteA) the router will fetch out if there are any available route on looking to the destination ip and responds (if it is Internal ) if not then the packets inturn handed over to next hop i.e (siteA:deault route to next hop as ISP-external/internet ).

to make sure the siteA router know how to reach the subnet 192.168.20.0/24, we have configured  a static route saying packets to be handed over to the intfa0/0 of siteB, below is the command.

ip route 192.168.20.0 255.255.255.0 192.168.1.2

2.

the default gateway for all the clients on the siteb wiill be the connected interface ip of the router.

ip = 192.168.20.5

mask= 255.255.255.0

default gateway= 192.168.20.1      

dns1= 201.122.33.154

dns2= 201.122.33.152

All the Best

Please rate the helpful posts.

Regards,

srikanth

9 REPLIES 9
Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hello Kuldeep,

1. By Default, Cisco 1841 comes with 2 Fastethernet Port so i need to buy HWIC card with one FastEthernet port.

   So plz tell me which HWIC card will need to purchase ?

I wonder Why you need this and where ?

Ans: Here you can create as many as virtual interface under an interface (note: Limited number of virtual interfaces can be created: depends on the model of the router and how many it supports)

Virtual interface

Example:

interface GigabitEthernet0/0

description $ trunk interface connected to switch$

no ip address

ip virtual-reassembly

duplex auto

speed auto

!

interface GigabitEthernet0/0.1

encapsulation dot1Q 25

ip address 10.10.45.254 255.255.255.0

ip virtual-reassembly

!

interface GigabitEthernet0/0.2

encapsulation dot1Q 290

ip address 10.10.101.1 255.255.255.0

ip virtual-reassembly

!

And go on gig 0/0.3, gig0/0.4…………………….

2 want to share this same internet line of Site A with a branch office (Site B) because Site B do not have any

   internet line .How can I do that please correct and send me configuration of  "Site-B Router"  and  "Site-A Router interface F0/2" .

Ans: As you have a point to point connection between two sites, please run a dynamic routing protocol (Rip/ospf/eigrp)which does the routing part and advertise the default route in the routing protocol

Site B (Here I used RIPv2):

For internet : Default route to Next hop(site A interface/Ip/Nulll):

Ip route 0.0.0.0 0.0.0.0 null0

router rip

version 2

network 192.168.1.0 255.255.255.0

network 192.168.20.0 255.255.255.0

no auto-summary

default-information originate

Note: Using default-information originate will advertise a default route, if there is one in the routing table. By adding the 'always' the default will be advertised even if there is no default route in the table.

   0r

You can use the redistribution of static to rip as by issuing a command under rip router of siteb: Redistribute static metric 11

3. Site-A's LAN should be communicate with Site-B's LAN   and   Site-B's LAN should be communicate with Site-A's LAN

   Note that, Site-A have multiple VLAN's but Site B have only single subnet..

Ans: both the sites will be able to communicate with the dynamic route protocol as mentioned above in point 2.

If you are not looking to run dynamic routing protocl: then you can go with default route point to site A (which may create a problem further ) as like your comment says

ip route 0.0.0.0 0.0.0.0 Fe0/0 

                   OR

Create "ip route for all VLAN's like as :

ip route 172.25.162.0 255.255.255.0 Fe0/0

ip route 172.25.163.0 255.255.255.0 Fe0/0

ip route 172.25.164.0 255.255.255.0 Fe0/0

ip route 172.25.165.0 255.255.255.0 Fe0/0

-

-

-

-

ip route 172.25.185.0 255.255.255.0 Fe0/0

Ans: I think its sufficient to have a default route to carry the traffic from site b to site A.

Note: if you are using a dynamic route you need not have to specify every single static route as above, you just need to advertise the networks of router. It will ease your work even if you have in need to create more subnets ahead in future in siteB as since you just need to advertise the network into rip/ospf.

Hope this helps you, let me know if you have any queries or issues in setting up this,

Kindly rate the helpull posts

Regards,

srikanth

Beginner

Re: Cisco 1800 Router + Two Sites + Share Internet of One Site t

Hi Srikanth,

                  you are saying that no need of HWIC card then how to connect one site to remote site.....

                  can u plz send me simple network diagram , so that i can understand that how to use vritual

                  interface to site to site connectivity....... is there any need to buy extra switch ????

Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hello Kuldeep,

I assumed why you need an card for siteB.

All right you need an interface card for the SitaA router, where the default two interfaces you have already used up for the lan and internet.

so please find the below link for installing:

http://www.cisco.com/en/US/docs/routers/access/1800/1841/hardware/installation/guide/18ic.pdf

http://www.cisco.com/en/US/prod/collateral/routers/ps5854/product_data_sheet0900aecd80581fe6_ps5855_Products_Data_Sheet.html

Please kindl check with image you have.

Support thread for Hwic card installation in router 1841:

https://supportforums.cisco.com/thread/2032105

Hope I have answered all your queires, please rate the helpfull posts.

Regards,

srikanth

Beginner

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hi Srikanth,

plz do not consider any routing protocol in my case.............i have already post configuration of both side but i am not sure about that is it correct or not  so please do changes according to you.......and send me finalize configuration before

once see my attached network diagram.. and reply me serialwise so that i can understand that which command for what purpose...

Secondly,

what will be the Default Gateway of user which is connected to site B.

Suppose tcp/ip configuration of User

ip = 192.168.20.5

mask= 255.255.255.0

default gateway= ???

dns1= 201.122.33.154

dns2= 201.122.33.152

Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hello Kuldeep,

simple

Connect new interface to siteB as Point-point-link with new ip subnet

siteA ----------------------------------------------------------SiteB

          192.168.1.1/30                                                  192.168.1.2/30

Router Site B Config.

Natting not Required here, just point a default route to next hop as siteA ip(which carries all the traffic generated from siteb to next Hop IP i.e siteA)

interface Fe0/0

description --- 2Mbps LL to SiteA Feo/2 ---

ip address 192.168.1.2 255.255.255.0

interface Fe0/1

description -----------

ip address 192.168.20.1 255.255.255.0

=========================

ip classless

Here i m confused that which one should i use  ??

do this:

no ip route 0.0.0.0 0.0.0.0 Fe0/0 

configure as

ip route 0.0.0.0 0.0.0.0 192.168.1.1

the above is primary default route to siteA (any traffic even internet generated at siteB is handed over to SitaA). that's it you dont require any more routes here.

SIteA config:

as you have a connected New interface as <192.168.1.0/30> you can see this in route table, any internal communication between the inside subnets is handled here.

for internet access you already ahave a default route pointing to next hop ip as ISP.

interface FastEthernet0/1

description $For LAN$

ip address 172.25.182.1 255.255.255.0

ip nat inside

interface FastEthernet0/0

description $For WAN$

ip address 122.55.66.77 255.255.255.224

ip nat outside

!

interface FastEthernet0/2

description --- 2Mbps LL to SiteB Fe0/0 ---

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip route 192.168.20.0 255.255.255.0 192.168.1.2  

ip route 0.0.0.0 0.0.0.0 122.55.66.76

ip http server

ip nat inside source list 101 interface FastEthernet0/1 overload

access-list 101 permit ip any any 

access-list 101 permit icmp any any

thats it by above setup siteB will be able to communicate with siteA and also utilises the same internet line from siteA.

Please dont forget to rate the helpful posts.let us know if you have any queries.

Thanks,

srikanth

Beginner

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hi  Srikanth,

1.  For internet access i already have a default route pointing to next hop ip as ISP gateway public ip at Site A router.

     ip route 0.0.0.0 0.0.0.0 122.55.66.76

     then do i have to configure same above command on Site B router.. ( Yes or No)

     which main command providing internet of SiteA ISP to SiteB ?  plz mention here

2. what will be the Default Gateway of user which is connected to site B.

Suppose tcp/ip configuration of User

ip = 192.168.20.5

mask= 255.255.255.0

default gateway= ???

dns1= 201.122.33.154

dns2= 201.122.33.152

Beginner

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hi Srikanth,

                 I am waiting for ur reply............

Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Hello Kuldeep,

Answers

1.

then do i have to configure same above command on Site B router.. ( Yes or No)

NO

which main command providing internet of SiteA ISP to SiteB ?  plz mention here

Default routes on siteB and SiteA will take care of this.

we have pointed a default route on siteB, where any traffic generated on siteb (source as 192.168.20.0/24) with destination as any will be handed over to next hop IP(i.e SiteA fa 0/2). on reaching here (siteA) the router will fetch out if there are any available route on looking to the destination ip and responds (if it is Internal ) if not then the packets inturn handed over to next hop i.e (siteA:deault route to next hop as ISP-external/internet ).

to make sure the siteA router know how to reach the subnet 192.168.20.0/24, we have configured  a static route saying packets to be handed over to the intfa0/0 of siteB, below is the command.

ip route 192.168.20.0 255.255.255.0 192.168.1.2

2.

the default gateway for all the clients on the siteb wiill be the connected interface ip of the router.

ip = 192.168.20.5

mask= 255.255.255.0

default gateway= 192.168.20.1      

dns1= 201.122.33.154

dns2= 201.122.33.152

All the Best

Please rate the helpful posts.

Regards,

srikanth

Enthusiast

Cisco 1800 Router + Two Sites + Share Internet of One Site to Ot

Sure Kuldeep...

Regards

srikanth

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards