cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
4355
Views
0
Helpful
37
Replies
ahmetemrah
Beginner

Cisco 2960S connection problem

Hi,

I have a Cisco 2960 S 24-TSL switch and a simple LAN of a few devices. I fail to connect to one of my devices from my PC both of which are connected to the switch. However, when I connect the PC and the device to another switch(unmanaged), or use a direct connection without using a switch there seems to be no problem.

37 REPLIES 37
Leo Laohoo
VIP Community Legend

Is the unmanaged switch is a 10/100BaseTx?  If this is yes, then the patch cable you use to connect the PC to the 2960S is faulty.  If you don't believe me, configure the port on the 2960S as "speed auto 10 100" and the link should go up.  Configure the interface speed to 1 Gbps and the link will go down.

Actually I don't think problem is the cable. I tried 2 unmanaged switches, one 10/100BaseTx, the other 1Gb and the PC connects to the device successfully with both. I should also mention that other devices work fine with the switch and that port in particular so I don't think there is a problem with 2960S but rather its settings. I tried setting the speed of the 2960S port to 10/100 and it didn't work. I don't have much experience in network switches and don't know what other settings of the 2960S may cause the problem. Any other suggestions are very welcome.

Hello

Can you post the running config of the switch and highlight what ports you arre using Res

Paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

please share the configuration of both switch ports connected with your PC and that device.

port 7 : device

port 9 : PC

 

 

 

GigabitEthernet1/0/7 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 2401.c79c.5d07 (bia 2401.c79c.5d07)
  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Half-duplex, 10Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:00, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     3861 packets input, 435050 bytes, 0 no buffer
     Received 3776 broadcasts (802 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 802 multicast, 0 pause input
     0 input packets with dribble condition detected
     4204 packets output, 604392 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

 

 

GigabitEthernet1/0/9 is up, line protocol is up (connected)
  Hardware is Gigabit Ethernet, address is 2401.c79c.5d09 (bia 2401.c79c.5d09)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 1000Mb/s, media type is 10/100/1000BaseTX
  input flow-control is off, output flow-control is unsupported
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input never, output 00:00:01, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     291 packets input, 97392 bytes, 0 no buffer
     Received 291 broadcasts (227 multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog, 227 multicast, 0 pause input
     0 input packets with dribble condition detected
     1314 packets output, 209814 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier, 0 PAUSE output
     0 output buffer failures, 0 output buffers swapped out

Device is on port 7

PC in on port 9

 

 

Switch#show running-config                         
Building configuration...                       

Current configuration : 3307 bytes                                 
!
version 12.2           
no service pad             
service timestamps debug datetime msec                                     
service timestamps log datetime msec                                   
no service password-encryption                             
!
hostname Switch              
!
boot-start-marker                
boot-end-marker              
!
enable secret 5 $1$kO/2$p2iZZsakSS/hRUs3FvXff1                                             
!
!
!
no aaa new-model               
clock timezone UTC 2                   
clock summer-time UTC recurring last Sun Mar 3:00 last Sun Oct 4:00                                                                  
switch 1 provision ws-c2960s-24ts-l                                  
!
!
!
!
crypto pki trustpoint TP-self-signed-3348913408                                              
 enrollment selfsigned                     
 subject-name cn=IOS-Self-Signed-Certificate-3348913408                                                      
 revocation-check none                     
 rsakeypair TP-self-signed-3348913408                                    
!
!
crypto pki certificate chain TP-self-signed-3348913408                                                     
 certificate self-signed 01                          
  3082023F 308201A8 A0030201 02020101 300D0609 2A864886 F70D0101 04050030                                                                        
  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274                                                                        
  69666963 6174652D 33333438 39313334 3038301E 170D3933 30333031 30303032                                                                        
  33365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649                                                                        
  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 33343839                                                                        
  31333430 3830819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281                                                                        
  8100F8B9 51FBC8E9 DC53A5C9 586FA531 D627F68B 977F64AE 5F5335D1 F177DBE7                                                                        
  B7D68B34 D33C136A 9ADFD5C2 77ABA4CF 6ED57FF3 1A731592 1CAB1014 30193FD0                                                                        
  5DB2239F 97F21CFB 0429E76C E7305B34 C6D0DA4B 1F12E3A9 1D92AEA1 E3F495F9                                                                        
  7410A99C EC3AEC1C 81E06DF7 373C65BF 3F30D4CD 1818E2F2 489D9A17 C5E10A27                                                                        
  90430203 010001A3 67306530 0F060355 1D130101 FF040530 030101FF 30120603                                                                        
  551D1104 0B300982 07537769 7463682E 301F0603 551D2304 18301680 14332F                                                                     
  F436B748 870F299F 734D49B0 CEB128BE 08301D06 03551D0E 04160414 332F8EF4                                                                        
  36B74887 0F299F73 4D49B0CE B128BE08 300D0609 2A864886 F70D0101 04050003                                                                        
  81810059 BBF37D44 74AF1DB9 9FFE517B 546A0870 0BCA4A4F FC36A2AB 0B90D73E                                                                        
  DB845783 3A984645 8B2C1BB7 870285AD A6DC26BC E5562A70 D71607E7 4F74B438                                                                        
  55E5F427 00A01539 E1AC3C7C 1D438698 3B6CC087 51167F04 44F6C8CC 25A34453                                                                        
  62CAC937 F8502C8B 79C51C3F 34777DB2 F7831FF3 E0B76ADC D1EB9A72 092AB769 D64D69                                                                              

  quit     
spanning-tree mode pvst                      
spanning-tree extend system-id                             
!
!
!
!
vlan internal allocation policy ascending                                        
!
!
!
interface FastEthernet0                      
 no ip address             
!
interface GigabitEthernet1/0/1                             
!
interface GigabitEthernet1/0/2                             
 speed 10        
 duplex full           
!
interface GigabitEthernet1/0/3                             
!
interface GigabitEthernet1/0/4                             
!
interface GigabitEthernet1/0/5                             
!
interface GigabitEthernet1/0/6                             
!
interface GigabitEthernet1/0/7                             
!
interface GigabitEthernet1/0/8                             
!
interface GigabitEthernet1/0/9                             
!
interface GigabitEthernet1/0/10                              
!
interface GigabitEthernet1/0/11                              
!
interface GigabitEthernet1/0/12                              
!
interface GigabitEthernet1/0/13                              
!
interface GigabitEthernet1/0/14                              
!
interface GigabitEthernet1/0/15                              
!
interface GigabitEthernet1/0/16                              
!
interface GigabitEthernet1/0/17                              
!
interface GigabitEthernet1/0/18                              
!
interface GigabitEthernet1/0/19                              
!
interface GigabitEthernet1/0/20                              
!
interface GigabitEthernet1/0/21                              
!
interface GigabitEthernet1/0/22                              
!
interface GigabitEthernet1/0/23                              
!
interface GigabitEthernet1/0/24                              
!
interface GigabitEthernet1/0/25                              
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
 ip address 10.10.27.100 255.255.255.0
!
ip http server
ip http secure-server
!
line con 0
line vty 0 4
 login
line vty 5 15
 login
!
end

Switch#

I can see interface  Gig 1/0/7 showing 10mb/s half-duplex. Try to connect your PC on a different port and check the speed/duplex of that switchport. If it is still 10mb/s half, then check the LAN card setting of your PC through LAN card properties,it may be set as 10mb/s half, make it default and check the connectivity. If still not coming up then swap cable.

PC is not connected to interface Gig 1/0/7, it is on port 9 and its LAN property is set to autonegotiation leading to 1Gbps full duplex.

The device that I try to communicate on the other hand, is on port 7 and I believe it has an old LAN card that supports only 10 Mbps half duplex, that's why we are seeing those numbers in the interface.

I tried swapping cables by the way and it did not work.

 

Leo Laohoo
VIP Community Legend

Ok, let's try this then: 

 

  1. Command:  test cable tdr interface <BLAH>;
  2. Wait for 5 seconds; 
  3. Command:  sh cable tdr interface <BLAH>; and
  4. Post output to #3.

Output to # 3:

 

Switch#sh cable tdr interface GigabitEthernet1/0/7
TDR test last run on: March 02 07:03:18

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/7   10M   Pair A     2    +/- 0  meters N/A         Normal
                Pair B     2    +/- 0  meters N/A         Normal
                Pair C     1    +/- 1  meters N/A         Short
                Pair D     1    +/- 1  meters N/A         Short

 

 

 

This tdr result means either your cable is of 10mb capable or switchport is malfunctioning. Change the cable and check else connect your pc on different switch port.

Thanks for the reply.

I tried several other cables that are 1Gb capable and get the same tdr result. The device connected to the port is not a PC by the way.

So I assume from your comments that the device connected to the port is 10Mb capable. I tried configuring port settings to 10 100 mb speed and half or full duplex, whatever configurations I try did not work.

Understanding the device is not GB ethernet capable, what can I do to connect it to 2960S?

Why would it work with 10/100BaseTX or 1Gb unmanaged switches but not 2960S?

Would connecting the device to an unmanaged switch that is connected to 2960S work?

 

Leo Laohoo
VIP Community Legend

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/7   10M   Pair A     2    +/- 0  meters N/A         Normal
                Pair B     2    +/- 0  meters N/A         Normal
                Pair C     1    +/- 1  meters N/A         Short
                Pair D     1    +/- 1  meters N/A         Short

There is NO CHANCE for this device to be able to connect to 1 Gbps (even if the NIC is capable of).  And this is proven by the result of the TDR.  Look at the Pair Status of Pair "D".   This is the pair which controls 1 Gbps protocol.   If this pair is not "Normal", the highest you can achieve with this cable is only 100 Mbps.  Change the cable closest to the switch.  This is where the fault is.

I tried the same cable on some other device and got:

Interface Speed Local pair Pair length        Remote pair Pair status
--------- ----- ---------- ------------------ ----------- --------------------
Gi1/0/3   1000M Pair A     2    +/- 0  meters N/A         Normal
                Pair B     2    +/- 0  meters N/A         Normal
                Pair C     1    +/- 1  meters N/A         Normal
                Pair D     1    +/- 1  meters N/A         Normal

So i concluded from your comments that the cabling inside the device or NIC is faulty.

I understand that the device cannot work 1Gbps, but I do not need the device to work with 1Gbps. If it could work 10Mbps  it would be ok. Yet it needs to be connected to the network formed by 2960S.

The question now is, is there a way to connect this device to the network formed by 2960S?