cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1980
Views
0
Helpful
1
Replies
WuTangClan
Beginner

Cisco 4500X VSS breaks when reloading

Hi all,

I have a pair of 4500Xs running the same IOS version. I am able to successfully get them in a vss pair after using this config and issuing the 'switch mode convert virtual' command. In doing failover testing I rebooted the active switch, and waited approximately 30 seconds and rebooted the standby switch. In doing so it broke the VSL and we are unable to recover it without converting back to standalone and rebuilding the VSS again. The switches end up in a dual-active scenario, and we don't have dual-active detection enabled. When examining the 'show switch virtual link' command the VSL is down and a 'show int po1' shows the interface as being down in the same status as if it were standalone pre conversion (notconnect).

I have tried every reload combination I can think of, I have done a shut/no shut on po1, I've let it sit for over an hour to give it time for it to come back up. So far the only thing that's worked is a complete teardown of the VSS and rebuilding it from standalone. Has anybody else experienced this? Do you have any suggestions?

Here is the VSS config:

--------------------PRIMARY--------------------

***********************************************
*                            VSS                            *
***********************************************
switch virtual domain 1
switch 1
switch 1 priority 200
!
int po1
switchport
switch virtual link 1
no shut
!
int te1/1
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/2
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/9
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/10
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on

***********************************************

'show ver'

Cisco IOS Software, IOS-XE Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSALK9-M), Version 03.06.04.E RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Fri 12-Feb-16 22:40 by prod_rel_team

'show switch virtual link'

Executing the command on VSS member switch role = VSS Active, id = 1


VSL Status : DOWN
VSL Uptime : -
VSL Control Link : -
VSL Encryption : Configured Mode - Off, Operational Mode - Off

Cannot execute command on peer supervisor because it is not in SSO Standby state

'show int po1'

Port-channel1 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, media type is N/A
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

--------------------STANDBY--------------------
***********************************************
*                            VSS                            *
***********************************************
switch virtual domain 1
switch 2
!
int po1
switchport
switch virtual link 2
no shut
!
int te1/1
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/2
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/9
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
int te1/10
switchport mode trunk
switchport nonegotiate
channel-group 1 mode on
***********************************************

'show ver'

Cisco IOS Software, IOS-XE Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSALK9-M), Version 03.06.04.E RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2016 by Cisco Systems, Inc.
Compiled Fri 12-Feb-16 22:40 by prod_rel_team

'show switch virtual link'

 Executing the command on VSS member switch role = VSS Active, id = 2


VSL Status : DOWN
VSL Uptime : -
VSL Control Link : -
VSL Encryption : Configured Mode - Off, Operational Mode - Off

Cannot execute command on peer supervisor because it is not in SSO Standby state

'show int po1'

Port-channel1 is down, line protocol is down (notconnect)
Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)
MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Auto-duplex, Auto-speed, media type is N/A
input flow-control is off, output flow-control is unsupported
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts (0 multicasts)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 unknown protocol drops
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

1 ACCEPTED SOLUTION

Accepted Solutions
Paul Chapman
Enthusiast

Hi -

Unless its a typo in your post, you cannot use the same port-channel number on both switches.  Switch 1 -> Port-Channel 1 & Switch 2 -> Port-Channel 2.

When the configurations merge, the port-channels will maintain their identities and be stored to the local member switch.

PSC

View solution in original post

1 REPLY 1
Paul Chapman
Enthusiast

Hi -

Unless its a typo in your post, you cannot use the same port-channel number on both switches.  Switch 1 -> Port-Channel 1 & Switch 2 -> Port-Channel 2.

When the configurations merge, the port-channels will maintain their identities and be stored to the local member switch.

PSC

View solution in original post