cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
718
Views
0
Helpful
1
Replies

Cisco 871 Router config

bennettdunlop
Level 1
Level 1

I have a Cisco 871 router that i'm trying to config right now with following config:

show run

Building configuration...

Current configuration : 3852 bytes

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname yourname

!

boot-start-marker

boot-end-marker

!

logging buffered 51200 warnings

!

no aaa new-model

!

resource policy

!

ip subnet-zero

ip cef

!

!

no ip dhcp use vrf connected

ip dhcp excluded-address 10.10.10.1

!

ip dhcp pool sdm-pool

   import all

   network 10.10.10.0 255.255.255.248

   default-router 10.10.10.1

   lease 0 2

!

!

no ip domain lookup

ip domain name yourdomain.com

!

!

crypto pki trustpoint TP-self-signed-987102425

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-987102425

revocation-check none

rsakeypair TP-self-signed-987102425

!

!

crypto pki certificate chain TP-self-signed-987102425

certificate self-signed 01

  3082024D 308201B6 A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 39383731 30323432 35301E17 0D303230 33303130 30323334

  395A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 1325494F

  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3938 37313032

  34323530 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818100

  E57DED3E FA51DC0C 745DFB8C D2C8156C 1418EC80 61232EE9 598AA5F6 5E4E426F

  25E2C9B0 39084AB5 224D2216 42129CCF 0747A2EF C482762B 6C94EE44 C5AEF27A

  92E65358 0F4CF5B9 F6B393D3 C744C145 A297AEB9 D3209499 3B59B2D8 10D44F28

  F5F49D73 473E723F E9FB2C51 372B993B E0DF26EA 887FEB5A 2979668B 01033C87

  02030100 01A37730 75300F06 03551D13 0101FF04 05300301 01FF3022 0603551D

  11041B30 19821779 6F75726E 616D652E 796F7572 646F6D61 696E2E63 6F6D301F

  0603551D 23041830 16801471 D890896A FCB86569 262C8942 04646FCA 91B34530

  1D060355 1D0E0416 041471D8 90896AFC B8656926 2C894204 646FCA91 B345300D

  06092A86 4886F70D 01010405 00038181 009F5EE7 F9CCCE36 FF266928 A155B751

  E7E6A46B EDA8092B 44E14AB7 07983E29 2FCD0F46 8DEDFEC5 C89A6BA5 B7185AD2

  517C659E EFAC2565 293D8DD2 0F9210A6 1CBF2ED9 576D2297 F8120B89 30FB43E2

  6DDA5FF7 68272374 C74ACC3B 04FE40D3 63E876F2 1274CEE6 34D25448 4AB031DA

  1C5F1B67 C1E58DF8 89F3755E F4605777 13

  quit

username cisco privilege 15 secret 5 $1$Y420$ZAHoUnY112CgL1Nnjlp7X1

!

!

!

!

!

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

ip address dhcp

duplex auto

speed auto

!

interface Vlan1

description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$

ip address 10.10.10.1 255.255.255.248

ip tcp adjust-mss 1452

!

ip classless

ip route 0.0.0.0 0.0.0.0 dhcp

!

!

ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

access-list 23 permit 10.10.10.0 0.0.0.7

no cdp run

!

!

control-plane

!

banner login ^C

-----------------------------------------------------------------------

Cisco Router and Security Device Manager (SDM) is installed on this device.

This feature requires the one-time use of the username "cisco"

with the password "cisco". The default username and password have a privilege level of 15.

Please change these publicly known initial credentials using SDM or the IOS CLI.

Here are the Cisco IOS commands.

username <myuser>  privilege 15 secret 0 <mypassword>

no username cisco

Replace <myuser> and <mypassword> with the username and password you want to use.

For more information about SDM please follow the instructions in the QUICK START

GUIDE for your router or go to http://www.cisco.com/go/sdm

-----------------------------------------------------------------------

^C

!

line con 0

login local

no modem enable

line aux 0

line vty 0 4

access-class 23 in

privilege level 15

login local

transport input telnet ssh

!

scheduler max-task-time 5000

end

yourname#ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 68/72/76 ms

If i plug in any device in to the one of the interfaces it seems to get a IP from vlan but is unable to connect to internet. What am i missing. Router it self seem to ping outside world.

1 Reply 1

You must enalbe NAT:

interface FastEthernet4

ip nat outside

interface Vlan1

ip nat inside

ip nat inside source list 23 interface FastEthernet4 overload

Regards.