Showing results for 
Search instead for 
Did you mean: 

Cisco 880 (887) and DHCP problems

Hello all,

I'm fairly new to Cisco configuration and I am looking at a problem for a client that involves the use of a Cisco 887 (wired only) as the main router/gateway.

The problem I am investigating involves the allocatoni of DHCP addresses from the device to a product we have designed that connects to the router.

I am attempting to set the 880 up on the bench with no ADSL connection and just use the DHCP feature of the box for the 4 switch ports on the back.

I have tried all kinds of configurations from default.  Whatever I do I can't get the router to assign an IP address to anything that is plugged in (Windows or Linux machines).  What could I be doing wrong ?  It can't be that difficult to get the system to just act as a DHCP server.

Configurations I have tried that don't work are:

Configure DHCP

To configure your router for DHCP operation, perform these steps, beginning in global configuration mode:


1. ip domain name name

2. ip name-server server-address1 [server-address2...server-address6]

3. ip dhcp excluded-address low-address [high-address]

4. ip dhcp pool name

5. network network-number [mask | prefix-length]

6. import all

7. default-router address [address2...address8]

8. dns-server address [address2...address8]

9. domain-name domain

10. exit

(That didnt work)

Then tried to add a VLAN and bound it to the port being used :

Assign a Switch Port to a VLAN

To assign a switch port to a VLAN, perform these steps, beginning in global configuration mode:


1. interface switch port id

2. switchport access vlan vlan-id

3. end

Even checked all the logs and its as if there have been no requests:

Router#show ip dhcp pool

Pool dpool1 :
Utilization mark (high/low)    : 100 / 0
Subnet size (first/next)       : 0 / 0
Total addresses                : 254
Leased addresses               : 0
Pending event                  : none
1 subnet is currently in the pool :
Current index        IP address range                    Leased addresses     -    0
Router#show ip dhcp server statistics
Memory usage         23179
Address pools        1
Database agents      0
Automatic bindings   0
Manual bindings      0
Expired bindings     0
Malformed messages   0
Secure arp entries   0

Message              Received
BOOTREQUEST          0
DHCPREQUEST          0
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            0
DHCPACK              0
DHCPNAK              0

Router#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0, Fa1, Fa2
2    VLAN0002                         active    Fa3
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
2    enet  100002     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0

Is there any way I can get this router to work standalone as a DHCP server and switch with no connection to ADSL ?

I'm pulling my hair out here.

Thanks in advance



For anyone that might be wondering the answer is to add the dhcp service to the vlan...

interface Vlan1

ip address pool dpool1


Simple really.  There is no need for the secondary Vlan, so simple step is to setup the dhcp service then add the service to the default vlan (1) and all will work.

Thanks to the community for all the support and suggestions (not)


Hey Marc!

I had just the same problem a moment ago and I found your answer!!!  So thank you very much, I know this community didn't pull through for you but you have for me so I am very much obliged



Hi Guys,

Just posting a quick note. I recently had a similar issue.

Ensure that the clock is set on the 887 router with the correct date / time.

The router that I encountered had the year set to 20 years ahead. So, it was refusing to handout IP's to clients.

After setting the time the issue was resolved.



SIR! your help is very much appreciated, i been running around circles all day.

Content for Community-Ad