02-01-2016 06:12 AM - edited 03-12-2019 05:19 PM
Hi,
I have a problem with a recent network architecture that I wanted to implement in my home.
The network architecture is as the following:
Internet gateway router (SAGEM): 192.168.1.1 (DHCP Disabled) (WIFI Enabled)
Cisco 887VA router: 192.168.1.254 (DHCP enabled)
The SAGEM is connected to FE0 cisco port
This cisco router contains 3 vlans:
VLAN 1 : 192.168.1.254
VLAN 2: 192.168.2.1
VLAN 3: 192.168.3.1
I added a static routing in the internet gateway (SAGEM) thinking that I will need to get response back if anyone request from the other network vlans:
192.168.2.0 255.255.255.0 192.168.1.254
192.168.3.0 255.255.255.0 192.168.1.254
In the cisco router I added a static route as well: ip route 0.0.0.0 0.0.0.0 192.168.1.1
I do have internet in the VLAN 1. VLAN 2 and 3 don't have access to internet but the LAN devices can ping each other.
This is my cisco config:
Current configuration : 2045 bytes
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
!
!
!
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.50
ip dhcp excluded-address 192.168.2.1 192.168.2.50
ip dhcp excluded-address 192.168.3.1 192.168.3.50
!
ip dhcp pool USERS
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool SAVANT
import all
network 192.168.2.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 192.168.2.1
!
ip dhcp pool SONOS
import all
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
dns-server 8.8.8.8 8.8.4.4
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C887VA-K9 sn FCZ191471DA
!
!
!
!
!
!
!
controller VDSL 0
!
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
switchport access vlan 2
no ip address
!
interface FastEthernet2
switchport access vlan 3
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan2
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan3
ip address 192.168.3.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
line con 0
password xxxxxxx
login
no modem enable
line aux 0
line vty 0 4
password xxxxxxx
login
transport input all
!
scheduler allocate 20000 1000
!
end
I need to know how to enable internet in vlan 2 and 3. Have I missed something ?
Thanks in advance for help me out.
Solved! Go to Solution.
02-02-2016 01:15 AM
What about putting Sagem into bridge mode using the public ip address on your FE0 router and using the pppoe setting on the Cisco side if that what the connection is , that way you can control all the nat on the Cisco side which is definitely capable iof doing multiple vlans nat , just an option
are the users in the vlan 2 and 3 wireless or wired , if wireless is it the same if there wired ? Just wondering is it having issues natting if there coming in by wireless as that's processed on sagem or if wireless is turned off
02-01-2016 09:22 PM
do you have access to the SAGEM router? perhaps it only can NAT the 192.168.1.0 network
02-02-2016 12:14 AM
Hi Richard Bradfield,
Thanks for your reply.
Yes I have access to SAGEM router. Actually, it seems that NAT option is missing I can't find anything related to it.
how to know that it can only nat 192.168.1.0 ?
Regards,
02-02-2016 01:15 AM
What about putting Sagem into bridge mode using the public ip address on your FE0 router and using the pppoe setting on the Cisco side if that what the connection is , that way you can control all the nat on the Cisco side which is definitely capable iof doing multiple vlans nat , just an option
are the users in the vlan 2 and 3 wireless or wired , if wireless is it the same if there wired ? Just wondering is it having issues natting if there coming in by wireless as that's processed on sagem or if wireless is turned off
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide