cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3531
Views
5
Helpful
3
Replies
Highlighted

Cisco ISR4321 with NIM-4G-LTE-GA Module Configuration assistance.

Hi All,

 

I am new to the cellular configuration and my configuration doesn't seem to work.

The SIM card is a data only (Telstra- Australia) and works on my phone, but when I put it in the Module, The physical LED status is as

 

EN: Green

WWAN : Green (Blinking at times)

Service: RED.

 

Configuration:

------------------

Current configuration : 1675 bytes
!
! Last configuration change at 03:48:04 UTC Wed Jun 13 2018
!
version 15.5
service timestamps debug datetime msec
service timestamps log datetime msec
no platform punt-keepalive disable-kernel-core
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
vrf definition Mgmt-intf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
!
no aaa new-model
!
!
subscriber templating
!
multilink bundle-name authenticated
!
!
!
!
license udi pid ISR4321/K9 sn xxxxxxxxx
license boot suite FoundationSuiteK9
!
spanning-tree extend system-id
!
!
redundancy
 mode none
!
!
!
!
controller Cellular 0/1/0
 lte sim data-profile 1 attach-profile 1
 lte modem link-recovery rssi onset-threshold -110
 lte modem link-recovery monitor-timer 20
 lte modem link-recovery wait-timer 10
 lte modem link-recovery debounce-count 6
!
!
vlan internal allocation policy ascending
!
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/1
 no ip address
 shutdown
 negotiation auto
!
interface Cellular0/1/0
 ip address negotiated
 ip nat outside
!
interface Cellular0/1/1
 no ip address
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto
!
interface Vlan1
 no ip address
 shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
ip tftp source-interface GigabitEthernet0
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0
!
!
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
line con 0
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 login
!
!
end
========================

Outputs:

 

Router#show cellular 0/1/0 profile

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = telstra.internet
Authentication = None

Profile 2 = INACTIVE
--------

  * - Default profile
 ** - LTE attach profile

 

Additional things I can't get straight.

1- All the encapsulation in the configuration docs that i found had SLIP but on this router there isn't any available.

Router(config)#int cell 0/1/0
Router(config-if)#en
Router(config-if)#encapsulation slip
                                 ^
% Invalid input detected at '^' marker.

Router(config-if)#encapsulation ?
  atm-dxi         ATM-DXI encapsulation
  bstun           Block Serial tunneling (BSTUN)
  frame-relay     Frame Relay networks
  hdlc            Serial HDLC synchronous
  lapb            LAPB (X.25 Level 2)
  ppp             Point-to-Point protocol
  sdlc            SDLC
  sdlc-primary    SDLC (primary)
  sdlc-secondary  SDLC (secondary)
  smds            Switched Megabit Data Service (SMDS)
  stun            Serial tunneling (STUN)
  x25             X.25

Router(config-if)#end

 

------------------

Debugs:


Router#
Router#
*Jun 13 02:36:16.832: ecell_ipc_rx_handler: IPC RX [20]:
*Jun 13 02:36:16.832: IPC  (40 bytes):
 04 00 00 14 00 00 00 00 01 01 00 00 00 01 00 01
 00 10 00 00 00 00 00 00 00 00 00 02 00 00 00 00
 00 00 00 04 00 00 00 00

*Jun 13 02:36:16.833: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Jun 13 02:36:16.833: [Cellular0/1/0]:MGMT RX (HEARTBEAT_NOTIFY) (16 bytes):
 00 00 00 00 01 01 00 00 00 01 00 01 00 10 00 00


*Jun 13 02:36:16.833: [Cellular0/1/0]:MGMT TX (CONN_RATE_GET Non-b
Router#lock) (16 bytes):
 00 00 00 00 01 01 00 00 00 02 00 45 00 10 00 01


*Jun 13 02:36:16.833: ecell_set_gps_led: cw_mgmt->gps_info = 7FBFEBDE91E4
*Jun 13 02:36:16.833:  no change in GPS state 1
*Jun 13 02:36:16.843: ecell_ipc_rx_handler: IPC RX [36]:
*Jun 13 02:36:16.843: IPC  (40 bytes):
 04 00 00 24 00 00 00 00 01 01 00 00 00 03 00 45
 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00

*Jun 13 02:36:16.844: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Jun 13 02:36:16.844: [Cellular0/1/0]:MGMT RX (GSM_CONN_RATE_GET_RESP) (32 bytes):
 00 00 00 00 01 01 00 00 00 03 00 45 00 20 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00


*Jun 13 02:36:22.131: [Cellular0/1/0]:MGMT TX (BAND_GET Non-block) (16 bytes):
 00 00 00 00 01 01 00 00 00 02 00 06 00 10 00 45


*Jun 13 02:36:22.132: [Cellular0/1/0]:MGMT TX (SYSTEM_STATS_GET Non-block) (16 bytes):
 00 00 00 00 01 01 00 00 00 02 00 D6 00 10 00 45


*Jun 13 02:36:22.132:  send system stats get msg rc 1
*Jun 13 02:36:22.166: ecell_ipc_rx_handler: IPC RX [20]:
*Jun 13 02:36:22.166: IPC  (40 bytes):
 04 00 00 14 00 00 00 00 01 01 00 00 00 06 00 00
 00 10 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00

*Jun 13 02:36:22.167: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Jun 13 02:36:22.167: [Cellular0/1/0]:MGMT RX (ERROR) (16 bytes):
 00 00 00 00 01 01 00 00 00 06 00 00 00 10 00 00


*Jun 13 02:36:22.226: ecell_ipc_rx_handler: IPC RX [158]:
*Jun 13 02:36:22.226: IPC  (40 bytes):
 04 00 00 9E 00 00 00 00 01 01 00 00 00 01 00 09
 00 9A 00 00 00 00 00 00 00 00 00 02 00 00 00 00
 00 00 00 04 00 00 00 00

*Jun 13 02:36:22.227: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Jun 13 02:36:22.227: [Cellular0/1/0]:MGMT RX (SYS_STATUS_NOTIFY) (154 bytes):
 00 00 00 00 01 01 00 00 00 01 00 09 00 9A 00 00
 00 00 00 00 00 00 00 02 00 00 00 00 00 00 00 04
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 02 00 00 00
 03 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00 00 00

*Jun 13 02:36:22.228: Cellular0/1/0: callbak_flag 1 service_status 2 channel number 0

Router#
Router#
Router#
Router#
*Jun 13 02:36:26.830: ecell_ipc_rx_handler: IPC RX [20]:
*Jun 13 02:36:26.830: IPC  (40 bytes):
 04 00 00 14 00 00 00 00 01 01 00 00 00 01 00 01
 00 10 00 00 00 00 00 00 00 00 00 02 00 00 00 00
 00 00 00 04 00 00 00 00

*Jun 13 02:36:26.830: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Jun 13 02:36:26.830: [Cellular0/1/0]:MGMT RX (HEARTBEAT_NOTIFY) (16 bytes):
 00 00 00 00 01 01 00 00 00 01 00 01 00 10 00 00


*Jun 13 02:36:26.830: [Cellular0/1/0]:MGMT TX (CONN_RATE_GET Non-b
Router#
Router#
Router#
Router#
Router#lock) (16 bytes):
 00 00 00 00 01 01 00 00 00 02 00 45 00 10 00 01


*Jun 13 02:36:26.831: ecell_set_gps_led: cw_mgmt->gps_info = 7FBFEBDE91E4
*Jun 13 02:36:26.831:  no change in GPS state 1
*Jun 13 02:36:26.840: ecell_ipc_rx_handler: IPC RX [36]:
*Jun 13 02:36:26.840: IPC  (40 bytes):
 04 00 00 24 00 00 00 00 01 01 00 00 00 03 00 45
 00 20 00 00 00 00 00 00 00 00 00 00 00 00 00 00
 00 00 00 00 00 00 00 00

*Jun 13 02:36:26.841: ecell_mgmt_process_ipc_event: IPC Message [400] Received

*Ju
Router#
Router#
Router#n 13 02:36:26.841: [Cellular0/1/0]:MGMT RX (GSM_CONN_RATE_GET_RESP) (32 bytes):
 00 00 00 00 01 01 00 00 00 03 00 45 00 20 00 00
 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

un all
 Parameter map cws-tunnel global not configured
All possible debugging has been turned off

----------------------------

 


Router#sh ip int brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0/0   unassigned      YES unset  administratively down down
GigabitEthernet0/0/1   unassigned      YES unset  administratively down down
Cellular0/1/0          unassigned      YES manual up                    up <<<<------------
Cellular0/1/1          unassigned      YES unset  down                  down
GigabitEthernet0       unassigned      YES unset  administratively down down
Vlan1                  unassigned      YES unset  administratively down down


Router(config-if)#encapsulation ppp
Router(config-if)#
*Jun 13 03:48:02.573: Cellular0/1/0: Unsupported encap typeend
Router#
*Jun 13 03:48:04.815: %SYS-5-CONFIG_I: Configured from console by console
Router#sh inte cellular 0/1/0
  Hardware is 4G WWAN NIM - Global Multimode(Europe) LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/GPRS
  Internet address will be negotiated using IPCP
  MTU 1500 bytes, BW 50000 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation HDLC, loopback not set
  Keepalive not supported
  Last input never, output never, output hang never
  Last clearing of "show interface" counters never
  Input queue: 0/375/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 0 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out

 

I've asked for an encapsulation method from the provider and authentication username password.

 

Need help on this if someone can point me to the right link or what configuration am i missing.

 

Thanks,

Ab

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

I got the 4G module working.

There are 2 parts to it.

  1. ISP Side configuration (get the below from your ISP)
    1. Username
    2. Password
    3. Authentication method
    4. APN
  2. Configuration on the router.

 Below is the configuration that needs to be done on the router.

 

Physical bit:

 

Make sure the antennas are connected to both the  M0 Main and M1 DIV.

The WWAN is static green with the SIM in.

Service LED – static Blue (2G) or Green

 

Configuration:

  1. Create the cellular profile
  2. Bind it to the controller
  3. Configure cellular interface.
  4. Perform nat statements
  5. Give a static route for the cellular interface.
  6. Access-lists
  7. Loopback interface is a must (any ip on /32). Mine only worked after the loopback interface.
  8. Once done, do a ping to 8.8.8.8 or any public or MPLS IP(if the sim is MPLS enabled).

 

Configuration

 

Router# cellular <interface number> lte profile create <profile number 1-16> APN <myisp.apn> authentication <chap/pap/none> username password

Router# cellular 0/1/0 lte profile create 10  myisp.apn chap username password

 

Router (config)#

controller Cellular 0/1/0

lte sim data-profile 10 attach-profile  10

lte modem dm-log output local-uf

lte modem dm-log rotation

lte modem link-recovery rssi onset-threshold -110

lte modem link-recovery monitor-timer 30

lte modem link-recovery wait-timer 30

lte modem link-recovery debounce-count 20

!

!

interface Cellular0/1/0

description Cellular-link

bandwidth 2000

ip address negotiated

ip nat outside

dialer in-band

dialer idle-timeout 0

dialer-group 1

pulse-time 1

!

!

ip nat inside source list 2 interface Cellular0/1/0 overload

!

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0

!

!

access-list 1 permit any

access-list 2 permit any

dialer-list 1 protocol ip permit

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

 

Do a PING and interface will come up with an IP as you will have to initiate the traffic for the interface cellular to obtain an IP.

 

ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

.

*Oct 30 23:04:49.007: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to up

*Oct 30 23:04:50.007: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/1/0, changed state to up.!!!

Success rate is 60 percent (3/5), round-trip min/avg/max = 24/77/177 ms

 

Outputs:

 

sh ip int br | e una

Interface              IP-Address      OK? Method Status                Protocol

Cellular0/1/0          10.102.XX.YY   YES IPCP   up                    up

Loopback0              192.168.1.1     YES NVRAM  up                    up

 

 

Router#sh cellular 0/1/0 profile

 

Profile 1 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = telstra.internet

Authentication = None

 

Profile 10 = ACTIVE* **

--------

PDP Type = IPv4

PDP address = 10.102.xx.yy

Access Point Name (APN) = telstra.internet

Authentication = CHAP

Username: admin

Password: admin

        Primary DNS address = 10.a.b.c

        Secondary DNS address = 10.d.e.f

        Primary DNS IPV6 address = 0

        Secondary DNS IPV6 address = 0

 

  * - Default profile

** - LTE attach profile

 

Hope that works for you!

 

Thanks,

Ab

View solution in original post

3 REPLIES 3
Highlighted
Beginner

Hi,

Did you ever get this working ? I have an ISR 4221 with a 4g NIM card but also cannot get it working. Looking for a base config if anyone has one - as the configs i have used to date are on 800 and 1900 and IOS 15 etc. I had two types of config - one using a dialer, one directly under cellular 0 - but neither of these seem applicable to the 4221 / IOS-XE etc

 

Any help would be much appreciated.

 

Thanks

Peter

Highlighted

I got the 4G module working.

There are 2 parts to it.

  1. ISP Side configuration (get the below from your ISP)
    1. Username
    2. Password
    3. Authentication method
    4. APN
  2. Configuration on the router.

 Below is the configuration that needs to be done on the router.

 

Physical bit:

 

Make sure the antennas are connected to both the  M0 Main and M1 DIV.

The WWAN is static green with the SIM in.

Service LED – static Blue (2G) or Green

 

Configuration:

  1. Create the cellular profile
  2. Bind it to the controller
  3. Configure cellular interface.
  4. Perform nat statements
  5. Give a static route for the cellular interface.
  6. Access-lists
  7. Loopback interface is a must (any ip on /32). Mine only worked after the loopback interface.
  8. Once done, do a ping to 8.8.8.8 or any public or MPLS IP(if the sim is MPLS enabled).

 

Configuration

 

Router# cellular <interface number> lte profile create <profile number 1-16> APN <myisp.apn> authentication <chap/pap/none> username password

Router# cellular 0/1/0 lte profile create 10  myisp.apn chap username password

 

Router (config)#

controller Cellular 0/1/0

lte sim data-profile 10 attach-profile  10

lte modem dm-log output local-uf

lte modem dm-log rotation

lte modem link-recovery rssi onset-threshold -110

lte modem link-recovery monitor-timer 30

lte modem link-recovery wait-timer 30

lte modem link-recovery debounce-count 20

!

!

interface Cellular0/1/0

description Cellular-link

bandwidth 2000

ip address negotiated

ip nat outside

dialer in-band

dialer idle-timeout 0

dialer-group 1

pulse-time 1

!

!

ip nat inside source list 2 interface Cellular0/1/0 overload

!

ip route 0.0.0.0 0.0.0.0 Cellular0/1/0

!

!

access-list 1 permit any

access-list 2 permit any

dialer-list 1 protocol ip permit

!

!

interface Loopback0

ip address 192.168.1.1 255.255.255.255

!

 

Do a PING and interface will come up with an IP as you will have to initiate the traffic for the interface cellular to obtain an IP.

 

ping 8.8.8.8

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:

.

*Oct 30 23:04:49.007: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to up

*Oct 30 23:04:50.007: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/1/0, changed state to up.!!!

Success rate is 60 percent (3/5), round-trip min/avg/max = 24/77/177 ms

 

Outputs:

 

sh ip int br | e una

Interface              IP-Address      OK? Method Status                Protocol

Cellular0/1/0          10.102.XX.YY   YES IPCP   up                    up

Loopback0              192.168.1.1     YES NVRAM  up                    up

 

 

Router#sh cellular 0/1/0 profile

 

Profile 1 = INACTIVE

--------

PDP Type = IPv4

Access Point Name (APN) = telstra.internet

Authentication = None

 

Profile 10 = ACTIVE* **

--------

PDP Type = IPv4

PDP address = 10.102.xx.yy

Access Point Name (APN) = telstra.internet

Authentication = CHAP

Username: admin

Password: admin

        Primary DNS address = 10.a.b.c

        Secondary DNS address = 10.d.e.f

        Primary DNS IPV6 address = 0

        Secondary DNS IPV6 address = 0

 

  * - Default profile

** - LTE attach profile

 

Hope that works for you!

 

Thanks,

Ab

View solution in original post

Highlighted

I used this configuration 1:1 and it works instantly. Thank you

Content for Community-Ad