08-16-2011 07:35 AM - edited 03-07-2019 01:44 AM
I have a few things setup in NAT on my Cisco 1700 router to allow forwarding to our servers. One of our servers that runs VOIP requires a range of ports setting up. In the NAT settings at the botton where you can select the type and port, Is it possible to do a range of ports on one setting or does it have to be a seperate setting per port?
Thanks
Paul
08-22-2011 12:55 PM
Any thoughts on this guys?
08-22-2011 01:15 PM
Hi,
which ios version have you got? Have you got a pool a public static IPs?
Regards.
Alain.
08-22-2011 01:31 PM
Just a single static ip address on this connection.
Cheers
Paul
08-22-2011 02:42 PM
Paul,
This can be done through the following sample configuration:
Take a look.
======================================
interface Ethernet0/0
description LAN
ip address 1.1.1.1 255.255.255.0
ip nat inside
!
interface Serial2/0
description WAN
ip address 2.2.2.1 255.255.255.0
ip nat outside
!
! NAT pool should contain the private ip address
!
ip nat pool TEST 1.1.1.2 1.1.1.2 prefix-length 30 type rotary
!
ip nat inside destination list 100 pool TEST
!
access-list 100 permit tcp any any range 5004 5082
access-list 100 permit tcp any any range 10000 20000
===============================================
As far as UDP ports are concerned you will need to create a static port
forwarding entry for each UDP port.
There is a bug is open for this enhancement; CSCsk86712
You can try the above stated configuration for TCP ports for UDP, but as its
not a supported configuration(for UDP) it may not work.
Regards,
Amit
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide