cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2934
Views
9
Helpful
21
Replies

Cisco Router - Cannot Get Internet Access (867VAE-K9) via Local Subnet

hasan0242
Level 1
Level 1

Hi guys 
I'm a newbie and trying to learn to Cisco IOS. I'm unable to get internet access on my router. Any help in debugging the issue will be great. I assume it has something to do with routing and ACL. I'm attaching the network diagram and running configuration as below: 

Router#sh run
Building configuration...

Current configuration : 1474 bytes
!
! Last configuration change at 02:06:35 UTC Mon Mar 6 2023
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
wan mode ethernet
no ipv6 cef
ip source-route
ip cef
!
!
!
!
ip dhcp pool Test1
network 192.168.5.0 255.255.255.0
class class1
address range 192.168.5.1 192.168.5.254
!
!
ip dhcp class class1
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
!
!
!
controller VDSL 0
shutdown
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
ip address 192.168.1.180 255.255.255.0
shutdown
keepalive 5
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
no ip address
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.5.1 255.255.255.0
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Ethernet0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
access-list 1 permit any
!
!
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 60000 1000
end

 

21 Replies 21

from first view there is no issue with your router config except 
I think you need to run command 
ip routing 

Thanks for your reply. 
Here's the excerpt from sh ip route: 

Router#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
+ - replicated route, % - next hop override

Gateway of last resort is not set

192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, Vlan10
L 192.168.5.1/32 is directly connected, Vlan10


I cannot see 192.168.1.0/24 network coming up here. 

Hi @hasan0242 ,

This is because interface ethernet0 is shutdown according to your configuration.

interface Ethernet0
ip address 192.168.1.180 255.255.255.0
shutdown
keepalive 5
!

You need to enter the following commands to change that:

config t

int e0

no shutdown

end

wr mem

Regards,

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

Thanks for point it out Harold. 
i did try to turn on the interface before but got below error/ details: 

Router(config)#int ethernet 0
Router(config-if)#no shut

% WAN interface is Ethernet.

WAN interface should definitely be Ethernet. But, now I'm not sure why I can't turn on this interface

 

Same configuration of ethernet interface apply to gigaethernet 1

Note:-you need to reomve ip from erhernet before apply it to gigs

Of course also remove cable. 

So, should I put 192.168.1.180 255.255.255.0 for both GE 1 and Ethernet 0? 
Router#sh ip int brief
Interface IP-Address OK? Method Status Protocol
ATM0 unassigned YES NVRAM administratively down down
Ethernet0 192.168.1.180 YES manual administratively down down
FastEthernet0 unassigned YES unset down down
FastEthernet1 unassigned YES unset down down
FastEthernet2 unassigned YES unset down down
FastEthernet3 unassigned YES unset down down
GigabitEthernet0 unassigned YES unset up up
GigabitEthernet1 192.168.1.180 YES manual up up
NVI0 unassigned NO unset up up
Vlan1 unassigned YES unset down down
Vlan10 192.168.5.1 YES NVRAM up up


In that case, should I remove IP from ethernet 0, configure it first. and then re-configure GE 1 with the same config? 


Hi @hasan0242 ,

According to the following document, it is the gigabit ethernet port that needs to be configured as the wan interface when the wan mode is ethernet. This would explain the message you see when you try to unshut Ethernet 0.

https://www.cisco.com/c/en/us/support/docs/long-reach-ethernet-lre-digital-subscriber-line-xdsl/lre-vdsl-long-reach-ethernet-very-high-data-rate-dsl/200987-Configure-WAN-Mode.pdf

Regards,

Regards,
Harold Ritter, CCIE #4168 (EI, SP)

Thanks Harold. 
It makes sense. Can you share what is the purpose of "Interface: Ethernet 0" is, for this scenario? 
I can now ping the 192.168.1.0/24 network from the router. 
Router IP: 192.168.5.1 

and router is responsive from any hosts under 192.168.1.0/24 network. 

However, a PC is connected to the GE0 interface where DHCP 192.168.5.0/24 has been setup. 

PC is getting IP 192.168.5.2. But, it cannot ping 192.168.5.1. 
Still I'm unable to get internet access. Do I need to change any NAT policy. 

Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet1
L 192.168.1.181/32 is directly connected, GigabitEthernet1
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, Vlan10
L 192.168.5.1/32 is directly connected, Vlan10

 

and sh run command: 


interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
ip address 192.168.1.181 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.5.1 255.255.255.0
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Ethernet0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
access-list 1 permit any

 

Or Do I need to change IP Default Gateway

The port is down

You miss no shut port

Thanks @MHM Cisco World 
Could you please help me with accessing the internet? I can now ping the interfaces as below: 

I can now ping the 192.168.1.0/24 network from the router. 
Router IP: 192.168.5.1 

and router is responsive from any hosts under 192.168.1.0/24 network. 

However, a PC is connected to the GE0 interface where DHCP 192.168.5.0/24 has been setup. 

PC is getting IP 192.168.5.2. But, it cannot ping 192.168.5.1. 
Still I'm unable to get internet access. Do I need to change any NAT policy. 

Excerpt of SH IP ROUTE: 
Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet1
L 192.168.1.181/32 is directly connected, GigabitEthernet1
192.168.5.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.5.0/24 is directly connected, Vlan10
L 192.168.5.1/32 is directly connected, Vlan10

 

and sh run command: 


interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
ip address 192.168.1.181 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.5.1 255.255.255.0
!
ip default-gateway 192.168.1.1
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface Ethernet0 overload
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
access-list 1 permit any

 

Or Do I need to change IP Default Gateway? or make some changes to NAT policy? 

You change to GE but you nat still point to ethnet 0'

Correct it 

Hi @MHM Cisco World Thank you for the input. I have now changed the IP Route as per below. 

I can ping from laptop to router (192.168.5.2) to (192.168.5.1)
However, I'm unable to ping from putty to laptop (192.168.5.1) to (192.168.5.2). So, I'm assuming it is still related to NAT. 

GigabitE 0 is part of VLAN10. DHCP (192.168.5.0/24) is setup on VLAN10. Laptop is directly connected to GigabitE 0

I've seen this on the startup log: 

%Default route without gateway, if not a point-to-point interface, may impact performance%Default route without gateway, if not a point-to-point interface, may impact performance

 

 

Router#sh run
Building configuration...

Current configuration : 1430 bytes
!
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
wan mode ethernet
no ipv6 cef
ip source-route
ip cef
!
!
!
!
ip dhcp pool Test1
network 192.168.5.0 255.255.255.0
class class1
address range 192.168.5.1 192.168.5.254
!
!
ip dhcp class class1
!
!
!
!
crypto pki token default removal timeout 0
!
!
!
!
!
!
controller VDSL 0
shutdown
!
!
!
!
!
!
!
!
!
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface Ethernet0
no ip address
shutdown
keepalive 5
!
interface FastEthernet0
switchport access vlan 10
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface GigabitEthernet0
switchport access vlan 10
no ip address
!
interface GigabitEthernet1
ip address 192.168.1.181 255.255.255.0
duplex auto
speed auto
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 192.168.5.1 255.255.255.0
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 GigabitEthernet1
ip route 0.0.0.0 0.0.0.0 Vlan10
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
access-list 1 permit any
!
!
!
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 60000 1000
end

 

It must be related to NAT or ACL. Could you please point me to the right direction? 

I dont see any NAT at all 
there is no ip nat inside/outside and there is no ip nat inside source ??

If I put NAT for VLAN 10 and GE 1, I can't ping from 192.168.5.2 to 192.168.5.1 anymore. 
I have put the command as below: 

VLAN 10 : ip nat inside 
GE 1 : ip nat outside