cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
715
Views
0
Helpful
1
Replies
Highlighted
Beginner

Cisco SR520 issues

Hi all,

I have been working on a customer site for quite some time now and keep on running into a variety of issues with their connection to the internet.  The Cisco SR520 is currently attached to the ADSL service, it stays up and running for a random ammount of time.  It disconnects sometimes 3 minutes, sometimes 8 hours but it still keeps on disconnecting. 

If I plug in the old Dreytek router the service stays connected but still it will drop after say 24 hours.

I'd just very much appreciate it if someone could look over my config below and tell me if there are any obvious mistakes which could be effecting the service;

Many thanks in advance.

James

!

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxxx

!

boot-start-marker

boot-end-marker

!

logging buffered 4096

no logging console

enable password 7 xxxxx

!

aaa new-model

!

!

!

!

aaa session-id common

!

crypto pki trustpoint TP-self-signed-3735572396

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-xxxx

revocation-check none

rsakeypair TP-self-signed-3735572396

!

!

crypto pki certificate chain TP-self-signed-xxxx

certificate self-signed 01

  30820255 308201BE A0030201 02020101 300D0609 2A864886 F70D0101 04050030

  31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274

  69666963 6174652D 33373335 35373233 3936301E 170D3131 30363237 32303037

  35395A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649

  4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D33 37333535

  37323339 3630819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281

  81009BEF 4153679A FEFB1CFB CD7497AC B8603721 7523E362 5EE41129 D8372782

  329D8C17 2643A167 0D5CE2FD 5CB9FEB6 12D54878 ACBA42CA 0F8D9071 DD102B0B

  7A22F535 AE626BAF 6BA4C128 18CEEE6E D1E895FF 53D5DC48 74200C5B 1A3ABB56

  F64221D2 F16A146C 07EFA94D 82F8272F 65A1E419 AFC58B7B A0027123 FB5ABC41

  EC570203 010001A3 7D307B30 0F060355 1D130101 FF040530 030101FF 30280603

  551D1104 21301F82 1D77746B 5F737235 32305F31 5F312E31 2E6B6E6F 776C6573

  2E636F2E 756B301F 0603551D 23041830 16801451 C3D58210 269482C3 9ADEA71E

  D96D91FB 92228630 1D060355 1D0E0416 041451C3 D5821026 9482C39A DEA71ED9

  6D91FB92 2286300D 06092A86 4886F70D 01010405 00038181 0080F3C7 AFF77F20

  161BAC4A FC24AE4C B987B43A B190CE70 9C3587DC ADA1276F 147611BA F42955E1

  621365F0 7558CFCD F7B016C2 18C6B2B5 B2F0B3BD 87CF1068 CF26B253 B873AFCC

  EAAD9AEA 1524C03D C7AF1687 821040D5 BA992978 2D2C13E4 031F5C62 9BE3554D

  C62D7EB5 65EDBD66 D227A053 E8ECA95A 892113AA 352ED910 AE

        quit

dot11 syslog

!

dot11 ssid xxxx

guest-mode

wpa-psk ascii 7 xxxxx

!

ip source-route

!

!

!

!

ip cef

ip domain name knowles.co.uk

ip name-server 8.8.8.8

ip name-server 8.8.4.4

no ipv6 cef

!

multilink bundle-name authenticated

!

!

username xxxx privilege 15 password 7 xxxxx

!

!

!

archive

log config

  hidekeys

!

!

ip ssh time-out 60

ip ssh authentication-retries 2

!

bridge irb

!

!

interface ATM0

no ip address

no atm ilmi-keepalive

!

interface ATM0.1 point-to-point

pvc 0/38

  pppoe-client dial-pool-number 1

!

!

interface FastEthernet0

description ## INSIDE CrossOver ##

switchport access vlan 10

!

interface FastEthernet1

description ## Unused ##

!

interface FastEthernet2

description ## Unused ##

!

interface FastEthernet3

description ## SERVER OUTSIDE ##

!

interface Dot11Radio0

no ip address

!

encryption vlan 10 mode ciphers aes-ccm

!

ssid wtk_wifi

!

speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0

station-role root

!

interface Dot11Radio0.10

encapsulation dot1Q 10

bridge-group 10

bridge-group 10 subscriber-loop-control

bridge-group 10 spanning-disabled

bridge-group 10 block-unknown-source

no bridge-group 10 source-learning

no bridge-group 10 unicast-flooding

!

interface Vlan1

description ## OUTSIDE LAN ##

ip address 192.168.1.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

!

interface Vlan10

description ## INSIDE LAN ##

no ip address

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1412

bridge-group 10

!

interface Dialer0

ip address negotiated

ip mtu 1452

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer idle-timeout 0

dialer persistent

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname xxxx@demon.a

ppp chap password 7 xxxxx

ppp pap sent-username xxxx@demon.a password 7 xxxxx

ppp ipcp dns request

!

interface BVI10

ip address 10.0.0.254 255.255.255.0

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 Dialer0

!

no ip http server

ip http authentication local

ip http secure-server

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source static tcp 10.0.0.2 25 interface Dialer0 25

ip nat inside source static tcp 10.0.0.2 22 interface Dialer0 22

ip nat inside source static tcp 10.0.0.2 3389 interface Dialer0 3389

!

access-list 1 permit 10.0.0.0 0.0.0.255

access-list 1 permit 192.168.1.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

!

control-plane

!

bridge 10 protocol ieee

bridge 10 route ip

!

line con 0

no modem enable

line aux 0

line vty 0 4

transport input ssh

!

scheduler max-task-time 5000

end

1 REPLY 1
Highlighted
Beginner

I resolved this problem via this article;

Modem Firmware seems to resolve the issue

https://supportforums.cisco.com/thread/2041041

Content for Community-Ad