cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
401
Views
0
Helpful
13
Replies

Cisco WS-3850-24T-S

kzahoor
Beginner
Beginner

Hi,

 

 I have above switch which I have tried to update from 16.3.1 and I have took it to 16.3.6 but not without a struggle.

 

At first, it completely failed to boot even after telling me that firmware upgrade was successful.

 

I have managed to use usb with image on it to get it going.

 

I also had to point boot variable to packages.conf as it wasn't loading the full package.

On support website, I can see there is Gibraltar 16.12.07 available to install.

 

Am I correct in thinking I can install this without destroying it again? or do I need to be careful about it ?

 

 

1 Accepted Solution

Accepted Solutions

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

If this is for "personal" use, do not even make any attempt to upgrade to 16.9.X (and later). 

Stick to 3.6.X, 3.7.X, 16.3.X or 16.6.X.  

Cisco 3850: IOS-XE/Firmware Upgrade

View solution in original post

13 Replies 13

marce1000
VIP Mentor VIP Mentor
VIP Mentor

 

 - If you are unsure of outcome , then copy running-config to external repository first with scp or  tftp, in worst case, factory reset, upgrade on virgin device then you can (still) restore config.

 M.

thanks.

 

I am not really bothered about config though I do have a backup of the config.

it won't kill the device if firmware upgrade fails ? thats what I want to know.

 

also, would that be correct latest version >> https://software.cisco.com/download/home/284455425/type/282046477/release/Gibraltar-16.12.7

 

regards

 

 

 - Firmware upgrade won't kill the device , when done correctly and or  always best to study release notes of intended version ,  yes link is latest advisory release which is the best to install.

 M.

thanks.

whats the best procedure to install I have used below previously

 

++ upload the firmware using tftp or usb to flash

++ then boot flash: name of BIN file

 

I have also used request platform software package install switch all file flash:BIN file

 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

If this is for "personal" use, do not even make any attempt to upgrade to 16.9.X (and later). 

Stick to 3.6.X, 3.7.X, 16.3.X or 16.6.X.  

Cisco 3850: IOS-XE/Firmware Upgrade

thanks @Leo Laohoo  the link you have provided is pretty comprehensive.

 

Yes its for personal use. I may take it up to 16.6.9

One question, where do I get the SMU file from if I need to go down that route ?

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

@kzahoor wrote:

where do I get the SMU file from if I need to go down that route ?


Do not install SMU unless you hit the bugs.  
Take it from someone who's been "beta testing" Cisco firmware since 2010, SMU usually introduce more bugs than fixing them.

thanks for that.

an update for 16.6.9, everything works however I am unable to login to WebUi after short amount of time. serial / ssh works fine still

WebUI just says invalid creds. is that a buggy web ui or something else.

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

@kzahoor wrote:

WebUI just says invalid creds. is that a buggy web ui or something else.


No, that means HTTP is not configured correctly.

so why would it work upon first login and then fail to login on subsequent attempt fail unless i restart the http server again ?

 

 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

What firmware is the switch on?

16.6.9

kzahoor
Beginner
Beginner

further update, I have managed to upgrade to 16.6.9 without any problems. just going to follow the other thread for my 3750G switch

 

I can login if i shut down and restart http secure-server

 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: