cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2439
Views
0
Helpful
4
Replies

Cisco WS-C2960S-48FPS-L power problems

radoslav-drabik
Beginner
Beginner

Hello,

Wondering if you can help me.

I have a Cisco WS-C2960S-48FPS-L switch which connects some VOIP conference phones (Polycom SoundStation IP7000 or IP6000). The phones don't come up. It looks like the switch is not providing enough power. If I connect any other phone (Siemens OpenStage, OptiPoint) it comes up w/o problems.

One more interesting thing. When I set a static power on the port the Polycom phones work fine.

Is there any bug that I am running into?

In the log I can see the following messages:

Dec  3 14:42:01.661 GMT: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/18: Power granted

Dec  3 14:44:08.665 GMT: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/18: Power granted

Dec  3 14:46:22.699 GMT: %ILPOWER-5-POWER_GRANTED: Interface Gi1/0/18: Power granted

Switch type: cisco WS-C2960S-48FPS-L

IOS version: c2960s-universalk9-mz.122-58.SE1.bin

LLDP is running on the switch.

The port config:

interface GigabitEthernet1/0/18

switchport access vlan 104

switchport mode access

switchport voice vlan 404

switchport port-security maximum 7

switchport port-security

switchport port-security aging time 1

switchport port-security aging type inactivity

no logging event link-status

load-interval 60

priority-queue out

no snmp trap link-status

spanning-tree portfast disable

end

!

lldp run

Working scenario with the static power setting:

interface GigabitEthernet1/0/18

power inline consumption 15400

power inline static

switch#show lldp neighbors gigabitEthernet 1/0/18

Capability codes:

    (R) Router, (B) Bridge, (T) Telephone, (C) DOCSIS Cable Device

    (W) WLAN Access Point, (P) Repeater, (S) Station, (O) Other

Device ID           Local Intf     Hold-time  Capability      Port ID

Polycom SoundStationGi1/0/18       120        T               0004.f2eb.6504

Total entries displayed: 1

4 Replies 4

Arumugam Muthaiah
Cisco Employee
Cisco Employee

Hi,

Please try to perform the below debug and check the logs. This issue seems to be matching with known DDTS

#debug ilpower port

#debug ilpower powerman

CSCtj20486 - phone requests 13W but it seems the switch just provides 9.8W

some time the issue was resolved by upgrading the polycom firmware to a newer version 3.3.1

Please verify the logs and firmware version, then share the detail.

Regards,

Aru

*** Please rate if the post is useful ***

Regards, Aru *** Please rate if the post useful ***

Hi, see the attached file. I did

#debug ilpower port

#debug ilpower powerman

The phone is connected on port 1/0/18.

Thanks.

radoslav-drabik
Beginner
Beginner

One more interesting thing...when I disabled the lldp feature on that port the phone worked just fine and the switch was even able to recognize the phone's power class.

That means that there must be some glitch when the phone negotiates its power capabilities with the switch by means of lldp.

Following lines were added to disable lldp on the port.

Interface giga 1/0/18
no lldp receive
no lldp transmit


Sent from Cisco Technical Support Android App

zidjali2007
Beginner
Beginner

I have this problem too. I will upgrade the IOS. The current IOS is 12.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers