configure pppoe on 831 router with modem in bridge mode
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-08-2012 12:15 PM - edited 03-07-2019 08:46 AM
Hi,
Can some one please provide a config to setup PPPoE on the cisco 831 router to be used with a modem in bridge mode. I have tired other peoples configs found on the web but, not all the commands were available on the IOS version thats on the router. Also note that I bought this as a used router and I dont have a service contract so I am unable to download an updated IOS. The router ver is 12.3(7)T9 and the IOS is c831-k9o3sy6-mz.123-7.T9.bin. Running config below is last tried still could not connect or get ip address from isp. Wasent sure which ppp authentication to use so I used both pap and chap not sure if thats ok. Any help would be apreciated thanks...
831#sh run
Building configuration...
Current configuration : 1967 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname 831
!
boot-start-marker
boot-end-marker
!
!
username bertone privilege 15 password 7 00071A150754
no aaa new-model
ip subnet-zero
ip domain name ackzz.com
ip name-server 4.2.2.2
!
!
ip audit po max-events 100
vpdn enable
!
vpdn-group 1
request-dialin
protocol pppoe
!
no ftp-server write-enable
!
!
!
!
no crypto isakmp enable
!
!
!
interface Ethernet0
description $ETH-LAN$
ip address 192.168.2.3 255.255.255.192
ip nat inside
!
interface Ethernet1
no ip address
ip nat outside
duplex auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer1
ip address negotiated
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin callout
ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxx
ppp chap password 7 xxxxxxxxxxxxxxxxxxxx
ppp pap sent-username xxxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxx
!
router rip
version 2
redistribute static
network 192.168.2.0
network 192.168.254.0
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
ip http authentication local
ip http secure-server
ip dns server
ip nat inside source list nat_address interface Ethernet1 overload
!
!
ip access-list standard nat_address
permit any
!
!
control-plane
!
banner motd ^C
************************************************
Authorised Access Only - Do Not Enter
************************************************
^C
!
line con 0
exec-timeout 0 0
password 7 13061E010803
logging synchronous
login
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
exec-timeout 0 0
password 7 14141B180F0B
logging synchronous
login local
length 0
transport preferred none
transport input telnet ssh
transport output none
!
scheduler max-task-time 5000
!
- Labels:
-
Other Switching
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-08-2012 12:38 PM
Hi,
you must put dialer 1 as nat outside interface and also change your nat statement like this:
no ip nat inside source list nat_address interface Ethernet1 overload
ip nat inside source list 10 interface dialer1
no ip access-list standard nat_address
access-list 10 permit 192.168.2.0 0.0.0.63
Let us know if this solves your problem.
Regards.
Alain
Don't forget to rate helpful posts.
- Mark as New
- Bookmark
- Subscribe
- Mute
- Subscribe to RSS Feed
- Permalink
- Report Inappropriate Content
09-08-2012 01:52 PM
Hi Alan, didnt make any difference. Is there a simple config even with out nat just to connect to isp using pppoe on router conected to modem in bridge mode? I can do the nat part later, just want to connect for now, I remeber seeing some one do that on youtube a while ago
