cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
305
Views
0
Helpful
2
Replies
Highlighted
Beginner

Configure stacking 9200L with VLAN trunk

We have four 9200L switches stacked together. I am trying to config it to connect to our core switch(Mellanox SN2100 100G switch) using LACP trunking. After play around I can't figure out why it won't pass traffic to my core switch. I need some help here. Thank you.

 

Here are some details:

1. sh run (on Cisco 9200L)

Current configuration : 13187 bytes
!
! Last configuration change at 14:14:01 UTC Thu Jun 27 2019 by jgao
! NVRAM config last updated at 13:56:40 UTC Thu Jun 27 2019 by jgao
!
version 16.11
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service call-home
no platform punt-keepalive disable-kernel-core
!
hostname patch-03
!
!
vrf definition Mgmt-vrf
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv6
 exit-address-family
!
enable password xxxxxxxxx
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
aaa session-id common
clock timezone UTC -8 0
clock summer-time UTC recurring
switch 1 provision c9200l-48p-4x
switch 2 provision c9200l-48p-4x
switch 3 provision c9200l-48p-4x
switch 4 provision c9200l-48p-4x
!
!
ip arp entry learn 10240
!
ip name-server 10.36.24.2
ip name-server vrf Mgmt-vrf 10.36.24.2
ip domain name van.aaaaaaa.com
!
!
port-channel load-balance src-ip
license boot level network-essentials addon dna-essentials
!
!
diagnostic bootup level minimal
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
memory free low-watermark processor 51796
!
!
!
redundancy
 mode sso
!
!
vlan configuration 14
!
!
!
interface Port-channel1
 description Trunk(LACP)
 switchport mode trunk
 spanning-tree portfast disable
!
interface GigabitEthernet0/0
 vrf forwarding Mgmt-vrf
 ip address 10.36.10.16 255.255.255.0
 speed 1000
 negotiation auto
!
interface GigabitEthernet1/0/1
 switchport access vlan 14
!
!
interface TenGigabitEthernet1/1/1
 switchport mode trunk
 channel-group 1 mode active
!
!
interface GigabitEthernet2/0/1
 switchport access vlan 14
!
!
interface TenGigabitEthernet2/1/1
 switchport mode trunk
 channel-group 1 mode active
!
interface TenGigabitEthernet3/1/1
 switchport mode trunk
 channel-group 1 mode active
!
!
interface GigabitEthernet4/0/1
 switchport access vlan 14
!
!
interface TenGigabitEthernet4/1/1
 switchport mode trunk
 channel-group 1 mode active
!
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
!
!
end

2. Mellanox LACP status:

core-02 [standalone: master] (config) # show interfaces port-channel summary 
Flags
    D: Down
    U: Up
    P: Up in port-channel (members)
    S: Suspend in port-channel (members)
    I: Individual

------------------------------------------------------------------------
Group Port-Channel   Type       Member Ports                            
------------------------------------------------------------------------
1 Po1(U)             LACP       Eth1/8/1(P) Eth1/8/2(P) Eth1/8/3(P) Eth1/8/4(P)
core-02 [standalone: master] (config) # show lacp interfaces ethernet 
1/1     1/10/4  1/11/4  1/12/4  1/13/4  1/14/4  1/15/4  1/16/4  1/5     1/8/2   1/9/2   
1/10/1  1/11/1  1/12/1  1/13/1  1/14/1  1/15/1  1/16/1  1/2     1/6     1/8/3   1/9/3   
1/10/2  1/11/2  1/12/2  1/13/2  1/14/2  1/15/2  1/16/2  1/3     1/7     1/8/4   1/9/4   
1/10/3  1/11/3  1/12/3  1/13/3  1/14/3  1/15/3  1/16/3  1/4     1/8/1   1/9/1   


core-02 [standalone: master] (config) # show lacp interfaces ethernet 1/8/1
Port: 1/8/1
Port State: Bundle
Channel Group: 1
Pseudo port-channel: Po1
LACP port-priority: 32768
LACP Rate: Slow
LACP Activity: Active
LACP Timeout: Short
Aggregation State: Aggregation, Sync, Collecting, Distributing, 

--------------------------------------------------------------
                    LACP Port  Admin   Oper   Port       Port
Port     State      Priority   Key     Key    Number     State
--------------------------------------------------------------
1/8/1    Bundle     32768      13826   13826  0x8        0x0     

core-02 [standalone: master] (config) # show lacp interfaces ethernet 1/8/2
Port: 1/8/2
Port State: Bundle
Channel Group: 1
Pseudo port-channel: Po1
LACP port-priority: 32768
LACP Rate: Slow
LACP Activity: Active
LACP Timeout: Short
Aggregation State: Aggregation, Sync, Collecting, Distributing, 

--------------------------------------------------------------
                    LACP Port  Admin   Oper   Port       Port
Port     State      Priority   Key     Key    Number     State
--------------------------------------------------------------
1/8/2    Bundle     32768      13826   13826  0x8        0x0     

core-02 [standalone: master] (config) # show lacp interfaces ethernet 1/8/3
Port: 1/8/3
Port State: Bundle
Channel Group: 1
Pseudo port-channel: Po1
LACP port-priority: 32768
LACP Rate: Slow
LACP Activity: Active
LACP Timeout: Short
Aggregation State: Aggregation, Sync, Collecting, Distributing, 

--------------------------------------------------------------
                    LACP Port  Admin   Oper   Port       Port
Port     State      Priority   Key     Key    Number     State
--------------------------------------------------------------
1/8/3    Bundle     32768      13826   13826  0x8        0x0     


core-02 [standalone: master] (config) # show lacp interfaces ethernet 1/8/4
Port: 1/8/4
Port State: Bundle
Channel Group: 1
Pseudo port-channel: Po1
LACP port-priority: 32768
LACP Rate: Slow
LACP Activity: Active
LACP Timeout: Short
Aggregation State: Aggregation, Sync, Collecting, Distributing, 

--------------------------------------------------------------
                    LACP Port  Admin   Oper   Port       Port
Port     State      Priority   Key     Key    Number     State
--------------------------------------------------------------
1/8/4    Bundle     32768      13826   13826  0x8        0x0     


core-02 [standalone: master] (config) # sh lacp counters 

Port-channel 1:
  -----------------------------------------------------------------------------------
  LACPDUs  Marker  Marker  Marker Rsp  Marker Rsp  LACPDUs  LACPDUs  Illegal  Unknown
  Port     Sent    Recv    Sent        Recv        Sent     Recv                     
  -----------------------------------------------------------------------------------
  1/8/1    0       0       0           0           265      236      0        0      
  1/8/2    0       0       0           0           169      150      0        0      
  1/8/3    0       0       0           0           168      153      0        0      
  1/8/4    0       0       0           0           179      148      0        0      

3. Test:

Connect my notebook (Static IP 10.36.14.100 on vlan 14) to port 1/0/1 (access port vlan 14), ping gateway 10.36.14.1 which is on core-02 failed. 

 

 

Can someone give me helps? Thanks a lot.

Everyone's tags (4)
2 REPLIES 2
VIP Expert

Re: Configure stacking 9200L with VLAN trunk

For testing can you use a single physical port (no portchannel) from each switch a test again?

Example:

1/1/1-----1/8/1

HTH

 

Beginner

Re: Configure stacking 9200L with VLAN trunk

I tried to config a single 10G port as trunk but it still not working. It may caused by the transceiver I am using (3rd party generic). When I make a 1G port as trunk then the traffic pass through fine. 

 

I am going to order the Cisco transceivers and test it again.

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards