cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
557
Views
0
Helpful
4
Replies

Configuring CISCO router 1801W

Marc Robat
Level 1
Level 1

Hello,

 

I'de like to replace the modem-router from my ISP by a CISCO router 1801w, can you help me for a good configuration please...?

Here you can find the configuration that I try, but it doesn't work...

 

Maximus#sh run
Building configuration...

Current configuration : 3535 bytes
!
version 12.4
service timestamps debug datetime
service timestamps log datetime
service password-encryption
!
hostname Maximus
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$5rA2$ZlJMZlWLEZGmUP8RUO9kV/
!
aaa new-model
!
aaa authentication login default local none
aaa authentication login console none
aaa authentication enable default none
!
aaa session-id common
clock timezone GMT+1 1
clock summer-time GMT+2_SUMMER recurring last Sun Mar 3:00 last Sun Oct 3:00
!
dot11 ssid ****
   vlan 1
   authentication open
   guest-mode
!
ip cef
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool DHCPSERV
   network 192.168.1.0 255.255.255.0
   dns-server 195.238.2.21 195.238.2.22
   default-router 192.168.1.1
!
ip domain name *****.local
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
multilink bundle-name authenticated
!
username maximus privilege 15 password 7 ***
!
archive
 log config
  hidekeys
!
bridge irb
!
interface FastEthernet0
 description Management and test
 ip address dhcp
 ip nat inside
 ip virtual-reassembly
 shutdown
 duplex auto
 speed auto
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface FastEthernet4
!
interface FastEthernet5
!
interface FastEthernet6
!
interface FastEthernet7
!
interface FastEthernet8
!
interface Dot11Radio0
 no ip address
 no ip route-cache cef
 no ip route-cache
 !
 ssid **
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 power local cck 15
 power local ofdm 15
 power client 17
 station-role root
 antenna receive right
 antenna transmit right
 antenna gain 2
!
interface Dot11Radio0.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no cdp enable
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Dot11Radio1
 no ip address
 no ip route-cache cef
 no ip route-cache
 !
 ssid **
 !
 speed basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0
 station-role root
 antenna receive right
 antenna transmit right
 antenna gain 2
!
interface Dot11Radio1.1
 encapsulation dot1Q 1 native
 no ip route-cache
 no cdp enable
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface ATM0
 no ip address
 ip nat inside
 ip virtual-reassembly
 no atm ilmi-keepalive
 pvc 8/35
  encapsulation aal5snap
 !
 dsl operating-mode auto
 bridge-group 1
 hold-queue 224 in
!
interface Vlan1
 no ip address
 bridge-group 10
!
interface BVI1
 ip address 91.176.**.*** 255.255.255.0 ==> static IP of my ISP ??? 
 ip nat outside
 ip virtual-reassembly
!
interface BVI10
 ip address 192.168.1.1 255.255.255.0 ==> IP CISCO 1801W
 ip nat inside
 ip virtual-reassembly
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 BVI1 ==> default network to BVI1 ??
!
no ip http server
no ip http secure-server
ip nat inside source list internal interface BVI1 overload
!
ip access-list extended internal
 permit ip 192.168.0.0 0.0.255.255 any
 permit ip 172.16.0.0 0.15.255.255 any
 permit ip 10.0.0.0 0.255.255.255 any
!
control-plane
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 10 protocol ieee
!
line con 0
 exec-timeout 0 0
 login authentication console
line aux 0
line vty 0 4
!
end

 

Do I must introduce the mac of the ISP's modem...?

If yes, where ?? And on which interface...?

 

Many thanks in advance.

 

Marc

 

4 Replies 4

Andre Neethling
Level 4
Level 4

How do you connect to your ISP? Is it via DSL, or Ethernet? I would reccrecommend using a routed interface to connect to your ISP if possible. 

Hello Andrée, it is via DSL.

what are the right commands to put in my config...?

ok...... I'll give you a config to try for your service provider link. and NAT, but I don't know what you have going on in your LAN or WLAN so I don't know if I can help there. See below.

interface ATM0
no ip address
no atm ilmi-keepalive
 pvc 8/35
    pppoe-client dial-pool-number 1
encapsulation aal5snap
dsl operating-mode auto
 

interface Dialer0
 ip address negotiated
 ip mtu 1492
 ip nat outside
 ip virtual-reassembly in
 encapsulation ppp
 ip tcp adjust-mss 1452
 dialer pool 1
 dialer-group 1

 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username <your username> password <your password>

 

Then you set your internal interfaces with the ip nat inside commands.

then set the NAT acl to match NAT traffic....

ip access-list extended internal
 permit ip 192.168.0.0 0.0.255.255 any
 permit ip 172.16.0.0 0.15.255.255 any
 permit ip 10.0.0.0 0.255.255.255 any

then use the following NAT command

ip nat inside source list internal interface Dialer0 overload

If the ATM0 config doesn't work, try this one.

interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto 

interface ATM0.1 point-to-point
 pvc 8/35 
  pppoe-client dial-pool-number 1

Review Cisco Networking for a $25 gift card