cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4444
Views
4
Helpful
13
Replies

connecting multiple servers with teamed NICs to 3750G stack

dtolstonogov
Level 1
Level 1

Hello,

I hope I can find some answers here! I am new to Cisco switches, they are pretty cool though... Here is my problem! Currently, in my testing environment, I have a stack of 2x brand new 3750G switches connected to each other via 2 StackWise cables. I have 2x DELL PowerEdge servers with Broadcom NICs installed. I would like to be able to connect these servers to the stack -- 1 NIC to Master and the other NIC to Member -- for the best performance and redundancy as well. So if one NIC or switch or port on the switch fails, the server can still be visible on the network.

I found some articles and how-to-dos online but still have questions!

So far I know that I need to create 2 etherchannels with LACP at both ends.

For SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan --- which VLAN#

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 1 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan --- which VLAN#

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 1 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

For SERVER-B:

switch#conf t

switch(config)#int Gi1/0/2

switch(config-if)#shutdown

switch(config-if)#description SERVER-B

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan --- which VLAN#

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 2 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/2

switch(config-if)#shutdown

switch(config-if)#description SERVER-B

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan --- which VLAN#

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 2 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

I guess I'm confused about VLANs! The default and only VLAN is 1. Which VLANs should I specify? Should I create a different VLAN for every etherchannel? Am I even doing it right? Because some examples have mode trunk instead of mode access but they all have a switch on each end.

Any suggetions or words of wisdom will be greatly appreciated!

Thanks,

Denis

2 Accepted Solutions

Accepted Solutions

yes, it should also create Port-Channel 1 and 2 interfaces automatically (if not, create it manually), and they'll have the same config as the physical interface (except for channel-group command)

if you want to maximize bandwidth look into port channel load balancing settings in IOS (and on the server side). There are different options. For example if you are doing SrcIp-DstIp, then traffic between these two servers will always take one of the two links on the first port channel and one of the two links on the second. If you have many clients accessing each server, then it should load balance because one of the two IPs in the packet will be different for each client. Unfortunately, 3750 doesn't support port channel load balancing based on src dst TCP/UDP ports like 6500's do.

Удачи!

View solution in original post

Hi,

   Active/active and Active/standby are the mode on the server that you want use.  VLAN is a subnet that you want to use for hosts/servers. Let's say you designed VLAN-10 for serverA and serverB. You just use "switchport mode access" and "switchport access vlan 10" on Cisco switch.  The difference is as follows:

Active/Standby

SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

Active/Active

SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#channel-group 1 mode active

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#channel-group 1 mode active

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

     No matter which mode you're using you need to assign a vlan to the servers anyway.

HTH,

Toshi

View solution in original post

13 Replies 13

Roman Rodichev
Level 7
Level 7

are you running vmware esxi on the servers?

No virtual software is installed on either server.

what OS are you running? Is "etherchannel" supported on the server side?

One is 2003 server and the other one is server 2008 R2. The NIC driver supports 802.3ad (LACP) and configured this way.

then your config is ok. If you don't have any VLANs, just use the default vlan 1.

You would only need trunking if you are going to configure VLAN tagging on the server side (very common in virtualized environment). So you probably don't need it and "mode access" is enough.

Thanks, Roman! Something like this:

For SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 1

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 1 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 1

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 1 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

For SERVER-B:

switch#conf t

switch(config)#int Gi1/0/2

switch(config-if)#shutdown

switch(config-if)#description SERVER-B

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 1

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 2 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/2

switch(config-if)#shutdown

switch(config-if)#description SERVER-B

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 1

switch(config-if)#spanning-tree portfast

switch(config-if)#channel-group 2 mode active

switch(config-if)#no shutdown

switch(config-if)#exit

yes, it should also create Port-Channel 1 and 2 interfaces automatically (if not, create it manually), and they'll have the same config as the physical interface (except for channel-group command)

if you want to maximize bandwidth look into port channel load balancing settings in IOS (and on the server side). There are different options. For example if you are doing SrcIp-DstIp, then traffic between these two servers will always take one of the two links on the first port channel and one of the two links on the second. If you have many clients accessing each server, then it should load balance because one of the two IPs in the packet will be different for each client. Unfortunately, 3750 doesn't support port channel load balancing based on src dst TCP/UDP ports like 6500's do.

Удачи!

Спасибо, Роман!!!

Hello  Dtolstonogov. i came across and am now in possession of one of your windows servers. I have full access to it and i am going to scrap it for parts. is there anything on the computers hard disk in which you want to be disposed of. I came across your server intel xeon pc at a scrap yard and took it home with me. it booted up and i have full access to it now so is there anything you want wiped from the hard drives because I'm going to be erasing and re formatting them for my own personal use

-emmettcr01@gmail.com

Hi,

   It depends on your design. If you want to go for active/standby on dell server, yes dell servers need to support this kind of configuration. You don't need to create channel-group on Cisco3750. Just plug the cables on both Cisco 3750 for each server . However, if you want to go for active/active on dell servers, you need to make sure that dell servers can bonding 2 NICs with LACP mode. And then go configure Cisco 3750 as your post.

HTH,

Toshi

Thanks, Toshi! It makes sense. I'd like to have active/active to increase the bandwidth but I'm confused about the configuration and VLANs. I guess if I don't figure it out, I'll have to stick with active/standby.

Hi,

   Active/active and Active/standby are the mode on the server that you want use.  VLAN is a subnet that you want to use for hosts/servers. Let's say you designed VLAN-10 for serverA and serverB. You just use "switchport mode access" and "switchport access vlan 10" on Cisco switch.  The difference is as follows:

Active/Standby

SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

Active/Active

SERVER-A

switch#conf t

switch(config)#int Gi1/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#channel-group 1 mode active

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

switch(config)#int Gi2/0/1

switch(config-if)#shutdown

switch(config-if)#description SERVER-A

switch(config-if)#switchport mode access

switch(config-if)#switchport access vlan 10

switch(config-if)#channel-group 1 mode active

switch(config-if)#spanning-tree portfast

switch(config-if)#no shutdown

switch(config-if)#exit

     No matter which mode you're using you need to assign a vlan to the servers anyway.

HTH,

Toshi

Thank you, Toshi!

Review Cisco Networking for a $25 gift card