cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
147
Views
0
Helpful
5
Replies
Beginner

Connecting through routed port on switch

For starters I'm using an IE 3010-16S-8PC switch and I am a beginner. I'm attempting to comm (remote desktop, ping, etc.) with a  piece of equipment that has a set ip address of 192.168.254.11 (this cannot change.) The equipment will only comm with the ip address 192.168.254.10 (also cannot change.) I configured the interface it is connected to with the .10 ip address and I can ping it from the switch, but not my PC. I can telnet into the switch and ping it from the switch when connected to the switch over just ethernet as well, but when I try to make direct connection from my PC I get nothing. I can't seem to figure out how to comm with a routed port from another whether it be part of a VLAN or another routed port. I tried adding ip routes, but that didn't work either. I appreciate any help and will add anything else if it helps. I've attached a txt file with my config.

Everyone's tags (2)
5 REPLIES 5
Highlighted
VIP Advisor

Re: Connecting through routed port on switch

what is your PC IP address and what port connected ?

 

here is simple config you can do example :

config t

!

vlan2

name vlan2

!

interface vlan 2

ip address 192.168.254.10 255.255.255.0

no shut down

 

interface FastEthernet0/17

switchport access vlan 2
switchport mode access

 

interface FastEthernet0/1

switchport access vlan 2
switchport mode access

 

your PC connect to Fas 0/1 with an ip address 192.168.254.XX 

 

 

 



 

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Connecting through routed port on switch

Preferably I'd like to have my PC on 192.168.101.50. We have other equipment in the .101 range and originally I just had a VLAN in that range, but I can't connect to both. Right now I'm connected to FA0/23, but that doesn't really matter.

VIP Advisor

Re: Connecting through routed port on switch

in that case you need to enable ( io routing)

 

interface FastEthernet0/23

switchport access vlan 1
switchport mode access

 

ip default-gateway 192.168.101.1   < --- this should point to uplink router if you one, this can be same local IP address in vlan 1.

 

once you do the above changes, you should able to communicate 192.168.101.X  to 192.168.254.X vice versa.

 

make sure this subnet is correct.

 

interface Vlan2
ip address 192.168.254.10 255.255.255.192

 

if you device is in 192.168.254.101 < they belong to different subnet

BB
*** Rate All Helpful Responses ***
Beginner

Re: Connecting through routed port on switch

The hosts are:

192.168.254.11

192.168.101.50

Even with the subnets set to: 192.168.254.10 and 192.168.101.1 respectively I can't ping even the .254 subnet from the .101 PC

I've pasted my config below

Disregard Vlan1, I moved the 101 address to Vlan2 just for ease of operation

.101 PC connected to FA0/19

.254 PC connected to FA0/23

 

interface FastEthernet0/17
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/18
!
interface FastEthernet0/19
switchport access vlan 2
switchport mode access
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
switchport access vlan 3
switchport mode access
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 192.168.102.1 255.255.255.0
!
interface Vlan2
ip address 192.168.101.1 255.255.255.0
!
interface Vlan3
ip address 192.168.254.10 255.255.255.0
!
ip default-gateway 192.168.101.1
ip http server
ip http secure-server
ip forward-protocol nd
ip route profile
ip route 0.0.0.0 0.0.0.0 192.168.101.0
ip route 192.168.101.0 255.255.255.0 192.168.254.0
ip route 192.168.254.0 255.255.255.0 192.168.101.0

VIP Advisor

Re: Connecting through routed port on switch

Basically you should be able to ping by enabling ip routing

 

change here as below

 

 

no ip default-gateway 192.168.101.1
no ip route profile   < you do not need for now, unti you doing some routing profile

ip routing

 

may be like to fine tune as below - some may not required, but no harm keeping them also.


ip route 0.0.0.0 0.0.0.0 192.168.101.1 
ip route 192.168.101.0 255.255.255.0 192.168.254.1
ip route 192.168.254.0 255.255.255.0 192.168.101.1

 

change above config, and ping let me know, if still not working post full config as below ;

 

show run

show ip route

show ip arp

show ip interface brief

show interface status | in connected

 

here is reference guide to configure

 

https://www.cisco.com/c/en/us/td/docs/switches/lan/cisco_ie3010/software/release/15-2_2_e/configuration/guide/SwCfg/swiprout.html#81681

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards