cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2381
Views
15
Helpful
3
Replies

Converting VLan configuration from HP ProCurve Switch 2510G-24 to Cisc

Hi, can anyone convert these Vlans configuration from HP switch to Cisco switch?? Cause I'm getting really confused about tagged untagged and no untagged on hp switch. I've been googling about that but still my brain did not get it.

vlan 1
name "DEFAULT_VLAN"
untagged 6,22
ip address dhcp-bootp
no untagged 1-5,7-21,23-24
exit
vlan 2
name "Lt.2"
tagged 1-2,4,6-7,10-11,17,20,22-24
exit
vlan 3
name "Lt.3"
tagged 1,3-4,6-7,10-11,17,20,22-24
exit
vlan 4
name "Lt.4"
untagged 5,8-9,12-14,17,21,23
tagged 1,4,6-7,10-11,20,22,24
exit

It's from backed up configuration with putty tho. Thanks for the help

3 Replies 3

Hello,

 

basically, on the HP, 'untagged' means host port, and 'tagged' means trunk. I have come up with the conversion below, not sure if it is all correct, but basically, if you look at this:

 

vlan 4
name "Lt.4"
untagged 5,8-9,12-14,17,21,23
tagged 1,4,6-7,10-11,20,22,24

 

That means ports 5,8-9,12-14,17,21,23 are access ports in Vlan 4. The tagged ports are trunk ports that carry Vlan 4.

 

interface GigabitEthernet0/1
switchport mode trunk
switchport trunk allowed vlan 2
!
interface GigabitEthernet0/2
switchport mode trunk
switchport trunk allowed vlan 2
!
interface GigabitEthernet0/3
switchport mode trunk
switchport trunk allowed vlan 3
!
interface GigabitEthernet0/4
switchport mode trunk
switchport trunk allowed vlan 2,3,4
!
interface GigabitEthernet0/5
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport mode access
switchport access vlan 1
!
interface GigabitEthernet0/7
switchport mode trunk
switchport trunk allowed vlan 2,3
!
interface GigabitEthernet0/8
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/9
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/10
switchport mode trunk
switchport trunk allowed vlan 2,3,4
!
interface GigabitEthernet0/11
switchport mode trunk
switchport trunk allowed vlan 2,3,4
!
interface GigabitEthernet0/12
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/13
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/14
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport mode access
!
interface GigabitEthernet0/16
switchport mode access
!
interface GigabitEthernet0/17
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport mode access
!
interface GigabitEthernet0/19
switchport mode access
!
interface GigabitEthernet0/20
switchport mode trunk
switchport trunk allowed vlan 2,3,4
!
interface GigabitEthernet0/21
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/22
switchport mode access
switchport access vlan 1
!
interface GigabitEthernet0/23
switchport mode access
switchport access vlan 4
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport mode trunk
switchport trunk allowed vlan 2,3,4
!
interface Vlan 1
ip address dhcp

 

Hello

 

Cisco 
conf t
vlan 2-11,17,20-24
exit

 

int vlan 1
ip address dhcp
no shut


access ports 5,8-9,12-14,17,21,23

int x/x
switchport host
switchport access vlan 4
no shut

 

int x/1
switchport mode trunk
switchport trunk allowed vlan 2,3,4

int x/2
switchport mode trunk
switchport trunk allowed vlan 1,2,4

int x/3
switchport mode trunk
switchport trunk allowed vlan 1,3

int x/4
switchport mode trunk
switchport trunk allowed vlan vlan 1-4

int ran x/6
switchport mode trunk
switchport trunk allowed vlan vlan 1-4

int ran x/7
switchport mode trunk
switchport trunk allowed vlan vlan 1-4

int ran x/10 -11
switchport mode trunk
switchport trunk allowed vlan vlan 1-4

int x/17
switchport mode trunk
switchport trunk allowed vlan vlan 1-4


int x/20
switchport mode trunk
switchport trunk allowed vlan vlan 1-4

int ran x/22 -24
switchport mode trunk
switchport trunk allowed vlan vlan 1-4


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Jerome BERTHIER
Level 1
Level 1

Hi

Please here few explanations on HPE vlan tagging rules :

https://techhub.hpe.com/eginfolib/networking/docs/switches/WB/15-18/5998-8156_wb_2926_atmg/content/ch01s02.html#s_VLAN_tagging_rules

To my understanding, "tagged" means that the port is configured as trunk and 801.Q tagged frames are accepted against vlans number matching the port config. "Untagged" means that 801.Q trunking is not applied. So, frames do not use vlan marking and are accepted to the vlan associated with the port.

"No untagged" means that this vlan is not usable as untagged traffic on port. I think that is a way to disable non tagged traffic on the port. On Cisco Catalyst, it is equivalent to disable the native vlan.

So, if we look at your HP configuration, Cisco equivalent for few ports would be (using equivalent port number on one Catalyst access switch) :

! port 1 - tagged on vlan 2-4 but no untagged on vlan 1

int git1/0/1
switchport mode trunk

! vlan 1 is not allowed so, as it is default native vlan, non tagged traffic will be dropped as HP config expect.
switchport trunk allowed vlan 2-4

 

! port 3 - tagged on vlan 3 but no untagged on vlan 1

int git1/0/3
switchport mode trunk

! vlan 1 is not allowed so, as it is default native vlan, non tagged traffic will be dropped as HP config expect.

switchport trunk allowed vlan 3

 

! port 5 - untagged vlan 4 (and no untagged vlan 1)

int git1/0/5
switchport mode access
switchport access vlan 4

 

! port 6 - tagged on vlan 2-4 but untagged on vlan 1

int git1/0/6
switchport mode trunk

! vlan 1 is allowed so, as it is default native vlan, non tagged traffic will be accepted as HP config expect.
switchport trunk allowed vlan 1-4

! next command is optionnal as vlan 1 is native per default

! switchport trunk native vlan 1

 

Moreover, you might add next commands depending your needs :

* on older Catalyst switches, set the type of trunking : switchport trunk encapsulation dot1q

* disable DTP to avoid port negociate its trunking state : switchport nonegotiate

* on a port facing a direct host, activate STP portfast to avoid convergence timers : spanning-tree portfast or spanning-tree portfast trunk (for tagged ports)

 

I'm not HP expert, so I hope to not be wrong.

Regards

Jérôme

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: