cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1692
Views
0
Helpful
5
Replies
Graham Murison
Beginner

Cross stack etherchannel 3650

I have setup a 2x 3650 stack. I tried to set up an etherchannel to two NetApp devices. NetApp only supports LACP.
I had setup the etherchannel but got the following errors:
Dec 27 14:18:15.057: %EC-5-L3DONTBNDL2: Gi1/0/1 suspended: LACP currently not enabled on the remote port.
Dec 27 14:18:20.409: %EC-5-L3DONTBNDL2: Gi1/0/3 suspended: LACP currently not enabled on the remote port.
Dec 27 14:22:36.795: %EC-5-CANNOT_BUNDLE2: Gi2/0/2 is not compatible with Po1 and will be suspended (trunk mode of Gi2/0/2 is dynamic, Po1 is trunk)
Dec 27 14:22:36.795: %EC-5-CANNOT_BUNDLE2: Gi2/0/4 is not compatible with Po1 and will be suspended (trunk mode of Gi2/0/4 is dynamic, Po1 is trunk)
Dec 27 14:22:36.836: %EC-5-CANNOT_BUNDLE2: Gi2/0/2 is not compatible with Po1 and will be suspended (trunk mode of Gi2/0/2 is dynamic, Po1 is trunk)
Dec 27 14:22:36.836: %EC-5-CANNOT_BUNDLE2: Gi2/0/4 is not compatible with Po1 and will be suspended (trunk mode of Gi2/0/4 is dynamic, Po1 is trunk)
Dec 27 14:22:36.875: %EC-5-CANNOT_BUNDLE2: Gi2/0/4 is not compatible with Po1 and will be suspended (trunk mode of Gi2/0/4 is dynamic, Po1 is trunk)

The configuration is:
interface GigabitEthernet1/0/1
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet2/0/2
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet1/0/3
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet2/0/4
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface Port-channel1
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate

I have done quite a bit of reading and it looks like I need to set the channel-group to 'on'.
I got the etherchannel working when connecting all ports to the same physical switch (A) in the stack using the below configuration when all four connection are connected to the same physical switch.

Is anyone in the know able to confirm if my configuration needs to be adjusted to allow the etherchannel across the stack?

Right now I have it working with the following config:
interface GigabitEthernet1/0/1
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet1/0/2
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet1/0/3
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface GigabitEthernet1/0/4
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate
channel-group 1 mode active
spanning-tree bpduguard enable
spanning-tree guard root
!
interface Port-channel1
switchport trunk allowed vlan 101,102
switchport mode trunk
switchport nonegotiate

5 REPLIES 5
Andrew Khalil
Rising star

Dear Graham,

Greetings, 

 

First, I don't understand the topology well! can you provide a diagram? 

Second, there is no need to configure the spanning-tree bpduguard and also the root guard on the physical interfaces, simply because when the physical interfaces are bundled, the STP is working on the port channel itself only! 

Third, for such an error, %EC-5-L3DONTBNDL2: Gi1/0/1 suspended: LACP currently not enabled on the remote port.

Please configure the following:

interface GigabitEthernet1/0/1 (also for others)

channel-protocol lacp
channel-group 1 mode on

 

please try it and let me know the results!

Best of luck, please don't forget to rate the helpful replies and mark it as  a solution if it has been helpful enough to solve your issues, it will be so nice from you! 

Bst Rgds,

Andrew Khalil

Andrew Khalil
Rising star

Hello again! 

If It will not work, I recommend, to clean this etherchannel configuration and reconfigure it as the following:

 

no int po 1

default interface range g1/0/1,3,g2/0/2,4

interface range g1/0/1,3,g2/0/2,4

shutdown

switchport mode trunk

switchport trunk allow vlan 101,102

switchport non

channel-prot lacp

channel-group 1 mode act

no shutdown

 

Usually, it's misconfig chronological sequence can cause such an error and it's a common issue!

I wish my reply will be helpful enough to solve it for you!

Bst Rgds!

Andrew Khalil

 

 

Ricky Sandhu
Beginner

Seems like a bug.  It's complaining that 2/0/2 etc. is set as dynamic which it doesn't appear to be.  What does it show when you look at the switchport config?

 

show interface gig2/0/2 switchport

 

Is this a new stack?  Try upgrading/downgrading the image.

 

.....AND this link just confirmed it.

https://www.theroutingtable.com/lacp-port-channel-member-ports-suspended/

 

Cheers~!

jalejand
Cisco Employee

On CAT3k platforms specially on Nova releases (3.x.x) there are a bunch of bugs in regards of LACP, this one for example:

https://bst.cloudapps.cisco.com/bugsearch/bug/CSCva22545/?rfs=iqvred

Try removing the nonegotiate parameter on all links. But first of all, attach a "show module" of your stack to confirm if there is no known bug for the release you are running.

Sorry for the delays, many fires to put out and not enough time! 

Thanks for the replies.  Looks like I may be dealing with a bug

 

#show module
Switch Ports Model Serial No. MAC address Hw Ver. Sw Ver.
------ ----- --------- ----------- -------------- ------- --------
1 52 WS-C3650-48TD-L FDO2031**** 00a6.cab8.2600 V04 03.06.05E
2 52 WS-C3650-48TD-L FDO2031**** 00a6.ca7e.5d00 V04 03.06.05E