11-18-2006 10:24 AM - edited 03-05-2019 12:54 PM
Is there a method of preventing a device with an IP address of 172.25.*.1 (* = any number) from being allowed on the network? The problem I am facing is the end user incorrectly configuring a device and using the .1 gateway address. We run DHCP and have multiple vlans.
I have thought about 802.1x but then all the devices must run a suplicant/client in order to connect and some devices are not capable of doing this.
the ideal solution would be the ability to detect the fraudulant gateway address on the edge port and disable the port.
11-19-2006 01:49 AM
what kind of switch do you use?
11-19-2006 10:40 PM
3548, 3550, 2950 & 2960's are the edge switches.
11-21-2006 03:48 AM
the best way to achive this would be to block ARP for hosts with this address. The below arp filter block ARP from hosts using the 172.25.X.1 range (on VLAN 1-100) but permits others. I think this syntax is correct but would suggest you test before using it!
arp access-list TEST
deny ip 172.25.0.1 0.0.255.0 mac any
permit ip any mac any
ip arp inspection filter TEST vlan 1-100
11-22-2006 08:53 AM
How about something like this?:
Switch(config)#ip access-list standard 50
Switch(config-std-nacl)#deny 172.25.0.0 0.0.255.255
Switch(config-std-nacl)#permit any
Switch(config)#int range fa0/1 - 24
Switch(config-if-range)#ip access-group 50 in
sh run... (example)
interface FastEthernet0/20
switchport access vlan 6
ip access-group 50 in
spanning-tree portfast
Placing an access-list on the router would be a better solution if you have access to the router or High End switch with a switching module like the 6509 series.
11-23-2006 12:33 AM
I don't think blocking all traffic on 172.16/16 is the solution. How will hosts send traffic (remember the hosts have source on this network).
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide