12-09-2009 09:11 AM - edited 03-06-2019 08:53 AM
How do I connect DeskTop/PC to a 3750 switch to support multiple VLAN and be able to ping a LO interface?
Can anyone advise me the best way to configure a (C3750 IPServices) IOS 12.2(25) to interface with a Desk Top doing .1Q tagging? And to be able to PING a LO once multiple VLAN’s are configured??
* With the below configuration connected, when I ping 10.2.1.1 (LO1) from the PC the switch see’s in the ARP table 10.2.1.255. Hence, does not echo ping back. So PING is unsuccessful not reaching the loop back interface. Seems the port or the NIC card are not functioning correct. This is where I am at now. Not getting much help from the Microsoft forums. The reason I am doing this is more complex, I am trying to set up virtual machines on a single PC with multiple VLANID’s but before I can even get to that, I cannot even get the PC to successfully ping a LO int by it self.
What I have done so far is this:
Windows XP Desk Top Config:
Configured VLAN (10.1.1.2) on PC running Win XP w/1gig NIC supports .1Q.
3750 Config:
Switch#sh run
Building configuration...
Current configuration : 1784 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
ip subnet-zero
ip routing
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback1
ip address 10.2.1.1 255.255.255.255
!
interface GigabitEthernet1/0/1 (this is the port PC is connected to)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2 ( I read somewhere that Access port will support multiple VLANs now. I am not sure about this maybe with VoIP and Data only please advise)
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.1.1.1 255.255.255.0
!
interface Vlan20
ip address 10.1.2.1 255.255.255.0
!
interface Vlan30
ip address 10.1.3.1 255.255.255.0
!
ip classless
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
End
12-09-2009 10:56 AM
Your issue is more PC related than it is network related.You're going to need to configure a routing interface on the 3750 to do subinterfaces and dot1q vlan ID's on each subinterface. It would, however make more sense to configure the interface connecting to the PC a trunk using dot1q. Then connect a router to the 3750 to handle all the subinterface vlan configurations.
12-09-2009 11:29 AM
i think i understood what you are trying to do.
if you want a pc connected to a trunk port on 3750 that can be achived however , the NIC card should support dot1q packets.
there are few NIC cards available in the market that understand dot1q tag.
if you dont have that type of nic then only native vlan will work on that trunk link as the native vlan packet goes untagged.
I have seen this working but i cant suggest you any NIC card you have to do some market research for the same.
regards,
Varun
12-09-2009 11:35 AM
briangrides wrote:
How do I connect DeskTop/PC to a 3750 switch to support multiple VLAN and be able to ping a LO interface?
Can anyone advise me the best way to configure a (C3750 IPServices) IOS 12.2(25) to interface with a Desk Top doing .1Q tagging? And to be able to PING a LO once multiple VLAN’s are configured??
* With the below configuration connected, when I ping 10.2.1.1 (LO1) from the PC the switch see’s in the ARP table 10.2.1.255. Hence, does not echo ping back. So PING is unsuccessful not reaching the loop back interface. Seems the port or the NIC card are not functioning correct. This is where I am at now. Not getting much help from the Microsoft forums. The reason I am doing this is more complex, I am trying to set up virtual machines on a single PC with multiple VLANID’s but before I can even get to that, I cannot even get the PC to successfully ping a LO int by it self.
What I have done so far is this:
Windows XP Desk Top Config:
Configured VLAN (10.1.1.2) on PC running Win XP w/1gig NIC supports .1Q.
3750 Config:
Switch#sh run
Building configuration...
Current configuration : 1784 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
ip subnet-zero
ip routing
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Loopback1
ip address 10.2.1.1 255.255.255.255
!
interface GigabitEthernet1/0/1 (this is the port PC is connected to)
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet1/0/2 ( I read somewhere that Access port will support multiple VLANs now. I am not sure about this maybe with VoIP and Data only please advise)
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
!
interface Vlan10
ip address 10.1.1.1 255.255.255.0
!
interface Vlan20
ip address 10.1.2.1 255.255.255.0
!
interface Vlan30
ip address 10.1.3.1 255.255.255.0
!
ip classless
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
End
Brian
Doesn't see a lot wrong with your config. Can you post a "sh interface trunk" from the 3750 switch please.
Jon
12-09-2009 12:21 PM
Have you considered using some of the
NIC teaming drivers available? Not sure what kind of NICs you have but both
Boradcom and Intel have NIC teaming drivers which support the 802.1Q tags. We use this with great success currently and it works good with a configuration like the one you have on your switch.. Not sure what virtualization software you are using but I seemed to remember something about using this team driver with the VMWare NIC virtualization drivers that made things not work. Would have to check though.
12-09-2009 02:03 PM
We used a Intel Gig Desktop adapter with the latest intel drivers.. This is per the LAN eng that had the PC. I was wondering if there may be an issue between the OS and NIC or drivers knowing how to manipulate the ping.
I suppose that teaming drivers are the same as the intel drivers? Or would there be additional software client to work WITH the Intel drivers for that manipulation???
I appriciate your response!!
Brian
12-09-2009 03:16 PM
Teaming drivers are now part of the regular driver installation, so you should be good there. I do not have a server that has this driver in it but with the latest install the configuration tool seemed to integrate into the device management in Windows. Then you could configure the VLANs for a team. If you have done all that then it should work. But you do actually have to configure the VLANs on the team and make sure the IDs match whats on your switch. Another idea would be to configure a native VLAN on the trunk port (switchport trunk native vlan
12-09-2009 02:24 PM
dlawson:
Eventually there will be a wan rtr inplace I am jsut trying to test the NIC and .1q at this time. Because eventually we will configure multiple virtual PC's on this one PC with their own VLAN and IP network. right now I cannot get this single vlan to ping or route through/inside the switch to a lo int.
Are you suggesting that I should create sub interfaces in my g1/0/1.1 and assign vlan 10 ip10.1.1.1 to it???
---------
Jon:
What is your thoughts about what Mr. Lawson is suggesting?
a far s the sh int trunk I am not connected to the DT at this time so will not get trunk info back. But when I did check the trunk while connected there was no errors we were up up.
--------
I appriciate all of your feedback!!!
12-09-2009 04:25 PM
briangrides wrote:
dlawson:
Eventually there will be a wan rtr inplace I am jsut trying to test the NIC and .1q at this time. Because eventually we will configure multiple virtual PC's on this one PC with their own VLAN and IP network. right now I cannot get this single vlan to ping or route through/inside the switch to a lo int.
Are you suggesting that I should create sub interfaces in my g1/0/1.1 and assign vlan 10 ip10.1.1.1 to it???
---------
Jon:
What is your thoughts about what Mr. Lawson is suggesting?
a far s the sh int trunk I am not connected to the DT at this time so will not get trunk info back. But when I did check the trunk while connected there was no errors we were up up.
--------
I appriciate all of your feedback!!!
Brian
You don't need to configure subinterfaces on either the 3750 or a router. You would use subinterfaces on a router if you did not have a L3 switch but as you do then you simply configure the port as a trunk port and create your L3 vlan interfaces which is exactly what you have done.
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide