02-23-2016 04:48 AM - edited 03-08-2019 04:41 AM
Hi all,
I'm trying to configure different DHCP pool on a Cisco 1841 router connected to a Cisco Catalyst 3750 switch, but DHCP seems to doesn't works...
I've created three VLAN on the switch 7-14-21 and three subinterface for FastEthernet 0/0 on router each with encapsulation dot1q referring to each vlan, so Fa0/0.7 Fa0/0.14 Fa0/0.21 and set default router to each subinterface according to DHCP pool, but device connected to the switch don't receive IP addresses.Does anyone could help me to check this issue ? Here the configuration:
R1841#sh running-config
Building configuration...
Current configuration : 3612 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1841
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YL73$DZPkNN4SsF3C.4PzBmXU1/
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.96.8.246
ip dhcp excluded-address 10.96.8.245
ip dhcp excluded-address 10.136.12.250
ip dhcp excluded-address 10.136.12.249
ip dhcp excluded-address 10.135.100.190
ip dhcp excluded-address 10.135.100.189
!
ip dhcp pool LAN
network 10.96.8.0 255.255.255.248
default-router 10.96.8.246
dns-server 8.8.8.8 8.8.4.4
lease 0 8
!
ip dhcp pool Static-Wifi
host 10.135.100.1 255.255.255.192
client-identifier 01d4.c9ef.54d7.4b
dns-server 8.8.8.8 8.8.4.4
default-router 10.135.100.190
!
ip dhcp pool WiFi
network 10.135.100.0 255.255.255.192
dns-server 8.8.8.8 8.8.4.4
default-router 10.135.100.190
lease 0 1
!
ip dhcp pool Static-LAN
host 10.96.8.1 255.255.255.248
client-identifier 0178.24af.889c.a8
dns-server 8.8.8.8 8.8.4.4
default-router 10.96.8.246
!
ip dhcp pool VLan1
network 10.10.10.0 255.255.255.0
default-router 10.96.8.246
dns-server 8.8.8.8 8.8.4.4
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/0.7
description Default Gateway Vlan 7 - LAN / Nat Inside
encapsulation dot1Q 7
ip address 10.96.8.246 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface FastEthernet0/0.14
description Default Gateway Vlan 14 - NAS / No Nat Inside
encapsulation dot1Q 14
ip address 10.136.12.250 255.255.255.252
!
interface FastEthernet0/0.21
description Sub-interface Default Gateway Vlan 21 - WiFi / Nat Inside
encapsulation dot1Q 21
ip address 10.135.100.190 255.255.255.192
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1/0
duplex full
speed 100
!
interface FastEthernet0/1/1
duplex full
speed 100
!
interface FastEthernet0/1/2
duplex full
speed 100
!
interface FastEthernet0/1/3
description Trunk per Access Point WiFi
switchport mode trunk
duplex full
speed 100
!
interface ATM0/0/0
no ip address
no ip route-cache cef
no ip route-cache
no ip mroute-cache
atm restart timer 300
no atm ilmi-keepalive
atm pppatm link reset
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0/0/0.1 point-to-point
no ip route-cache
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Vlan1
description Interface VLAN1
ip address 10.10.10.10 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface Dialer0
ip address negotiated
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username User password 0 password
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0
password pwd
login
line vty 1 4
login
!
scheduler allocate 20000 1000
end
Configurazione Switch 3750:
Switch#sh running-config
Building configuration...
Current configuration : 3180 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname Switch
!
!
no aaa new-model
switch 1 provision ws-c3750-24p
ip subnet-zero
!
!
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
interface FastEthernet1/0/1
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/2
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/3
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/4
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/5
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/6
switchport access vlan 7
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/7
switchport access vlan 7
duplex full
speed 100
!
interface FastEthernet1/0/8
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/9
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/10
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/11
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/12
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/13
switchport access vlan 14
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/14
switchport access vlan 14
duplex full
speed 100
!
interface FastEthernet1/0/15
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/16
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/17
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/18
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/19
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/20
switchport access vlan 21
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/21
switchport access vlan 21
duplex full
speed 100
!
interface FastEthernet1/0/22
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/23
shutdown
duplex full
speed 100
!
interface FastEthernet1/0/24
description Trunk
switchport trunk encapsulation dot1q
switchport mode trunk
duplex full
speed 100
!
interface GigabitEthernet1/0/1
shutdown
!
interface GigabitEthernet1/0/2
shutdown
!
interface Vlan1
no ip address
!
interface Vlan7
description Interface Vlan 7 - Management Vlan LAN
ip address 10.96.8.245 255.255.255.248
!
interface Vlan14
description Interface Vlan 14 - Management Vlan NAS
ip address 10.136.12.49 255.255.255.252
!
interface Vlan21
description Interface Vlan 21 - Management WiFi
ip address 10.135.100.189 255.255.255.192
!
ip default-gateway 10.96.8.246
ip classless
ip http server
ip http secure-server
!
!
!
!
!
control-plane
!
!
line con 0
line vty 0
password pwd
login local
line vty 1 4
no login
line vty 5 15
no login
!
!
end
Switch#
Thanks!
Solved! Go to Solution.
02-23-2016 02:05 PM
Your LAN DHCP pool is misconfigured.
Change this -
"network 10.96.8.0 255.255.255.248"
to -
"network 10.96.8.240 255.255.255.248"
Jon
02-23-2016 05:15 AM
Hi
There is no requirement for layer 3 vlans on a layer 2 switch , only 1 svi is required for mgmt. purposes and reachability
on your switch turn on dhcp
no service dhcp
service dhcp
02-23-2016 05:51 AM
Hi,
so I've to remove interface for Vlan 7-14-21 and set only Vlan 1 and to start DHCP service on 3750 switch, right ?
Thanks
02-23-2016 05:56 AM
Hey It shouldn't be a requirement but its best practice to only have a mgmt. vlan on your layer 2 switch not multiple layer 3 ints , your telling switch my default gateway is 10.96.8.246 but then there is a closer layer 3 ip on its switch configured in same subnet , dhcp being turned off could be causing it as well
Just trying to fix what I see wrong at first look and then if problem is still there after can look deeper and what might be the cause
vlan 1 should be a sub interface like the other as well to keep it consistent as well f0/0.1
good guide for your design
http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/336-cisco-router-8021q-router-stick.html
02-23-2016 07:43 AM
You could test the fix on this easy enough by shutting vlan 7 on the switch only it will not effect traffic for that subnet then turn on dhcp and connect a device up see then if you get the ip address
02-23-2016 12:00 PM
HI,
issue is still there... -.-''
Here the new configuration:
Router 1841:
02-23-2016 12:00 PM
From the switch -
"sh int trunk"
and I assume you have connected fa01/0/24 to fa0/0 on the router ?
Jon
02-23-2016 01:46 PM
Hi,
yes FA1/0/24 is connected to Fa0/0
Here command output:
02-23-2016 02:05 PM
Your LAN DHCP pool is misconfigured.
Change this -
"network 10.96.8.0 255.255.255.248"
to -
"network 10.96.8.240 255.255.255.248"
Jon
02-23-2016 02:27 PM
Hi,
I've change network to 10.96.8.240 255.255.255.248 and nothing changed
I've tried to set network 10.96.8.0 255.255.255.0 and it works fine.
But checking network originally set 10.96.8.0 255.255.255.248 first address should be 10.96.8.1 last 10.96.8.6
http://mxtoolbox.com/subnet/?filter=10.96.8.0/29&source=subnettool
why it doesn't works ?
Other question after changed network to 10.96.8.0 255.255.255.0 my pc receive the IP address but it was not able to go to internet... but this topic next thread; now I've to solve DHCP.
Thanks to all for support to a student :)
02-23-2016 04:03 PM
Solved!!!!
It works :)
Here the correct DHCP pool configuration:
R1841#sh running-config
Building configuration...
Current configuration : 3765 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1841
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YL73$DZPkNN4SsF3C.4PzBmXU1/
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.135.100.62
ip dhcp excluded-address 10.10.11.254
ip dhcp excluded-address 10.96.8.6
!
ip dhcp pool LAN
network 10.96.8.0 255.255.255.248
default-router 10.96.8.6
dns-server 8.8.8.8 8.8.4.4
lease 0 8
!
ip dhcp pool Static-Wifi
host 10.135.100.1 255.255.255.192
client-identifier 01d4.c9ef.54d7.4b
dns-server 8.8.8.8 8.8.4.4
default-router 10.135.100.62
!
ip dhcp pool WiFi
network 10.135.100.0 255.255.255.192
dns-server 8.8.8.8 8.8.4.4
default-router 10.135.100.62
lease 0 1
!
ip dhcp pool WiFi-Vlan1
network 10.10.11.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
default-router 10.10.11.254
lease 0 3
!
ip dhcp pool VLan1
network 10.10.10.0 255.255.255.0
default-router 10.10.11.254
dns-server 8.8.8.8 8.8.4.4
!
ip dhcp pool Static-LAN
host 10.96.8.1 255.255.255.248
client-identifier 0178.24af.889c.a8
dns-server 8.8.8.8 8.8.4.4
default-router 10.96.8.6
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
vpdn enable
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.11.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/0.7
description Default Gateway Vlan 7 - LAN / Nat Inside
encapsulation dot1Q 7
ip address 10.96.8.6 255.255.255.248
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface FastEthernet0/0.14
description Default Gateway Vlan 14 - NAS / No Nat Inside
encapsulation dot1Q 14
ip address 10.136.12.3 255.255.255.252
!
interface FastEthernet0/0.21
description Sub-interface Default Gateway Vlan 21 - WiFi / Nat Inside
encapsulation dot1Q 21
ip address 10.135.100.62 255.255.255.192
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1/0
duplex full
speed 100
!
interface FastEthernet0/1/1
duplex full
speed 100
!
interface FastEthernet0/1/2
duplex full
speed 100
!
interface FastEthernet0/1/3
description Trunk per Access Point WiFi
switchport mode trunk
duplex full
speed 100
!
interface ATM0/0/0
no ip address
no ip route-cache cef
no ip route-cache
no ip mroute-cache
atm restart timer 300
no atm ilmi-keepalive
atm pppatm link reset
bundle-enable
dsl operating-mode auto
hold-queue 224 in
!
interface ATM0/0/0.1 point-to-point
no ip route-cache
pvc 8/35
pppoe-client dial-pool-number 1
!
!
interface Vlan1
description Interface VLAN1
ip address 10.10.10.10 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1410
no ip mroute-cache
!
interface Dialer0
ip address negotiated
no ip proxy-arp
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication pap callin
ppp pap sent-username user password 0 pwd
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0
password pwd
login
line vty 1 4
login
!
scheduler allocate 20000 1000
end
R1841#
02-23-2016 04:03 PM
Glad to hear you got it working :)
Jon
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide