03-18-2008 06:38 AM - edited 03-05-2019 09:49 PM
Is it possible to handle via a local IP DHCP configuration on a 3560 switch any DHCP option e.g. #242 with the necessary information(s) in a string (like 'MCIPADD=192.168...etc.')?
10-23-2015 12:40 PM
Dynamic Host Configuration Protocol (DHCP) can be configured either on a server or on the router. In many cases, the main site DHCP server may already have the correct scope and configuration for option 176 or 242 as needed. Since remote sites may not warrant the added expense of a server, the DHCP option commands can be configured on that remote site's router. DHCP options are vendor-specific. There is no single document I've found that addresses all the issues I'm going to cover here, so comments are more than welcome. I noticed this is an 8-year old thread.
Keep in mind that VLAN separation is a fundamental best practice on the LAN that also defines the relationship between the switch and local router. Do not enable IP routing on your switches even if they have that capability. Keep in mind that minimizing data loss, jitter and delay are critical for voice applications. Avoid technologies that are historically unfriendly to voice, such as VPN, or GLBP.
The network and phone systems should be properly configured with time synchronization, such as Cisco's Network Time Protocol (NTP). Also, make sure you're on the same page with the phone engineers regarding timezones. Here's an example if you're in the US Midwest:
clock timezone CST -6
clock summer-time CDT recurring
Avaya 4600 Series phones use Option 176 as the default DHCP Site Specific Option Number (SSON) with TFTP or HTTP. The 1600 and 9600 Series phones use Option 242 with HTTP or TLS. Both IP telephones use these servers as file servers, to download firmware and access scripts or settings files.
Avaya uses a 46xxsettings.txt file that contains everything. The generic 46xxsettings.txt file is available for download from Avaya. That file resides on an Avaya server and your routers need to point to that server. Avaya engineers know how to tweak this file if necessary.
Router configuration example (first, reserve the IPs you don't want assigned via DHCP):
ip dhcp excluded-address 172.31.70.1 172.31.70.4
ip dhcp excluded-address 172.31.70.251 172.31.70.255
DHCP configuration with DHCP option 242:
ip dhcp pool VoIP
network 172.31.70.0 255.255.255.0
default-router 172.31.70.254
domain-name yourcompany.com
option 242 ascii MCIPADD=[up to eight Avaya Call server IPs],MCPORT=1719,HTTPSRVR=[IP of Avaya HTTP server],HTTPDIR=[directory where the 46xxsettings.txt file resides]
If you have a supplicant set up (wall jack -> IP phone -> PC), include the L2QVLAN because the phone will boot in the data VLAN; tell the IP phone to hop over to the VoIP VLAN:
option 242 ascii MCIPADD=[up to eight Avaya Call server IPs],MCPORT=1719,HTTPSRVR=[IP of Avaya HTTP server],HTTPDIR=[directory where the 46xxsettings.txt file resides],L2QVLAN=70
If you also have older Avaya phones, include the DHCP option 176:
option 176 ascii MCIPADD=[up to eight Avaya Call server IPs],MCPORT=1719,TFTPSRVR=[IP of Avaya TFTP server],TFTPDIR=[directory where the 46xxsettings.txt file resides],L2QVLAN=70
So, why up to eight Avaya Call servers in the MCIPADD option? Generally, you have a main site, so the first IP address will be the same for all your remote sites. That first address is your main, central, call server. If you have backup Avaya servers at a remote site, list the remaining IP address(es) - separated by a comma.
Note: if you do not manually configure the L2QVLAN setting, it may revert to your default VLAN. That may be undesirable.
Subinterface (to keep things simple, use the same number in your IP, subinterface, and VLAN):
interface GigabitEthernet0/2.70
encapsulation dot1Q 70
ip address 172.31.70.254 255.255.255.0
no shutdown
Switch configuration:
disable cdp globally (cdp is not friendly to many non-Cisco IP phones)
enable lldp for switchports connected to Avaya devices for 802.1x
enable qos
Configure separate VLANs for voice and data separation:
Vlan 3
name DATA
interface Vlan3
description DATA
ip address 192.168.3.1 255.255.255.0
no shutdown
Vlan 70
name VOICE
interface Vlan70
description VOICE
ip address 172.31.70.2 255.255.255.0
shutdown
Switchport configuration (VoIP VLAN only):
standalone IP phone:
interface GigabitEthernet0/1
switchport mode access
switchport access vlan 70
switchport nonegotiate
mls qos trust dscp
priority-queue out
Trunk or uplink
interface GigabitEthernet0/52
description [uplink - router or another switch]
switchport trunk allowed vlan 3,70
switchport mode trunk
switchport nonegotiate
mls qos trust dscp
priority-queue out
IP phone supplicant configuration (VoIP & data vlans):
interface GigabitEthernet0/1
switchport mode access
switchport access vlan 3
switchport voice vlan 70
mls qos trust dscp
priority-queue out
Helpful Avaya documents (yes, they're old, but provide thorough explanations):
http://downloads.avaya.com/css/P8/documents/100057468
https://downloads.avaya.com/css/P8/documents/100145934
https://downloads.avaya.com/elmodocs2/security/802_1x-LLDP.pdf
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide