cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2521
Views
20
Helpful
16
Replies

Dhcp + vlan configuration

black.robber
Level 1
Level 1

According to the diagram, i wanna make R3 a dhcp server and provide ip addresses to different vlans,

vlan 10 is on PC1 and PC4 and network address is 192.168.1.0

vlan 20 is on PC2 and PC5 and network address is 192.168.2.0

vlan 30 is on PC3 and PC6 and network address is 192.168.3.0

what should i do to pass the dhcp broadcast from R1 and R2  and reach R3 and R3 provide the ip addresses to vlan and their PCs?

1 Accepted Solution

Accepted Solutions

blau grana
Level 7
Level 7

Hello Muhammad,

Configure DHCP pools on R3 router. Configure ip helper-address 200.1.2.3 on R1 LAN interface. R2 does not need any configuration.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

View solution in original post

16 Replies 16

blau grana
Level 7
Level 7

Hello Muhammad,

Configure DHCP pools on R3 router. Configure ip helper-address 200.1.2.3 on R1 LAN interface. R2 does not need any configuration.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

this is what i have done

R3

R3(config)#ip dhcp pool vlan10

R3(dhcp-config)#network 192.168.1.0 255.255.255.0

R3(dhcp-config)#default-router 192.168.1.1

R3(dhcp-config)#exit

R3(config)#ip dhcp pool vlan20

R3(dhcp-config)#network 192.168.2.0 255.255.255.0

R3(dhcp-config)#default-router 192.168.2.1

R3(dhcp-config)#exit

R3(config)#ip dhcp pool vlan30

R3(dhcp-config)#network 192.168.3.0 255.255.255.0

R3(dhcp-config)#default-router 192.168.3.1

R3(dhcp-config)#exit

and

R1

R1(config-subif)#int fa0/0.10
R1(config-subif)#ip helper-address 200.1.2.3

R1(config-subif)#int fa0/0.20

R1(config-subif)#ip helper-address 200.1.2.3

R1(config-subif)#int fa0/0.30

R1(config-subif)#ip helper-address 200.1.2.3

what am i missing?

Hi,

did you configure a route for each remote vlan on the dhcp server as well as on the other router linked to R3 ?

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

hi alain

i have no idea how to do it, would you like to explain it more?

thanks

Hello Muhammad,

What Alain meant is, R3 must have routes for all VLANs in routing table, can you check this?

Reason for this is that when R1 receive DHCP request on some of the subinterfaces, R1 will send this request as unicast packet to R3 (destionation IP address 200.1.2.3 - source IP address of interface where request was received, for vlan 10 it will be 192.168.1.1). But if R3 router do not have route back to 192.168.1.1, DHCP reply can not be delivered.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

hi grana

i check all three router and all the routes are ok..

          now whats is wrong with this?

and thanks for the reply

Hi,

post your configs.

Regards

Alain

Don't forget to rate helpful posts.

Don't forget to rate helpful posts.

abel.ortgea
Level 1
Level 1

Hi
I think you have almost do it, you have the sub interfaces configured, only if check on your routing table that you have the networks you need, for example if you are using EIGRP
# router EIGRP 10
# network 192.168.10.0 0.0.0.255
and all the others you need

In your switches L2 check that you have create the vlans you need (10, 20, etc), corresponding to each sub interface
if you manage a native vlan also put it on your switch L2, if not only check the switch port is mode trunk


Sent from Cisco Technical Support iPad App

Also check you encapsulation o each interface
Must switches has encapsulation Dot1q by default, but check it
I. The sub interfaces on the router check them, encapsulation dot1q vlan#

Regards

Sent from Cisco Technical Support iPad App

black.robber
Level 1
Level 1

on R3
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.3.1
!
ip dhcp pool vlan10
network 192.168.1.0 255.255.255.0
default-router 192.168.1.254
ip dhcp pool vlan20
network 192.168.2.0 255.255.255.0
default-router 192.168.2.254
ip dhcp pool vlan30
network 192.168.3.0 255.255.255.0
default-router 192.168.3.254
!
interface FastEthernet0/0
ip address 192.168.4.254 255.255.255.0
ip nat inside
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 200.1.2.3 255.255.255.0
ip nat outside
clock rate 64000
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 192.168.4.0
network 200.1.2.0
!
ip nat inside source list 1 interface Serial0/2/0 overload
ip classless
ip route 192.168.5.0 255.255.255.0 Serial0/2/0
ip route 200.1.11.0 255.255.255.0 Serial0/2/0
ip route 200.1.12.0 255.255.255.0 Serial0/2/0
ip route 200.1.13.0 255.255.255.0 Serial0/2/0
ip route 200.1.14.0 255.255.255.0 Serial0/2/0
ip route 192.168.1.0 255.255.255.0 Serial0/2/0
ip route 192.168.2.0 255.255.255.0 Serial0/2/0
ip route 192.168.3.0 255.255.255.0 Serial0/2/0
!
access-list 1 permit 192.168.4.0 0.0.0.255
!

on R1
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.1.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 192.168.2.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/0.30
encapsulation dot1Q 30
ip address 192.168.3.254 255.255.255.0
ip nat inside
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/2/0
ip address 200.1.1.1 255.255.255.0
ip nat outside
clock rate 64000
!
interface Serial0/2/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 200.1.1.0
!
ip nat inside source list 1 interface Serial0/2/0 overload
ip classless
ip route 192.168.5.0 255.255.255.0 Serial0/2/0
ip route 200.1.11.0 255.255.255.0 Serial0/2/0
ip route 200.1.12.0 255.255.255.0 Serial0/2/0
ip route 200.1.13.0 255.255.255.0 Serial0/2/0
ip route 200.1.14.0 255.255.255.0 Serial0/2/0
ip route 200.1.2.0 255.255.255.0 Serial0/2/0
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
access-list 1 permit 192.168.3.0 0.0.0.255
!

Muhammad, you said that you configured ip helper-address on subinterfaces, but it is not there.

R1(config-subif)#int fa0/0.10
R1(config-subif)#ip helper-address 200.1.2.3

R1(config-subif)#int fa0/0.20

R1(config-subif)#ip helper-address 200.1.2.3

R1(config-subif)#int fa0/0.30

R1(config-subif)#ip helper-address 200.1.2.3

Also I am not sure about NAT configuration, if this would not cause problems, I need to check this first.

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

hello blau grana,

yah sorry that was wrong copy but beleve me its there..

did you check it with nat?

Hello Muhammad,

NAT should not be a problem. Can you provide output of these commands? Are you sure that you have connectivity?

R1# ping 200.1.2.3 source Fa0/0.10

R1# ping 200.1.2.3 source Fa0/0.20

R1# ping 200.1.2.3 source Fa0/0.30

Try these debugs to see if some DHCP requests are received by R3.

R3# debug ip dhcp server events

R3# debug ip dhcp server packet

Best Regards

Please rate all helpful posts and close solved questions

Best Regards Please rate all helpful posts and close solved questions

hye blau grana

non of these commands are working here and they are showing "Invalid input detected"

and thanks for you time that you making to reply me

Review Cisco Networking for a $25 gift card