cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
817
Views
10
Helpful
3
Replies
Highlighted
Beginner

Directed Broadcasting not working

I am attempting to configure broadcasting from network segment to another.  This has been working in the past but since we upgrade some technology (from unix to Windows platforms) it is not working.

Essentially I want UDP traffic on port 3000 which originates from IP 172.20.1.4/16 to be received by host 192.168.25.107.  Both are connected directly to a 1941 Router.

I have attempted many configuration changes, with no luck.  Here is my current configuration:

interface GigabitEthernet0/0
ip address 172.20.1.1 255.255.0.0
ip directed-broadcast 103
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1
ip address 192.168.250.40 255.255.255.0
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/0/0
ip address 192.168.25.1 255.255.255.0
ip access-group 102 in
ip helper-address 172.20.1.4
ip directed-broadcast 103
ip accounting output-packets
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/1/0
ip address 192.168.102.1 255.255.255.0
ip access-group 109 in
duplex auto
speed auto
no cdp enable
!
ip forward-protocol nd
ip forward-protocol udp 3000
!
no ip http server
no ip http secure-server
!
ip route profile
!
access-list 101 permit tcp host 10.2.0.97 any eq 3310
access-list 101 permit udp host 10.2.0.97 any eq 3310
access-list 101 permit icmp any any
access-list 101 deny ip any any
access-list 102 permit udp 192.168.25.0 0.0.0.255 any eq 3000
access-list 102 permit icmp any any
access-list 102 deny ip any any
access-list 103 permit udp host 172.20.1.4 any eq 3000
access-list 108 permit udp host 192.168.101.10 any eq 3320
access-list 108 permit tcp host 192.168.101.10 any eq 3320
access-list 108 permit icmp any any
access-list 108 deny ip any any
access-list 109 permit udp host 192.168.102.10 any eq 3320
access-list 109 permit tcp host 192.168.102.10 any eq 3320
access-list 109 permit icmp any any
access-list 109 deny ip any any
access-list 120 permit ip any any
access-list 122 permit udp 192.168.25.0 0.0.0.255 any eq 3000
access-list 122 permit icmp any any
access-list 123 permit udp host 172.20.1.4 any eq 3000
access-list 133 permit ip host 172.20.1.4 192.168.25.0 0.0.0.255
no cdp run
!
!
!
control-plane
!
!
!
!
end

Any ideas?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

You are certainly on the right track and most of your config is ok. To support what you are trying to do with directed broadcast you need three things in your config:

1) you need the ip forward-protocol udp 3000  

2) you need the ip helper-address to forward the broadcasts

3) you need the ip directed-broadcast to allow forwarding of the broadcasts.

You biggest problem is that your helper address is on the wrong interface and that it specifies the wrong address. The helper address is configured on the interface where the broadcasts will be originated. In your case that would be on Gig0/0 and not on Gig0/0/0. Also helper address specifies where the broadcast would be forwarded and in your case that would be 192.168.25.255. If you fix this then directed broadcast should work.

I see that you have ip directed-broadcast configured on Gig0/0. You do not need it there. It does no harm to have it, but it does no good either. directed broadcast is only needed on interfaces which will receive directed broadcast and needs to forward the packet as a local broadcast.

HTH

Rick

HTH

Rick

View solution in original post

3 REPLIES 3
Highlighted
Hall of Fame Guru

You are certainly on the right track and most of your config is ok. To support what you are trying to do with directed broadcast you need three things in your config:

1) you need the ip forward-protocol udp 3000  

2) you need the ip helper-address to forward the broadcasts

3) you need the ip directed-broadcast to allow forwarding of the broadcasts.

You biggest problem is that your helper address is on the wrong interface and that it specifies the wrong address. The helper address is configured on the interface where the broadcasts will be originated. In your case that would be on Gig0/0 and not on Gig0/0/0. Also helper address specifies where the broadcast would be forwarded and in your case that would be 192.168.25.255. If you fix this then directed broadcast should work.

I see that you have ip directed-broadcast configured on Gig0/0. You do not need it there. It does no harm to have it, but it does no good either. directed broadcast is only needed on interfaces which will receive directed broadcast and needs to forward the packet as a local broadcast.

HTH

Rick

HTH

Rick

View solution in original post

Highlighted

Richard,

You are a beautiful man!

Thank you.

Highlighted

I am glad that my explanation was helpful. Thank you for using the rating system to mark this question as answered. This will help other readers in the forum to recognize discussions that have helpful information.

HTH

Rick

HTH

Rick
Content for Community-Ad