cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14627
Views
35
Helpful
4
Replies

Disabling DTP for 3550 switcport access

samisalim
Beginner
Beginner

As you all know, the ports in the 3550s comes with DTP enabled. I have gone through the messages posted in this group in last Nov. 23rd. The recommended solution to configure the port to "switchport nonegotiate" didn't work. I do get the message "Command rejected: Conflict between 'nonegotiate' and 'dynamic' status"

Please see the initial config. and the response to the command"-

!

interface GigabitEthernet0/2

switchport access vlan 20

switchport mode dynamic desirable

shutdown

end

sw2#conf t

Enter configuration commands, one per line. End with CNTL/Z.

sw2(config)#int gi0/2

sw2(config-if)#switchport nonegotiate

Command rejected: Conflict between 'nonegotiate' and 'dynamic' status.

sw2(config-if)#

4 Replies 4

konigl
Rising star
Rising star

If you want to disable DTP, you have to first specify the trunking status on a port manually: either "switchport mode access" or "switchport mode trunk". Then you can issue the "switchport nonegotiate" command.

The "switchport nonegotiate" command is valid only when the interface switchport mode is access or trunk. This command returns an error message if you attempt to execute it in dynamic (auto or desirable) mode.

When you use the "switchport mode dynamic desirable" or "switchport mode dynamic auto" commands on an interface, you are telling the switch to autonegotiate the trunk status on that interface. Trunk negotiation is managed by the Dynamic Trunking Protocol (DTP).

When you try to run "switchport nonegotiate" on a dynamic trunking port, you're telling the switch to NOT use DTP, the protocol that it needs to use to determine trunking status. That's why you get the error.

Thank you very much. Your input is proven working.

This is correct and if you want to change the to trunk mode back to 'dynamic auto' or 'dynamic desirable' first you have to disable the 'switchport nonegotiate' by typing 'no switchport nonegotiate' within the interface configuration, and then change to dynamic auto or desirable by writing 'switchport mode dynamic auto' or 'switchport mode dynamic desirable' respectively. 

To check for options incase you dont remember the commands press 'switchport mode ?'

Paul Webster
Beginner
Beginner

Greetings .. the best way to disable DTP on a cisco port is:

switchport mode access
switchport nonegotiate
and then.....
switchport access vlan 20

Access ports do not handle DTP.

Recall that DTP is a proprietary protocol for trunk handling .. and will always try to raise a trunk, Cisco in various documents recommends disabling it if not in use and forcing the trunk ports with the respective command.

PAWP
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers